locked
Deploying reports -- permission error sharepoint\system RRS feed

  • Question

  • Hi,

    Iam having sharepoint server as a separeate box and sql as separate box.

     

    When deploying reports from ssrs it gives me error sharepoint\system have insufficient permissions

    Pls help me on this..

    Thanks

    krishna

     

    Wednesday, May 25, 2011 8:19 AM

Answers

  • Hi krishna,

     

    This error can be caused when Kerberos authentication has been set up correctly and delegation in a double hop scenario will succeed, but Reporting Services integration has been set up for Trusted Account rather than Windows Authentication. This causes SharePoint to continue to impersonate the logged-on user when contacting Reporting Services; when Reporting Services compares the application pool account to the user account making the request, they are not equal.

     

    There are two ways to resolve the issue with Kerberos:

     

    1.       Change the SharePoint site(s) so that they are configured for NTLM authentication rather than Negotiate. Follow these steps to change this:

    a.       Open Central Administration, and then click Application Management.

    b.      Under Application Security, click Authentication Providers.

    c.       Click the zone you want to modify.

    d.      Under IIS Authentication Settings, click NTLM instead of Negotiate.

    e.      Click Save.

    f.        Repeat steps iv-vi for each zone/site you want to change by selecting a different Web application from the drop-down list in the upper right-hand corner.

     

    2.       Change the ReportServer virtual directory on the Reporting Services server to support NTLM only instead of Negotiate, NTLM. Use the following sections to change this:

    SQL Server 2005 Reporting Services

    a.       Get the Web Site ID for the Reporting Services Web site from IIS Manager by clicking the Web Sites folder and looking in the Identifier column next to the site.

    b.      Open a command prompt.

    c.       Type cd\inetpub\adminscripts

    d.      Type cscript adsutil.vbs set w3svc/<WebSiteID>/root/NTAuthenticationProviders "NTLM"

    e.      Note: This will cause all double hops to Reporting Services to fail unless the value is set back to Negotiate,NTLM.

    SQL Server 2008 Reporting Services

    Using the information in How to: Configure Windows Authentication in Reporting Services (http://msdn.microsoft.com/en-us/library/cc281253.aspx) in SQL Server Books Online, set AuthenticationTypes to RSWindowsNTLM only.

     

    Thanks & Regards,

    Peng Lei

    • Marked as answer by David HM Tuesday, May 31, 2011 9:05 AM
    Thursday, May 26, 2011 4:47 AM

All replies

  • Hi krishna,

     

    This error can be caused when Kerberos authentication has been set up correctly and delegation in a double hop scenario will succeed, but Reporting Services integration has been set up for Trusted Account rather than Windows Authentication. This causes SharePoint to continue to impersonate the logged-on user when contacting Reporting Services; when Reporting Services compares the application pool account to the user account making the request, they are not equal.

     

    There are two ways to resolve the issue with Kerberos:

     

    1.       Change the SharePoint site(s) so that they are configured for NTLM authentication rather than Negotiate. Follow these steps to change this:

    a.       Open Central Administration, and then click Application Management.

    b.      Under Application Security, click Authentication Providers.

    c.       Click the zone you want to modify.

    d.      Under IIS Authentication Settings, click NTLM instead of Negotiate.

    e.      Click Save.

    f.        Repeat steps iv-vi for each zone/site you want to change by selecting a different Web application from the drop-down list in the upper right-hand corner.

     

    2.       Change the ReportServer virtual directory on the Reporting Services server to support NTLM only instead of Negotiate, NTLM. Use the following sections to change this:

    SQL Server 2005 Reporting Services

    a.       Get the Web Site ID for the Reporting Services Web site from IIS Manager by clicking the Web Sites folder and looking in the Identifier column next to the site.

    b.      Open a command prompt.

    c.       Type cd\inetpub\adminscripts

    d.      Type cscript adsutil.vbs set w3svc/<WebSiteID>/root/NTAuthenticationProviders "NTLM"

    e.      Note: This will cause all double hops to Reporting Services to fail unless the value is set back to Negotiate,NTLM.

    SQL Server 2008 Reporting Services

    Using the information in How to: Configure Windows Authentication in Reporting Services (http://msdn.microsoft.com/en-us/library/cc281253.aspx) in SQL Server Books Online, set AuthenticationTypes to RSWindowsNTLM only.

     

    Thanks & Regards,

    Peng Lei

    • Marked as answer by David HM Tuesday, May 31, 2011 9:05 AM
    Thursday, May 26, 2011 4:47 AM
  • Hi,

    Right now iam having the same configuration but still iam getting the same error

    Domain/user insuffic ient permissions in sharepoint

    Thanks,

    Krishna

    Monday, June 6, 2011 4:19 PM