locked
451 4.7.0 Temporary server error. Please try again later. PRX5 RRS feed

  • Question

  • Hi,

    I have ES2019 on-premises installed on a WS2019 VM (the underlying Hyper-V is also WS2019).

    I have a mail backup service (DuoCircle) which apparently got forwarded a mail because my first priority MX (my ES2019 on-premises) was refusing it. When DuoCircle tries to resend it to me, it keeps on getting this message:

    "451 4.7.0 Temporary server error. Please try again later. PRX5 "

    What could be causing this?

    Also (and possibly related), sometimes it takes a very long time (about an hour) for mail sent to me to be received. Perhaps those sender's SMTP servers are getting the same message, and I don't know about it because they eventually get through before they decide to try my secondary MX (DuoCircle).

    From web searches, it seems that both these problems might be related to internal DNS issues. Apparently multiple NICs (which I need to have) can be problematic. This article seemed to be relevant:
    https://social.microsoft.com/Forums/azure/ko-KR/5f606a51-db9c-4f70-86fe-82d561f7b237/exchange-2016-smtp-relay-error-451-470-temporary-server-error-please-try-again-later-prx5?forum=Exch2016MFSM

    Here are my Receive Connectors. I believe they are all defaults - I don't think I touched them since the installation:
     

    Does something need to be changed there?

    There are no Exchange Server errors in the Event Log.

    Where can I see all failed attempts to send mail to my ES2019? The command
    "Get-MessageTrackingLog -Resultsize unlimited| where-object {$_.EventID -eq "Fail"}"
    only seems to show mail which was rejected due to bad recipient addresses.
    I need to see a log of all rejections (and in particular those which are given a "451 4.7.0 Temporary server error. Please try again later. PRX5" response by my ES2019), and their reason.

    TIA,

    mlavie








    • Edited by mlavie58 Tuesday, January 8, 2019 1:06 PM
    Tuesday, January 8, 2019 10:08 AM

All replies

  • You mentioned that you have multiple NIC's on server.

    Does those have default gateways and dns servers configured.

    Are those registered in DNS.

    For log location you can see transport logs which can be found under exchange installation folder.

     %ExchangeInstallPath%TransportRoles\Logs\Hub\ProtocolLog\SmtpReceive


    Thanks, Ashish MCITP, MCT, MCSE

    Tuesday, January 8, 2019 1:22 PM
  • Hi Ashish,

    Folder C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\Logs\Hub\ProtocolLog\SmtpReceive is empty.

    How do I turn on logging?

    TIA,

    mlavie

    Tuesday, January 8, 2019 1:31 PM
  • It is enabled by default.

    What you see while running test-servicehealth?

    All service should be running on Exchange. If those are running then logs should be there.

    Also make sure exchange instllation directory is correct.

    You can check it by running below:-

    $env:ExchangeInstallPath

    https://docs.microsoft.com/en-us/exchange/mail-flow/transport-logs/transport-logs?view=exchserver-2019


    Thanks, Ashish MCITP, MCT, MCSE

    Tuesday, January 8, 2019 1:37 PM
  • $env:ExchangeInstallPath shows the path I searched for, above, and in which there is no log.

    The results of test-servicehealth are:

    Role                    : Mailbox Server Role
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeDelivery, MSExchangeIS, MSExchangeMailboxAssistants, MSExchangeRepl, MSExchangeRPC, MSExchangeServiceHost, MSExchangeSubmission, MSExchangeThrottling,
                              MSExchangeTransportLogSearch, W3Svc, WinRM}
    ServicesNotRunning      : {}
    
    Role                    : Client Access Server Role
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeMailboxReplication, MSExchangeRPC, MSExchangeServiceHost, W3Svc, WinRM}
    ServicesNotRunning      : {}
    
    Role                    : Hub Transport Server Role
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeEdgeSync, MSExchangeServiceHost, MSExchangeTransport, MSExchangeTransportLogSearch, W3Svc, WinRM}
    ServicesNotRunning      : {}

    Command [xml]$bp=Get-ExchangeDiagnosticInfo  -Process EdgeTransport -Component ResourceThrottling; $bp.Diagnostics.Components.ResourceThrottling.ResourceTracker.ResourceMeter
    shows all resources on Low, except for System memory, which is on medium.

    As for the NICs:
    One is a static NIC, with Gateway and local DNS set correctly.
    The other is DHCP (has to do with a problem with the RRAS server on the same machine). It is showing a greyed-out gateway which is correct. I just now dictated a local DNS server instead of automatic. I'll se if this fixes something.

    mlavie

    Tuesday, January 8, 2019 1:50 PM
  • You should not have multiple NIC with default gateways and DNS registration.

    Is it possible to disable another NIC and then test mail flow?


    Thanks, Ashish MCITP, MCT, MCSE

    Tuesday, January 8, 2019 2:03 PM
  • Hi Ashish,

    The problem is intermittent - most of the time the mails arrive on time, so disabling the second (DHCP) NIC would not given an obvious result until a day or two goes by. But I will try it.

    I did not understand your comment "You should not have multiple NIC with default gateways and DNS registration". What did you mean by that? What do I need to change?

    Just so you understand the background for the second NIC:
    I need to run my RRAS on the same box as my ES2019, because I have only 1 incoming external IP address, and therefore to support SSTP (which uses port 443) it needs to be on the same machine with my ES2019 which requires getting 443 for its owa/ecp web app. 
    There is a bug in RRAS 2019 which requires an additional NIC set to DHCP - even if incoming and outcoming communication is on the same subnet.

    If you have a solution that could avoid removing the 2nd NIC, I'd be great. For example, some posts in various forums suggest removing the "Frontend" receive connectors or changing all receive connectors so that instead of stating for IPv4 to listen on all addresses - to specify the address of the static NIC. However, I am afaaid to make any changes to the default settings unless someone from Microsoft recommends it.

    TIA,

    mlavie

    Tuesday, January 8, 2019 2:28 PM
  • Hi,

    As per best practice for Exchange, It should not have multiple NIC with default gateway assigned and registered to DNS.

    Exchange use preferred IP Address.

    Apart from that best practice says that Exchange server should not have any other roles installed like your are using RRAS.

    Also there will be conflict on port 443 as your RRAS and Exchange both using same port.


    Thanks, Ashish MCITP, MCT, MCSE

    Tuesday, January 8, 2019 2:57 PM
  • Hello,

    You should create new custom Receive Connector on the Front End Transport service.

    Remote IP address ranges: IP of mail backup server

    Permission groups: Anonymous Users 

    Thursday, January 10, 2019 4:48 AM
  • Hi mlavie,

    I met some similar cases which is solved by modifying Frontend receive connector and adding local server IP to host file. For step-by-step walkthrough, please refer to the following blog.

    Exchange 2013 451 4.7.0 Temporary server error. Please try again later. PRX5

    Please note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information. And the changes made in the above blog is not supported officially by Microsoft.

    Regards,

    Dawn Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, January 10, 2019 10:50 AM