This document could not be opened. It does not appear to be a Crystal Report document. RRS feed

  • Question

  • Hi, I have sequenced an application called Symology that uses Crystal Reports XI.  It works fine on my PC but on a number of others when they try to open any report thay are getting the following error.



    This document could not be opened.  It does not appear to be a Crystal Report document.

    This document has the file extension  (.RPT), but it seems to be corrupted.  If this report used to work, try opening it with a different version of Crystal Reports and if that still does not work, please contact your administrator.

    The document is not corrupt as it can be opened from other PCs.  I have a feeling that they are missing some .dll file.


    Can anyone help?


    • Moved by Aaron.ParkerModerator Monday, July 22, 2013 3:41 PM Not related to Server App-V
    • Edited by Shepsy Monday, March 27, 2017 8:03 AM
    Monday, July 22, 2013 3:15 PM

All replies

  • Can you give a little more information. What is this document? Should it live on a share like that? Is it possible there's a conflict if one user has it open when the others attempt to use it?

    Is Crystal Reports virtualized too? Or is it on the local machine? Have you tried installing it locally on one of the machines to verify if that fixes the issue?

    Does your report.xml file show any files excluded from your sequenced application?

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    • Edited by RorymonMVP Monday, July 22, 2013 4:08 PM added question re: report.xml to see if a .dll may have been excluded.
    Monday, July 22, 2013 3:45 PM
  • The document is a template that is used throughout the authority so it has to be on the shared server.  It only uses the template for a split second to populate it with data and places it in the users temp folder so that they can print it. I have already virtualised Crystal Reports XI as a separate package and this opens the template .rpt’s fine.

    The problem is that the Symology uses its own version of Crystal Reports XI as an add-on. 

    If I log onto PC (a) and try to access the .rpt through the virtualised Symology app it works fine.  If I log onto PC (b) and try to access the same rpt I get the error. 

    I have installed the thick client onto PC (b) and this also works fine, but once I un-install it and try to access the .rpt again through the virtualised version it fails. 

    I have already had problems with sequencing Crystal Reports as it doesn’t sequence all the .dll’s it needs. I have to manually copy mfc71u.dll,  msvcp71.dll, msvcr71.dll as not all PC’s have them.

    I think that this is probably a similar problem.

    Monday, July 22, 2013 4:18 PM
  • Oh ok, I see. So it sounds like it might be a good idea to check your report.xml file to see if anything got excluded during sequencing or failing that, install the app locally (or look in the MSI if possible) and compare that to the contents of your virtual app.

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Monday, July 22, 2013 6:23 PM
  • After further investigation it looks as though this has something to do with Crystal Report ActiveX Designer.  I still can not figure out why it works on some PC's and not on others. 

    Any help would be appreciated.

    Tuesday, July 30, 2013 12:17 PM
  • Hello,

    I would use Process Monitor to identify the differences between a working and a non-working computer

    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, July 30, 2013 12:23 PM
  • After further investigation I found that the business Objects Chrystal Reports 11 is not being captured in the Appv Bubble.  If I run the installation and then manually install just that part it will then work. I have tried to automate this by trying to record the manual installation eg. "Symology.exe -r" which should create an .iss that I could have run in the OSD in pre-launch but this application will not allow the -r /r command.  I have done a regshot and can see the multiple registry settings & would put a copy on here but I don't know how to put a html file

    from my c: drive on here.  Is there a way I can capture/record these settings?

    Wednesday, September 25, 2013 12:46 PM
  • Hello,

    Any reason you can not export those keys into a .reg-file and import them during sequencing?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, September 26, 2013 8:02 PM
  • This has inspired me to write a blog. I need to stress the importance of Devirtualization to hone in these things quicker.

    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Sunday, September 29, 2013 4:19 AM