KVM Switching Moves Windows on Single Monitor Setup RRS feed

  • Question

  • I am working on setting up Windows 10 Enterprise LTSB 2016 on a machine that is connected to its monitor via a DisplayPort KVM switch.  Model of KVM switch is Tripp-Lite B004-DPUA2-K.  Monitor resolution is 1920x1200.  Every time I switch away from the Win10 machine, all of my windows move to the top left corner of the screen.  My first impression was that this was happening because Windows was changing the resolution like it couldn't communicate with the monitor.  Searching for similar problems lead me to slews of people who had problems with multiple monitor setups (with and without KVM switches) and windows moving between monitors after upgrading to various versions of Windows (with some comments even indicating having issues like this in WinXP) in addition to people who were frustrated that their icons were moving around in Windows 10.  I don't have any icons on the desktop other than recycle bin, and it was in the top left corner, so I focused on the multiple monitor issue even though it isn't exactly what I have.  The only solution I could find that worked for anyone was to upgrade the video drivers.  This is a basic PC with an Intel HD 530 integrated chipset, so I downloaded the latest version from Intel and forcefully installed it since it wouldn't install automatically because it "wasn validated" with this HP machine.  Afterwards, I moved the Recycle Bin icon to the lower right corner (as opposed to messing with a window, for various trivial reasons).  Next, I switched away and back.  The icon did not move, so I thought the problem was resolved, but I was wrong.  I opened Notepad and put the window in the lower right hand corner of the monitor.  I switched away and back again.  Notepad was moved to the top left corner of the screen, but the Recycle Bin icon remained in the lower left corner.  Prior to all that troubleshooting, I also tried minimizing the window before swiching away and back as well as locking the screen before switching away and back.  Neither of those things helped, either (the window moved even though it was minimized and / or the screen was locked).  I don't have this problem on the Win7 Enterprise machine I am switching back and forth with, but it is running different hardware.  Since I've already tried drivers, I'm thinking I might just use Remote Desktop instead of the KVM switch, but that has its own whole slew of problems.  Can anyone give me any other ideas on how to work around or stop this behavior?
    Friday, February 24, 2017 8:16 PM


  • OK, so I thought I was out of ideas and then realized several more things I could try.  None of them were successful, but I did determine that turning off the monitor while it was connected to the Win10 machine caused the same issue.  Given this, I removed the KVM from the equation (plugged the monitor directly to the computer), and confirmed it still caused the problem.  Because of this, I did some more research and found this thread:

    Working off of this particular solution (from RMNixon) worked for me (key is not called "SIMULATED" in Win10, but same location and general idea):

    Here is a solution that created a solution for me, with extra directions at the end since only doing what MichealAtOz states didn't solve the problem for me:

    "I have found a work-around.
    Using Sysinternals ProcessMonitor I found that Windows was accessing the following Registry path;

    My system had three entries;

    Under each is a tree called "00" two of the keys are

    Under "00" was another branch also called "00" two of the keys are;

    The first two of the configs (ie DELF00... & QHD3...) the above keys were 1440x900,
    so they were not involved.

    The third (SIMULATED...) were set to 1024x768.

    I changed these to 1600x900 and the problem was solved.

    Further I changed resolution (via control panel) to 1920x1080, the moving/resize issue returned,
    but the lower right corner was set to 1600x900, ie the SIMULATED... settings."

    Use MichealAtOz's advice but within all the folders that are labeled "00" or "01", (etc, I had 00 and 01) look for any settings that contain 1024, 768, or I 4096 in the data values at the end in parenthesis. Change the 1024 to the x resolution of your desktop (the first number in resolutions) and the 768 to the y resolution of your desktop. Change the 4096 number of "Stride" to whatever number there already is in a "00" or similar titled folder that already has (without you changing them) the desired desktop resolution numbers in and ...y. Right click the name and choose modify, then select binary as the base to enter correct resolution values.

    Hopefully this makes sense - it solved the issue for me.

    Saturday, June 16, 2012 5:41 AM
    • Marked as answer by PRDIT Friday, February 24, 2017 9:00 PM
    Friday, February 24, 2017 9:00 PM