none
RSAT Windows 10 - AD - Remote Desktop Services Profile Tab RRS feed

  • Question

  • Have installed RSAT for Windows 10 successfully, am using Active Directory Users and Computers, but I am unable to view the Remote Desktop Services Profile Tab.

    Advanced Features is selected in the AD view.

    I have been through install/remove Windows features and ensured all RSAT tools have been ticked, including the Remote Desktop Services Tools.

    Have tried the following fix with no success - https://technet.microsoft.com/en-us/library/cc725609.aspx?f=255&MSPPError=-2147217396

    Anybody run into this? Have any suggestions?

    Thanks

    Friday, August 28, 2015 1:25 PM

Answers

  • I have fixed this issue with a workaround.

    1. Copied two files (tsuserex.dll and tsuserex.dll.mui) from one of my Windows Server 2012 R2 servers to my laptop, (where I am running my custom MMC) in the same directories that I copied them from.

    2 Opened a command prompt on my laptop, as an Administrator, and from the root of C:\ ran regsvr32 to register c:\Windows\System32\tsuserex.dll.  (the command is - regsvr32 c:\Windows\System32\tsuserex.dll)

    Hope this helps some of the rest of you.  I had tried registering these files before but didn't launch the command prompt as an admin and tried registering from the C:\Windows\System32 directory.  I guess it make a difference doing it from the root of the C: drive.

    Wednesday, September 2, 2015 2:49 PM

All replies

  • Hi,

    Please refer to this KB:

    Windows 7 RSAT: Multiple tabs are missing when viewing user properties in Active Directory Users and Computers

    https://support.microsoft.com/en-us/kb/2028835

    In addition, I would like to suggest you add all components from the Turn Windows Features on or off.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 31, 2015 6:13 AM
    Moderator
  • Hi, 

    I have all the components installed and advanced features checked in view and I am not able to see the "remote desktop services profile" tab in Windows 10. 

    Thanks


    • Edited by UnionITS Monday, August 31, 2015 1:13 PM
    Monday, August 31, 2015 1:12 PM
  • As I mentioned in the original post, I have all the RSAT components installed, but "Remote Desktop Services Profile Tab" is still not visible in AD.

    Seems someone else below me is seeing the same issue too.

    Tuesday, September 1, 2015 2:58 PM
  • I am having the same problem on multiple systems.  Thought it might be my laptop at first but this seems to be a bug.  Hopefully Microsoft will fix this soon.  I will be watching this thread for an answer.  If anyone finds a fix please post it here.
    • Proposed as answer by rpixton Wednesday, September 2, 2015 2:40 PM
    • Unproposed as answer by rpixton Wednesday, September 2, 2015 2:40 PM
    Tuesday, September 1, 2015 5:08 PM
  • I'm guessing the Remote Desktop Services are part of the Routing and Remote Access tools Microsoft mentioned in the RSAT details:

    Routing and Remote Access Tools.  Routing and Remote Access Tools that are GUI-based cannot be used for remote configuration in this release of RSAT, but the equivalent Windows PowerShell cmdlets are available.

    More info here.  Try seeing if the PowerShell cmdlets show up - hope that helps!

    Tuesday, September 1, 2015 5:39 PM
  • We are just looking for the following tab in active directory users and computers(not Routing and Remote Access Tools):

    

    Tuesday, September 1, 2015 5:51 PM
  • Having the same problem.  Annoying
    Wednesday, September 2, 2015 1:53 PM
  • I have fixed this issue with a workaround.

    1. Copied two files (tsuserex.dll and tsuserex.dll.mui) from one of my Windows Server 2012 R2 servers to my laptop, (where I am running my custom MMC) in the same directories that I copied them from.

    2 Opened a command prompt on my laptop, as an Administrator, and from the root of C:\ ran regsvr32 to register c:\Windows\System32\tsuserex.dll.  (the command is - regsvr32 c:\Windows\System32\tsuserex.dll)

    Hope this helps some of the rest of you.  I had tried registering these files before but didn't launch the command prompt as an admin and tried registering from the C:\Windows\System32 directory.  I guess it make a difference doing it from the root of the C: drive.

    Wednesday, September 2, 2015 2:49 PM
  • I have fixed this issue with a workaround.

    1. Copied two files (tsuserex.dll and tsuserex.dll.mui) from one of my Windows Server 2012 R2 servers to my laptop, (where I am running my custom MMC) in the same directories that I copied them from.

    2 Opened a command prompt on my laptop, as an Administrator, and from the root of C:\ ran regsvr32 to register c:\Windows\System32\tsuserex.dll.  (the command is - regsvr32 c:\Windows\System32\tsuserex.dll)

    Hope this helps some of the rest of you.  I had tried registering these files before but didn't launch the command prompt as an admin and tried registering from the C:\Windows\System32 directory.  I guess it make a difference doing it from the root of the C: drive.


    Dude, you rock!
    Wednesday, September 2, 2015 3:25 PM
  • I have fixed this issue with a workaround.

    1. Copied two files (tsuserex.dll and tsuserex.dll.mui) from one of my Windows Server 2012 R2 servers to my laptop, (where I am running my custom MMC) in the same directories that I copied them from.

    2 Opened a command prompt on my laptop, as an Administrator, and from the root of C:\ ran regsvr32 to register c:\Windows\System32\tsuserex.dll.  (the command is - regsvr32 c:\Windows\System32\tsuserex.dll)

    Hope this helps some of the rest of you.  I had tried registering these files before but didn't launch the command prompt as an admin and tried registering from the C:\Windows\System32 directory.  I guess it make a difference doing it from the root of the C: drive.

    Worked for me too, great fix thanks!
    Lets hope MS fix the original issue
    Thursday, September 3, 2015 10:58 AM
  • Worked like a charm ! Thanks !

    Just a little precision :

    tsuserex.dll is indeed located in C:\Windows\System32\

    and

    tsuserex.dll.mui is located in C:\Windows\System32\en-US\

    You'll need to copy both files at in their respective folders with administrator elevated privileges, and before using the regsrv32 command (still with elevated privileges), make sure all your current mmc consoles are closed !

    Then reopen ADUC, in the View menu enable the Advanced Features, then browse to any users, and voilà ! You'll see the missing tabs you're looking for.

    Thanks a lot again to rpixton for his finding.

    Thursday, December 10, 2015 10:00 PM
  • It's nice that we have a manual fix but is Microsoft going to release a new RSAT to address this? I don't understand how something like this can slip through the cracks. Especially after we're already on the second release of Win 10 RSAT. 
    Tuesday, February 9, 2016 4:32 PM
  • Did you install the x64 RSAT or x86 version?  I cannot get this to work on my PCs with the x64 version of RSAT installed.

    Thank you

    Thursday, February 18, 2016 8:07 PM
  • On 64bit machines you must also copy the TSUSEREX.DLL and TSUSEREX.DLL.MUI from the SYSWOW64 directory in addition to the System32 directory (do not duplicate from there, copy all files individually from source to destination). Then it will register successfully.

    • Edited by Code Chief Monday, February 22, 2016 4:26 PM
    Monday, February 22, 2016 4:26 PM
  • Hi, here is full pack with RSAT install and my script for install DDL files for Terminal Services Tabs.

    https://www.ulozto.net/!pvYgnKunZ/rsat-install-for-windows-10-rar

    Friday, August 5, 2016 6:13 AM
  • Retry when the updated RSAT package becomes available after the release of WS16
    Monday, September 26, 2016 11:40 PM
  • Tried with new RSAT tools for W10 (v1.2) and it doesn't work....

    I took the same files from the official version of WS2016 and I have a window telling me I have to choose between 32 and 64 bits.

    Here's the window I get after registering all dll :

    I still haven't found a solution

    SOLVED : The new RSAT tools v1.2 include the RDS Profile tab by design.

    You musn't copy the tsu* files from another server... if you do so, you get the problem showed in my image.

    I uninstalled KB2693643 and reinstalled it and everything is back without any error.

    MS heard our requests... Thanks

    • Edited by Tof006 Friday, October 21, 2016 6:01 AM SOLVED
    Thursday, October 20, 2016 7:03 AM
  • Fine to me too. Thanks
    Thursday, December 22, 2016 7:53 PM
  • I removed kb2693643 and installed it back. Issue has resolved.
    • Proposed as answer by jsibauste Monday, August 7, 2017 10:02 PM
    Friday, January 6, 2017 6:48 PM
  • Hi

    Thanks for sharing solution.

    But when i try to copy root folder (C:\widows\system32\) Its showing permission error. Im admin as well as i chnage root folder permission. Finally not working

    Wednesday, February 22, 2017 8:43 AM
  • Hi

    Thanks for sharing solution.

    But when i try to copy root folder (C:\widows\system32\) Its showing permission error. Im admin as well as i chnage root folder permission. Finally not working

    You may need to take ownership of the file.
    Thursday, February 23, 2017 5:11 PM
  • I have copied the 32 bit version and the 64 bit version to their perspective locations.  I have tried registering both versions from the directory they are located in and from the root.  I have also done all of this with CMDs being run as Administrator.  None of this has worked.  I am still not able to see the object tab.  I have removed and reinstalled it a few times and nothing has worked.  Any other thoughts at this point?

    Thursday, February 23, 2017 8:45 PM
  • You do not need to take ownership of any files and no need to copy any files of any folders if you follow the latest instructions about removing the KB and reinstalling it. People need to start reading the end first.
    Monday, August 7, 2017 10:02 PM
  • The butler did it.
    Friday, October 20, 2017 4:29 AM