locked
How to use multiple addresses with a public folder RRS feed

  • Question

  • Hi

    What is the correct way to set up a public folder with multiples mailaddresses?

    Today we have a set up with a public folder called "CompanyMail" and a distribution group called "CompanyMails". The public folder is a member of the distribution group and all our different mailaddresses (Info@domain.dk, job@domain.dk and so on) are added to the distribution group. So if someone sends a mail to info@domain.dk it ends up in the public folder.
    We don't use the "CompanyMails" distribution group to anything else than the different company mails that ends up in the public folder.

    This is a set up I have enherited from the previous IT guy. If I was told to make a set up with the same result, I would properly create a public folder and add all the necessary addresses to that folder instead of using a distribution group.
    One of our issues is that we can't send mail to the addresses from our own domain, we get a NDR.

    I hope this makes sense :-)


    /Lasse
    Friday, April 8, 2011 8:59 AM

Answers

  • Hi

    Can you check the permission on the public folder?  Can you see if you're allowed to create items, i.e check the anonlymous has at least create items?

    You may also want to check that default has create permissions to?

    Sukh

    • Marked as answer by LasseF Monday, April 11, 2011 6:25 AM
    Friday, April 8, 2011 6:02 PM

All replies

  • I have now moved all the mailaddresses from the distribution group to the public folder and removed the Exchange attributes from the distribution group. I have tested that we still receive mail on the moved addresses from outside the company but I still get an error when I try to send to one of the addresses that are assigned to the public folder.

    I actually get different NDR's from the system depending on which address I use.

    One is this reply:
    #550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

    Another is this erply:
    #550 5.2.0 STOREDRV.Deliver: The Microsoft Exchange Information Store service reported an error. The following information should help identify the cause of this error: "MapiExceptionNotAuthorized:16.18969:18110000, .... BLA BLA BLA


    /Lasse
    Friday, April 8, 2011 10:26 AM
  • Hi LasseF,

     

    I would say that having email addresses assign directly to public folders is best practice in your case.

    When you sending the email to the public folder from the Outlook client can you try to pick the address from the Global Address List. I got this error when my Outlook client used the “Auto-Complete” function which is stored in this file “%APPDATA%\Microsoft\Outlook\Outlook.NK2”. You could also delete this file completely when your Outlook is closed and a new one will be generated next time you send an email.

     


    Adam Bokiniec
    • Edited by Adam.Bokiniec Friday, April 8, 2011 10:42 AM spelling
    Friday, April 8, 2011 10:41 AM
  • I have tried adding the address from the GAL but that didn't change the result. I have also tried renaming the Outlook.NK2 file, so I got a new, and that was the same result.

    The plan is to hide the address from the Global Address List, but we should still be able to send mails to it. We have around 10 addresses assigned to the public folder, if I enter the complete address when trying to send a mail it returns the same error. We have other mail-enabled public folders where we don't have any issues. The main difference is that the other public folders don't have other assigned addresses other than the 2 default addresses (We have registered 2 domains). Another think is that the public folder with the issue has been renamed, but can't see why that should be a problem.

    I am considering deleting the PF and starting all over.

     


    /Lasse
    Friday, April 8, 2011 11:31 AM
  • Before deleting try to create a new public folder and assign a couple of email addresses to it from the two new domains you recently added.
    Adam Bokiniec
    Friday, April 8, 2011 11:36 AM
  • I think I know what's causing the issue. I have tested several mail-enabled public folders and I have found 1 more that has the same issue. The only thing the 2 public folders has in common is that both folders has been renamed.


    /Lasse
    Friday, April 8, 2011 12:05 PM
  • Hi

    Can you check the permission on the public folder?  Can you see if you're allowed to create items, i.e check the anonlymous has at least create items?

    You may also want to check that default has create permissions to?

    Sukh

    • Marked as answer by LasseF Monday, April 11, 2011 6:25 AM
    Friday, April 8, 2011 6:02 PM
  • Hi Sukh

    I have already checked the permissions, but after reading your reply I did again :-)

    The Default account didn't have Create permission but Anonymous had, so that's why we could receive mails from outside the organization and not inside.
    I couldn't see the forest for all the trees :-)

    Thanks.

    Lasse


    /Lasse
    Monday, April 11, 2011 6:25 AM