locked
VCUServe.exe - Entry Point Not Found RRS feed

  • Question

  • I clean installed Windows 7 RC 7100 a few days ago and have had nearly a flawless experience.  This morning at boot up, i received a dialog box entitled "VCUServe.exe-Entry Point Not Found.  The text in the box reads ""The procedure entry point ??0CsnyUtilsApi@@QAE@XZ could not be located in the dynamic link library VCULib.dll". 

    I"m operating a Sony Vaio, 2GHz, 2 GB memory, processor is Intel Core TM2 CPU.  After i installed Windows 7, i have been slowly adding in the Vaio patches.  Since this happened a couple of days after the main install of Windows, i cant think it could be anything else.  All printers, etc... installed without any problems. 

    Thanks for any help.
    Adam Lewis
    Saturday, May 23, 2009 4:39 AM

Answers

  • ericL44,

    VCUlib.dll  is part of the Vaio Camera Utility. Maybe you could roll back the update for this? Has the camera worked at all with Windows7?
    Saturday, May 23, 2009 4:54 PM
    Answerer

All replies

  • ericL44,

    VCUlib.dll  is part of the Vaio Camera Utility. Maybe you could roll back the update for this? Has the camera worked at all with Windows7?
    Saturday, May 23, 2009 4:54 PM
    Answerer
  • I realize that this post is over a year old however I'm having the same problem with a sony vaio laptop and to answer your unanswered question....No!!  The camera has not worked at all since upgrading to Windows 7, which kinda irritates me because I did everything recommended on Sony's website.  I ran the compatability program and it all passed....I installed a clean windows 7 and then proceeded to download the Camera Drivers for Windows Vista from the Sony Download and Support page, which incidentally, Sony went out of their way to assure we upgrading visitors that no specific Windows 7 drivers would be required (which would have been a good thing since none are offered).  All that anyone would need to do for a flawless upgrade to Windows 7, was to download Vista Drivers for anything not "driven" by the newest operating system's installation program...   Easy as that sounds, it's a load of ____.   And Finally, as if three days of hair pulling and frustration at trying every conceivable option to get the motion eye camera up and running, to no avail, wasn't enough of a kick in the groin....Now...fully a week of doing windows 7 updates (both important and optional) later, hoping each time to see something in the way of a camera update for the yellow exclamatorized shadow of it's former self listed but non-operational in device manager....suddenly tonight one does...only after giving it the old beach bum try at an installation I get error code 800F020B which according to microsoft's very own registry of windows error codes.....that particular code does not exist therefore rendering a big fat nothing in the way of useful information of even non-useful help of any kind. At this point I really don't know who to be pissed at...Sony for their failed assurance and advice about upgrading to Windows 7 or Microsoft for not assuring their assurances.   If anyone happens across very lengthy and very late bit of rambling, and could offer anything in the way of a solution to this ongoing source of discomfort and stress induced flagelance...please please please spill it.....thank you!
    • Proposed as answer by ninh_ Tuesday, July 6, 2010 1:26 AM
    Friday, June 18, 2010 1:40 PM
  • Hard disk died so I installed a 500Gb disk and did a clean Win7 install.  

     

    I got every thing to work but the WebCam.  So I tried to chat with Sony support.  They ended up to be useless, just wasted about 45 minutes of my time poking about my laptop (with a remote assistance software) while telling they can help.  But in the mean time, the support person only wanted to know what other software I was using, and that Sony support could help support me on Word, Excel, PPT, Skype and so forth.  I asked I only need help on the Sony built in webcam (I was thinking, you can't help me with your own hardware driver, how are you going to help me with other 3rd party software, fix this one first).  I keep saying NO to the marketing pitch, and she would say Ok.  She kept on saying all though I don't want the service contract, she can still help to resolve my webcam problem (or at least a rouse to keep me hanging on). I got tired of this support staff trying to sell me a service contracts (starting from $199 and got quickly discounted with the first no).  After about 5 times asking, I me kept on saying NO, I got no where and told her I was ending the session.  I called because it's their download that kept on blowing up when I tried to install Sony software on Sony software.  I guess that tech (from the typical outsource location with a name of Rebecca) doesn't understand the English word "No Thank You".  Her accent does not fit a Rebecca.  Why don't she just use a more appropriate name then hiding behind Rebecca.  Ok, I can help you if you would ....  She sounded like a broken parrot by asking the same thing over and over again.   I was hoping to get some hints or suggestion or know work around, but it ended up to be a frustrating session with Sony Support. This will probably the last Sony laptop I'll buy.  Aesthetic laptop, but awkward implementation of simple controls such as Sony's use of FN keys to change volume and display settings (brightness & external toggle).  Plus Sony's proprietary battery power management, if not configured correctly, will over charge and kill your battery quickly.  Sorry for the ranting...

     

    In the end, after hours of tinkering, I found that not all the Sony stuff on the download site will worked.  Even though I'm in Vista, some complained it was not for my OS, but for Vista.  Some acted like it work, but did nothing (failed in the middle and skipped straight to Finish dialog, as it it worked ok). Some corrupted my registry and left nasty slime trails, accompanied by pop-up warnings of errors at each reboot (e.g., 0CSnyUtils.dll).  Good thing I was able to do incremental rollbacks, using windows restore.  I finally got the following combination to work with a clean Vista or Win7 install (see attached list).  Install Windows Vista or Win7, then follow the list.  I numbered them in the sequence that worked for me, and REBOOT whenever the install prompt you to do so (don't try to install it all at once or two go rounds, be prepare to sit through a bunch of reboots).  Note, for the web cam to finally work, I had to use an XP download version.  Windows 7 now works for me on my Sony VGN-SZ220.

     

    By the way, don't upgrade to Bios R0092N0.  It caused my SZ220 laptop to no longer recognize my 2Gb RAM sticks.  My 4Gb laptop came up as 2Gb.  When I rolled the Bios back, I got back the 4Gb.  The old original factory Bios ran fine under Vista and Win7.

     

    http://esupport.sony.com/US/perl/swu-list.pl?mdl=VGNSZ220&SelectOS=27

     

     1. intel_chip_update INDVID-01355607-US.EXE

     2. modem CODMOD-01355201-US.EXE

     3. flashcard_reader SOOOTH-A1013106-US.EXE

     4. Aps_pointer ALDOTH-01347903-US.EXE

     5. memory_stick_icon SODOTH-01362101-US.EXE

     6. digital_audio_upd STDAUD-00157222-US.EXE

     7. Fingerprint_Sensor UPDFPD-70163534-32.EXE

     8. TI_card_reader TIDMSC-01424702-US.EXE

     9. hdd_protect SOAHDD-01315102-US.EXE

    10. hdd_update SODOTH-A1074304-US.EXE

    11 intel_wireless INDWLL-01396400-US.EXE

    12. video_update NVDVID-01422002-US.EXE

    13. video_shared_lib_update SOAOTH-01277903-US.EXE

    14. utility_dll SOASNU-01298604-US.EXE

    15. shared_lib SOASSL-A1298203-US.EXE

    16. setting_utility SOAOTH-01298404-US.EXE

    17. prog_IO SODSPI-A0445700-US.EXE

    18. notebook_controls SOAOTH-00445800-US.EXE

    19. power_mgnt SOAVPM-01305802-US.EXE

    20. sony_events SOAVES-01302701-US.EXE

    21. web_cam_driver_VVC2 SODCAM-01074405-US.EXE

    http://esupport.sony.com/US/perl/swu-download.pl?mdl=VGNSZ220&upd_id=2089&os_id=7

     

    In Vista, everything works fine.

    In Windows7, everything works with exception of "Vaio power management".  Web cam continue to work fine.  However, there a new problem crept up post installation.  The laptop now will consistently crash with a blue screen of death (when I attempt to set the CPU fan speed through the battery Power Options".  I think it's over charging my battery because the warning says (plugged in, charging) even thought it shows the battery to be 100%.  I was able to solved the crashing by doing Windows7 MS update.  Updates from Microsoft for windows7 fixed the crashing and allowed me to access "Viao power management".  I think at this time everything finally worked Ok.

     

    • Proposed as answer by ninh_ Tuesday, July 6, 2010 3:00 AM
    Tuesday, July 6, 2010 2:31 AM
  • Bellieve it or not download the driver from the XP OS (SODCAM-01074405-US).. I have win 7ult 32 bit.in a SONY Vaio VGN-SZ160P and it works fine

     

    I have all the drivers installed but i stiil have a problem with this "VCUServe.exe-Entry Point Not Found. The procedure entry point  ??0CsnyUtilsApi@@QAE@XZ could not be located in the dynamic link library VCULib.dll".  

     

     

    Saturday, October 29, 2011 6:47 PM