locked
Unable to mount new database RRS feed

  • Question

  • Hello 

    Please i need your help 

    while trying to create new database i get this message : 

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'USER_ARCHIVEDB4'.

    USER_ARCHIVEDB4
    Failed
    Error:
    Couldn't mount the database that you specified. Specified database: USER_ARCHIVEDB4; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorFileNotFound: Unable to mount database. (hr=0x80004005, ec=-1811)
    . [Database: USER_ARCHIVEDB4, Server:*****.****.***l].

    An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorFileNotFound: Unable to mount database. (hr=0x80004005, ec=-1811)
    . [Database: USER_ARCHIVEDB4, Server: *****.****.***]

    An Active Manager operation failed. Error: Operation failed with message: MapiExceptionJetErrorFileNotFound: Unable to mount database. (hr=0x80004005, ec=-1811)
    . [Server: *******.****.****]

    MapiExceptionJetErrorFileNotFound: Unable to mount database. (hr=0x80004005, ec=-1811)

    Any Ideas ? 

    Thanks 

    Monday, September 3, 2012 12:16 PM

Answers

  • Hi

    Did you look at below KB

    You cannot create a new Exchange Server 2010 Mailbox database in a multiple domain environment

    http://support.microsoft.com/kb/977960

    As the KB said,

    "This issue occurs when the value of the ConfigurationDomainController parameter and the value of the PreferredGlobalCatalog parameter are different. In this scenario, the Mailbox database operation   fails because of the replication latency that occurs between the configured   domain controllers and the preferred global catalog. "

    So, you can set the preferred Active Directory server in Exchange Management Shell to the following cmdlet:

    Set-ADServerSettings –PreferredServer <var><DC FQDN></var>

    Hope it helps

    Cheers


    Zi Feng

    TechNet Community Support

    • Marked as answer by Zi Feng Monday, September 10, 2012 2:48 AM
    Wednesday, September 5, 2012 8:10 AM
  • Hi,

    Please run eseutil /mh to check the status of the database.

    If it is dirty status, we may have to recover the database with eseutil /r.


    Regards, Nayan

    • Marked as answer by Zi Feng Monday, September 10, 2012 2:48 AM
    Wednesday, September 5, 2012 9:07 AM

All replies

  • Hi,

    When it fails go back to the EMC and refresh the database view, it happened to me several times and after sometime it mounts itself, if not then i go back and manually mount it. To be honest i think it could be the latency when new database is trying to register in AD which could be taking a while. 

    Let us know how you go.

    Surj

    • Proposed as answer by Surjeet Saini Friday, September 7, 2012 9:19 AM
    Monday, September 3, 2012 12:56 PM
  • Hi

    If you open up EMS and run Mount-Database "USER_ARCHIVEDB4" can you mount the database

    It could be that the log files are missing. On the EMC does it give you the error that log files are missing?

    check if the database is in a dirty state or clean shutdown state.

    http://support.microsoft.com/kb/896143

    Monday, September 3, 2012 1:01 PM
  • When i tried to mount the database from EMC i got this : 

    [PS] C:\Windows\system32>Mount-Database user_archivedb4
    Couldn't mount the database that you specified. Specified database: user_archivedb4; Error code: An Active Ma
    ation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorF
    d: Unable to mount database. (hr=0x80004005, ec=-1811)
    . [Database: USER_ARCHIVEDB4, Server: ARDCVPEXMB2.arcci.local].
        + CategoryInfo          : InvalidOperation: (USER_ARCHIVEDB4:ADObjectId) [Mount-Database], InvalidOperati
       on
        + FullyQualifiedErrorId : AFA502CC,Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase
    Monday, September 3, 2012 1:25 PM
  • i noticed something maybe can help  

    Exchange servers are Virtual servers using HYPER-V , When i create new database on normal virtual hard drive 

    it mounted and every thing goes fine 

    recently i,v added new Virtual hard drive using LUN SCSI  

    The Database on that virtual hard drive cannot be mounted ! 

    Monday, September 3, 2012 1:30 PM
  • Hi

    Did you look at below KB

    You cannot create a new Exchange Server 2010 Mailbox database in a multiple domain environment

    http://support.microsoft.com/kb/977960

    As the KB said,

    "This issue occurs when the value of the ConfigurationDomainController parameter and the value of the PreferredGlobalCatalog parameter are different. In this scenario, the Mailbox database operation   fails because of the replication latency that occurs between the configured   domain controllers and the preferred global catalog. "

    So, you can set the preferred Active Directory server in Exchange Management Shell to the following cmdlet:

    Set-ADServerSettings –PreferredServer <var><DC FQDN></var>

    Hope it helps

    Cheers


    Zi Feng

    TechNet Community Support

    • Marked as answer by Zi Feng Monday, September 10, 2012 2:48 AM
    Wednesday, September 5, 2012 8:10 AM
  • Hi,

    Please run eseutil /mh to check the status of the database.

    If it is dirty status, we may have to recover the database with eseutil /r.


    Regards, Nayan

    • Marked as answer by Zi Feng Monday, September 10, 2012 2:48 AM
    Wednesday, September 5, 2012 9:07 AM