locked
Vista Freezes When USB Device Plugged-In RRS feed

  • Question

  • Bought Vista Home Edition on Toshiba Satellite A-135 Laptop. Bought Targus keypad and Logitech (Vista certified) keyboard and mouse. Everything worked fine for a few months. Then Vista started freezing when peripherals were plugged-in. Both hard drives crashed and Geek Squad had to recover, replace and reinstall. After replacing hard drives and reinstalling Vista, it was still freezing. Took it back to Geek Squad who said it was a Vista issue related to unplugging peripheral and plugging it back in. They said that Vista didn't like it when you unplugged a peripheral and plug it back in. But, Vista seems to freeze even when you plug it in the first time. We've tried updating software for Logitech keyboard/mouse but it's still freezing.

    Anyone have any ideas?
    Sunday, August 5, 2007 9:42 PM

All replies

  • Having the same problem with my Dell Lattitude.  Did you find a solution?
    Monday, September 24, 2007 3:00 PM
  • i also have a dell d620 and the keyboard and mouse are verry jittery, and often freeze.  i'm using a dell keyboard and a microsoft mouse.  i tried updating the chipset and bios and mouse drivers.  it did not help

     

    Monday, September 24, 2007 4:05 PM
  • D620 w a D/Port at home (MS Wireless USB Keyboard/Mouse w fully charged batteries) and D/Dock at work witttttttly [example of my keybaord issue] with directly connected Dell USB mouse and a high end keyboard that was on a PS2->USB adaptor.

     

    To recap:

    1.       Dell tech replaced m/b

    2.       We installed a VIRGIN Vista Biz

    3.       Plugging office keyboard into D/Dock PS/2 connector fixes only the keyboard issue

    4.       Installation of MS v6.3 Intellikey/Intellmouse have no effect at home w D/Port’

    5.       Tried switching BIOS setting from USB v2.0 to USB Compat – no change

    6.         Moved USB running Wireless Keyboard/Mouse from D/Port to Machine itself and it appears to be working much better, I just noticed that the Mouse wheel works like it used to... 

    7.       Found this:

    http://episteme.arstechnica.com/eve/forums/a/tpc/f/579009962631/m/251004487831

     

    Some posts @ Dell appear to suggest turning off the Alps Touchpad when using external devices.  My system is docked, lid down in all cases.  I do note that when I'm using it in laptop mode I have no trouble with the integral mouse and keyboard.

     

    Don in Texas

     

     

    Saturday, November 15, 2008 5:26 PM
  • Just a thought - but it sounds like drivers for various usb devices conflicting that might cause it throw a wobbly.

    Have you tried to use different mouse (generic one which doesnt require any software drivers) - Perhaps de-install drivers for peripherials one at a time and see if you get one which is cause of the problem.
    Sunday, November 16, 2008 4:02 PM
  • I have the same problem.  Searched the net and got nowhere. A lot of people seem to have the same problem but no one has a fix for it. I am beginning to think it’s a hardware problem but was just wondering in it would make any difference the order that all the other drivers are installed on a clean install as it cold be another driver interfering with the usb.
    • Proposed as answer by dadriano Monday, July 27, 2009 8:21 PM
    Friday, March 6, 2009 10:42 AM
  • Like everyone else I had the same issue with USB's either not being recognized or coming up as unknown device. I even had a thumbdrive that would freeze my computer until I would pull it out. After searching the net and reviewing other's attempts this is what fixed mine.

    I began by nagivating to two separate folders
       The first: C:\Windows\System32\DriverStore\FileRepository
       The second: C:\Windows\inf
    Afterward I created a folder on my desktop
    Beginning with the first directory I noticed a multitude of folders beginning with "usb" (i.e. usb.inf, usbccid, usbcir, usbport, usbprint, usbstor, usbvideo)
    Additionally, there were multiples of each of these "usb" folders each dated differently (i.e. "usb.inf_debef" dated 6/20/2009, "usbinf_e4caf" dated
       1/20/2008, "usb.inf_faa99" dated 11/2/2006, etc)

    My solution was this:
    From the FileRepository folder I went into the most current of each of the "usb" folders (majority were dated 6/20/2009 a couple were 1/20/2008)
    I then copied every file in these "usb" folders except the file "component.man" into the created folder on my desktop
    This left me with twenty-six files in my new folder (your's may vary)
    I created a system restore
    I then copied and pasted all twenty-six files into the "inf" folder overwriting when necessary
    Restarted my computer and now everything works I can even use my flash drives again without freezing my computer.

    I am using Vista 64-bit I don't believe there is a difference in file structure so everything should work as stated.
    Let me know if this helps anyone. If it does I will post to other sites.

    Monday, July 27, 2009 8:46 PM
  • Having had problems with USB devices (memory cards, usb memory sticks and external hard drives) freezing my computer when plugged in for at least 5 years I tested dadriano´s solution, and it worked!!!

    I am most happy and grateful.

    Season Greetings from Sweden!

    Friday, December 16, 2011 10:46 PM