locked
Update-SCSMConnector removed the updated Connector! RRS feed

  • Question

  • Hi all,

    We just had a weird issue.

    We are running SCSM 1801 and using PowerShell remoting to perform a few SCSM tasks. One of them is to enable/disable the SCOM alerts connector. Section of the code:

    $SCSMConnector = Get-SCSMConnector -DisplayName $SCSMConnectorName
    $SCSMConnector.Enabled = $true
    Update-SCSMConnector -Connector $SCSMConnector

    It works perfectly if I run it in the SCSM Server, but remotely throws the following error and REMOVES the connector:

    The user does not have sufficient permission to perform the operation.
        + CategoryInfo          : InvalidArgument: (Microsoft.Enter...onnectorCommand:UpdateSCSMConnectorCommand) [Update-SCSMConnector], ArgumentException
        + FullyQualifiedErrorId : ExecutionError,Microsoft.EnterpriseManagement.ServiceManager.Cmdlets.UpdateSCSMConnectorCommand
        + PSComputerName        : SCSMServer

    And yes, the user has permissions.

    The connector is not in the SCSM console anymore. "Get-SCSMConnector" doesn't return it. The object is marked as "IsDeleted" in the database (table BaseManagedEntity). And the SCOM console still shows the Alert connector.

    Also, the following error is the Event Viewer:

    Cannot find instance of connector with internal name OMConnector.c7e1ac2271fc56584e724838a2f94628. If this message appears on every scheduled synchronization, the connector may have been improperly deleted outside of the Service Manager Console.
    This can only occur in exceptional conditions when the connector is deleted but its associated schedule is still active.  The workaround to prevent this error message is to export the ServiceManager.LinkingFramework.Configuration management pack and edit it to remove the following rules and tasks:
    Rule: OMConnector.c7e1ac2271fc56584e724838a2f94628_SyncRule
    Task: OMConnector.c7e1ac2271fc56584e724838a2f94628_SyncNowTask
    Task: OMConnector.c7e1ac2271fc56584e724838a2f94628_DeleteTask
     and then reimporting the management pack.

    Just wondering if it worked for anybody else or could be a bug...

    Thank you for your help.

    Wednesday, July 25, 2018 11:11 AM