none
Sendconnector changing port not working

    Question

  • Hi,

    I have changed my sendconnector port to xx. and i have also changed receive connector port to anonymous inbound connection, and now it works perfectly. But when i change sendconnector/smtp to another port, then won't working (It's work perfectly by default). What to do I have changed sendconnector with this cmd, and firewall also is ok.

    Set-SendConnector -Identity "XXXXXX" -Port XXXXX

    regards 

    Zlatan

    Monday, December 19, 2016 10:47 AM

Answers

  • Hi Jason,

    Thanks for answer, now everybody told me it's not necessary to changed to port 26. It's that correct, that I will not winning to make it harden to spammers if I change it ?

    Regards

    ZS 


    Exactly. It does not buy you any protection against spammers. Anti-spam software and using DMARC helps against spammers, not changing the port.

    Blog:    Twitter:   

    • Marked as answer by Bosancero Thursday, January 5, 2017 7:18 AM
    Monday, December 26, 2016 3:46 PM

All replies

  • Hi Zlatan,

    Thanks for contacting our forum.

    The command is right. Which port have you changed to ?

    What’s the error message after you changed the port?

    Could you please post out the protocol log in the following path for further analyzing?

    Firstly, increase the logging level of the corresponding Send connector to Verbose

    Path:  C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\Logs\FrontEnd\ProtocolLog\SmtpSend

    Thanks for your effort.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 20, 2016 7:38 AM
    Moderator
  • Why did you change the port? External SMTP servers are expecting you to send on port 25.

    Blog:    Twitter:   

    • Proposed as answer by PK Sarangi Saturday, December 24, 2016 6:32 PM
    • Unproposed as answer by Bosancero Sunday, December 25, 2016 8:42 AM
    Saturday, December 24, 2016 4:15 PM
  • Hi Jason,

    Sorry my late answare. 

    I changed my port to 26 

    When I look at smtpsend folder I can't see a log what happens. But in this case under quene i get this error.

    Identity: xxxxxxx\11\1937030250510
    Subject: test denne burde du modtage
    Internet Message ID: <972950022e7547f8a60307f36a975578@xxxxxxxx.local>
    From Address: xxxxx@xxxx.xx
    Status: Active
    Size (KB): 4
    Message Source Name: SMTP:Default xxxx
    Source IP: xxx.xxx.x.xxx
    SCL: -1
    Date Received: 25-12-2016 09:29:47
    Expiration Time: 27-12-2016 09:29:47
    Last Error: 
    Queue ID: xxxxxx\11
    Recipients:  xxxxl@xxxx.com;2;2;[{LRT=};{LED=};{FQDN=};{IP=}];0;CN=Default-smtp,CN=Connections,CN=Exchange Routing Group (DWBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=XXXExchange Hosting,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=XXXX,DC=local;0

    regards

    ZS


    Sunday, December 25, 2016 8:39 AM
  • Hi Andy,

    Thanks for your answer I change this because security reason. 

    regars

    ZS

    Sunday, December 25, 2016 8:42 AM
  • Hi Andy,

    Thanks for your answer I change this because security reason. 

    regars

    ZS


    What security reason? Like I said, SMTP servers expect you to send on port 25. If you change it to another port, it wont work unless you are sending to a smarthost that is listening on port 26.

    Blog:    Twitter:   

    • Proposed as answer by DineshSMehra Sunday, December 25, 2016 10:58 PM
    Sunday, December 25, 2016 4:09 PM
  • I agree with Andy, SMTP servers always expect port 25.

    Dinesh https://ucservice.blogspot.com

    Sunday, December 25, 2016 10:59 PM
  • Per my test, after changed the port to 26, the messages will be queued in the queues with the error as below:

    Every remote SMTP server that you want to communicate with must be configured to accept connections on the specified port. In most cases, you do not want to change the default port setting.

    Please refer to: https://support.microsoft.com/en-sg/kb/274842

    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Jason.ChaoModerator Thursday, December 29, 2016 1:56 AM
    • Unproposed as answer by Bosancero Thursday, January 5, 2017 7:18 AM
    Monday, December 26, 2016 6:08 AM
    Moderator
  • Hi Andy,

    I have read about it and every body say it's important to changed it so spammers find it harder to send spam mails. I need to try smarthost.

    regards

    zs

    Monday, December 26, 2016 2:09 PM
  • Hi Jason,

    Thanks for answer, now everybody told me it's not necessary to changed to port 26. It's that correct, that I will not winning to make it harden to spammers if I change it ?

    Regards

    ZS 

    Monday, December 26, 2016 2:14 PM
  • Hi Jason,

    Thanks for answer, now everybody told me it's not necessary to changed to port 26. It's that correct, that I will not winning to make it harden to spammers if I change it ?

    Regards

    ZS 


    Exactly. It does not buy you any protection against spammers. Anti-spam software and using DMARC helps against spammers, not changing the port.

    Blog:    Twitter:   

    • Marked as answer by Bosancero Thursday, January 5, 2017 7:18 AM
    Monday, December 26, 2016 3:46 PM
  • Welcome! You're right. It's not recommended to change it.

    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 27, 2016 5:18 AM
    Moderator