Failure to create VPN network connection (unexpected error - device missing - error 711(?) ) in Windows 7 RRS feed

  • Question

  • I'm trying to create a VPN network connection on my Windows 7 PC.
    I was following my ISPs instructions, but it didn't help - the connecition appears in the control panel>network connections window as "unavailable - device missing".  Right-clicking and choosing "properties" brings up an "unexpected error" window.  I think at one point I got an "error 711" somewhere.
    I did the same on an XP PC and it worked fine.
    What is also strange is that when I try to delete this new profile it doesn't go away until I physically disconnect the network cable from the PC - and then it goes away.
    My ISPs tech support are baffled as well - say it's an OS issue.  At least my wireless works...
    Please help
    Sunday, January 17, 2010 7:54 AM


All replies

  • Hi,


    Please refer to the following article to troubleshoot the issue:


    You receive an "Error 711: Cannot load Remote Access Service Connection Manager" error message when you create a network connection







    • Marked as answer by Novak Wu Monday, January 25, 2010 2:44 AM
    Monday, January 18, 2010 8:28 AM
  • I'm having the same problem with setting up a VPN on a Windows 7 Laptop; Dell Latitude D810, Windows 7 Pro, 2.13 Ghz, 2GB mem, Mobile ATI Radeon X600, Intel Pro Wireless 2200/BG.  I'm getting error code:711, even though I have everything setup correctly and as far as services are concerned, all the proper protocals are turned on.  The one's I've turned on, won't start because of the other dependancies which are also turned on, but can't start.....it's this vicious circle and I don't know what else to do....MS needs to do more than just offer up articles to read when we need a real fix or solution for the problem, articles aren't going to fix it.  So if MS would please supply a fix rather than an article, it would be greatly appreciated....TY

    Tuesday, January 26, 2010 12:43 PM
  • Found the fix, its related to Windows Event log not starting causing error 4201 and that leads this service not to start....

    So follow the instructions...

    Renaming or deleting the following folder seems to work for some users:


    REF: Event log error 4201 - ERROR_WMI_INSTANCE_NOT_FOUND (a helluva great thread)

    1) Used msconfig to switch to safe mode boot
    2) Booted to safe mode
    3) ran cmd.exe as an administrator
    4) typed "cd C:\Windows\System32\LogFiles\WMI"
    5) typed "rename RtBackup RtBackup2"
    6) Used msconfig to switch to normal boot mode
    7) Reboot and found event viewer working

    That fixed the issue.

    Here is the link as well...

    • Proposed as answer by TrueTsunami Sunday, September 4, 2011 4:42 PM
    Sunday, February 21, 2010 10:35 PM
  • My Window Event Log service is "started", this does not seem to be the problem
    Monday, February 22, 2010 7:42 AM
  • Thank you so much, Jegan.

    I tried all the classical remedies suggested for these kind of issues (PPP keys registry removing or manually activating RAS services etc....)

    No way.

    It would be really interesting to know which update and/or service is responsible for this Win behavior.

    It occurred on several machines of mines and even on an Seven Ultimate copy running as a guest OS in a Parallels Desktop Virtual Environment.


    All the best

    P.S. I wasn't able to rename RtBackup but anyway I became owner of the folder and took complete control on it.

    It's been enough.....After the reboot, event logging started to work awa VPN, RAS and all the other Network services


    Friday, January 14, 2011 6:57 PM
  • I just want to say thank you! I know you wrote this quite some time ago, but I have been experiencing this issue for 2 months now.  I stumbled upon this article, tried your steps, and now can connect to my work VPN!


    I know it won't mean much, but you are my hero!



    Thank you!!

    Friday, August 5, 2011 2:29 AM
  • I made an account and necrod this thread just to say THANK YOU! You too are my hero.
    not even geek squad had a clue. 
    Sunday, September 4, 2011 4:42 PM
  • JeganMCPD, just want to say thank you for posting your helpful answer on here. That fixed the VPN issue for me. I was completely stumped on trying to get the VPN services to start. 
    Wednesday, November 2, 2011 7:19 PM