locked
Windows Explorer Favorites always open in new window RRS feed

  • Question

  • I am experiencing a problem when left-clicking on Favorites in the Windows Explorer navigation pane. Specifically, Favorites always open -- or try to open -- in a new Explorer window.

     

    This is a problem not simply because I would prefer to use just one Explorer window, but because when I click a Favorite folder in a 'save as…' dialogue (in any application shows the Favorites), nothing happens. I assume this is because Explorer wants to open a new window, but it can't, due to being in a 'save as…' dialogue.

     

    Some information on my setup: it's a desktop PC running Windows 7 Ultimate 64-bit SP1. The ONLY folders affected are the Favorites, and all my Favorites are folders on my PC. As users often say, I'm not aware of having changed any setting that would have affected this, although I did recently need to add the following to the registry, due to the 'Open with' context menu disappearing:

     

    [HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With]
    @="{09799AFB-AD67-11d1-ABCD-00C04FC30936}"

    I'd like to make completely clear that I am not asking how to change the Windows Explorer Folder Options from "Open each folder in its own window" to "Open each folder in the same window". It is already -- and has always -- been set to "Open each folder in the same window". Also, "Launch folder windows in a separate process" is unchecked.

     

    I have searched extensively online for solutions and discovered some suggested registry tweaks, but none of these have been successful. For example:

    As suggested in the third link above, I also ran the Windows System File Checker, which found no errors. I then used ShellExView to disable everything not made by Microsoft. This made no difference. I tried removing Favorite folder shortcuts and creating new ones. I tried restoring defaults in Windows Explorer Folder Options. I even tried resetting internet explorer's options.

     

    I'd appreciate any advice. Thanks in advance!




    Wednesday, May 25, 2011 12:17 AM

Answers

  • Never mind; I reinstalled Windows and the problem hasn't come back (yet).
    • Marked as answer by yanini Tuesday, May 31, 2011 8:29 AM
    Tuesday, May 31, 2011 8:29 AM

All replies

  • A little more information. I compared the registries of my desktop (affected by the problem described above) and my laptop (Win 7 Ultimate 32-bit, unaffected by the problem described above).

    Specifically, I examined the entries under HKEY_CLASSES_ROOT\Folder.

    The only unexpected difference between the computers is that on the desktop, 'Folder' and 'ShellEx' contain capitals, whereas in the laptop's registry they are spelt 'folder' and 'shellex'. (Surely this cannot be the cause of the problem!).

    There are some different shell extensions between the computers (e.g. the desktop has Acrobat X installed) but these have always been present and predate the problem with Favorites opening in new Explorer windows.

    Meanwhile, the contents of HKEY_CLASSES_ROOT\Directory are identical on both computers.

    Can anyone suggest a fix?
    • Edited by yanini Thursday, May 26, 2011 2:25 PM added more info
    Thursday, May 26, 2011 2:23 PM
  • Never mind; I reinstalled Windows and the problem hasn't come back (yet).
    • Marked as answer by yanini Tuesday, May 31, 2011 8:29 AM
    Tuesday, May 31, 2011 8:29 AM