locked
Remove last Exchange 2003 server RRS feed

  • Question

  • When I attempt to uninstall our Exchange 2003 server, I get the following error msg:

    Error message when you try to remove Exchange Server from a mailbox server that no longer hosts mailboxes: "One or more users currently use a mailbox store on this server"

    But I can't any of these mailboxes on the Exchange Home Server column.

    Friday, May 11, 2012 2:03 PM

Answers

  • That seems to have done the trick. Thanks for everyones help...
    • Marked as answer by Nismo350 Monday, May 14, 2012 5:02 PM
    Monday, May 14, 2012 5:02 PM

All replies

  • Friday, May 11, 2012 2:27 PM
  • I have reviewed Article ID: 924170, but still can not file and reference to the mailboxes on the 2003 box. Did you see the image i posted?
    Friday, May 11, 2012 3:22 PM
  • Use instructions on my blog to use blog to filter for the user that never logged into mailbox.

    1. Start ADUC; click find.

    2. Click custom search in drop down

    3. Click Advanced tab

    4. In LDAP field type:


    (msExchHomeServerName=/O=myexchangeorgname/
    OU=myorgname/cn=Configuration/cn=Servers/cn=myexchangeserver)
    (objectClass=User)

    http://msexchangetips.blogspot.com/2008/04/exchange-one-or-more-users-currently.html


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, May 11, 2012 4:49 PM
  • I ran you example and found no results. The 2003 is name Hammer. Here is the query:

    (msExchHomeServerName=/O=HernandoCounty/OU=First Administrative Group/cn=Configuration/cn=Servers/cn=Hammer)
     (objectClass=User)

    Friday, May 11, 2012 5:07 PM
  • To ensure you have the right syntaxt try this instead

    (objectclass=user)(msExchHomeServerName=*Hammer*)

    Also you need to close our your ADUC search because anytime your query is wrong and you fix it it still wont work you have to close out the search box and start over.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, May 11, 2012 5:30 PM
  • Ok, I got a result of 11 users, but none have mailboxes. The only Exchange Tasks is "Remove Exchange Attributes".
    Friday, May 11, 2012 5:45 PM
  • Yup because they never logged into their mailboxes, yes remove the exchange attribs and you should be good.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, May 11, 2012 5:48 PM
  • Ok, I got a result of 11 users, but none have mailboxes. The only Exchange Tasks is "Remove Exchange Attributes".

    Remove em! 
    Friday, May 11, 2012 5:50 PM
  • I removed the attributes and then the user account. They were old test accounts. But still got the same error message.
    Friday, May 11, 2012 6:09 PM
  • If you re-run the query no accounts show up now? Try restarting the information store and re-run the uninstall.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, May 11, 2012 6:24 PM
  • I've rebooted the server and re-run the query with no results. Uninstall failed to run with same error message.

    Friday, May 11, 2012 6:45 PM
  • Did you try the ldp tool referenced in the article I linked?

    Friday, May 11, 2012 7:09 PM
  • Base Dn: DC=co,DC=hernando,DC=fl,DC=us

    Filter: (msExchHomeServerName=*Hammer*)

    Scope: Subtree

    ***Searching...
    ldap_search_s(ld, "DC=co,DC=hernando,DC=fl,DC=us", 2, "(msExchHomeServerName=*Hammer*) ", attrList,  0, &msg)
    Result <0>: (null)
    Matched DNs:
    Getting 0 entries:

    Friday, May 11, 2012 7:18 PM
  • Could there be references to that mail server in other AD domains? I.e. can you set it to another BASE DN?

    Friday, May 11, 2012 7:22 PM
  • ldap_search_s(ld, "CN=Configuration,DC=co,DC=hernando,DC=fl,DC=us", 2, "(msExchHomeServerName=*Hammer*) ", attrList,  0, &msg)
    Result <0>: (null)
    Matched DNs:
    Getting 0 entries:

    Same results

    Friday, May 11, 2012 7:36 PM
  • Can I delete the mailbox store?
    Friday, May 11, 2012 7:40 PM
  • Yeah just hard delete it in adsiedit, doesnt hurt. Go to start, run, adsiedit.msc, expand the configuration partition, services....find your hammer server, expand find the mailstore and right click delete. Then run the uninstall again.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Proposed as answer by Xiu Zhang Monday, May 14, 2012 7:51 AM
    Saturday, May 12, 2012 2:48 PM
  • Can I delete the mailbox store?

    If you are sure there is no mailboxes on there yes.

    However, so you have a pf store as well? If so, I would make sure all the replicas are removed from that server first

    It is supported to manually remove a 2003 server

    http://support.microsoft.com/kb/833396

    However make sure you have covered everything:

    http://technet.microsoft.com/en-us/library/bb288905(v=exchg.80).aspx

    • Proposed as answer by Xiu Zhang Monday, May 14, 2012 7:51 AM
    Saturday, May 12, 2012 3:42 PM
  • Hi,

    How is the issue now? Please feel free to update here.


    Xiu Zhang

    TechNet Community Support

    Monday, May 14, 2012 7:52 AM
  • I was off over the weekend. But I tried the adsiedit option. But still cannot uninstall Exchange through Add-Remove. I've also diasabled the services and tried, failed too. Before I try to manually do it, are there any other ideas?

    Monday, May 14, 2012 1:03 PM
  • Hi

    Once you have deleted the server using ADSIedit you can shut it down.  There is no need to continue to attempt to uninstall Exchange after it has been removed from AD.

    Steve

    Monday, May 14, 2012 1:13 PM
  • Is there a step-by-step kb article (ADSIedit) on the process? And how will that affect my Exch2007 server? Will all my enterprise options now be available?
    • Edited by Nismo350 Monday, May 14, 2012 2:20 PM forgot adsiedit
    Monday, May 14, 2012 2:19 PM
  • Go into adsiedit, right click the server and delete. How does it affect your 2007 server? Well of course when you hard delete it doesn't delete any backlinks, however you can always re-home or fix them if you find any, no biggie. Just delete it.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Monday, May 14, 2012 2:37 PM
  • Please confirm:

    ADSIedit -> Configuration -> Services -> Microsoft Exchange -> Mydomain (HernandoCounty) -> Administrative Groups -> First Administrative Group - Servers (CN=HAMMER)

    Monday, May 14, 2012 2:54 PM
  • Yup, delete cn=hammer.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Marked as answer by Nismo350 Monday, May 14, 2012 5:01 PM
    • Unmarked as answer by Nismo350 Monday, May 14, 2012 5:02 PM
    Monday, May 14, 2012 2:56 PM
  • That seems to have done the trick. Thanks for everyones help...
    • Marked as answer by Nismo350 Monday, May 14, 2012 5:02 PM
    Monday, May 14, 2012 5:02 PM