locked
Load behavior changed automatically for the add-in..Add-in shows up only after next outlook restart RRS feed

  • Question

  • We developed an add-in with load behavior set to 16 so it loads on demand and is faster to load on startup. After couple of upgrades we did for add-in, the add-in does not show first time on outlook restart. Only on next restart we can see add-in.

    this is impacting our installed base so any pointers would help us!

    For our add-in it  shows "load on next startup" Earlier it used to show "Load on demand(currently loaded))

    We have both user exe and per machine msi. issue is with use exe only.


    Friday, August 4, 2017 4:28 AM

All replies

  • Hi,

    Please try to set the LoadBehavior DWord value to 2. The following are the different value settings for theLoadBehavior DWord value:
      • 0 = Disconnect - the COM add-in is not loaded.
    • 1 = Connected - the COM add-in is loaded.
    • 2 = Bootload - the COM add-in loads at Startup.
    • 8 = DemandLoad - the COM add-in loads only when it is requested by the user.
    • 16 = ConnectFirstTime - the COM add-in loads only one time. This COM add-in can do this one time load at the next Startup.

    Best Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 7, 2017 2:21 PM
  • thank you for your response. I assume you meant value of 3 and not 2?

    also, can you share why the behavior changed? Load behvaior 16 was working fine all this while where it would say "Load on demand (currently loaded)". Why did it change to "Load on next startup"? We want to use 16 only as it helps reduce load in time. Please let us know

    Wednesday, August 9, 2017 4:02 AM