locked
Internet explorer 11 deployment issue RRS feed

  • Question

  • Hi,
    I'm trying to deploy internet explorer 11 from ie 8 on windows 7 sp 1 computer using sccm 2012 r2.
    I used Ieak and the ie prerequisite to configure the msi package.
    The application was deployed but fails. Apparently the package still try to download the prerequisite even if they are embedded . how can I accomplish this task ?


    Luca Pozzoli


    • Edited by pozlu0 Monday, November 23, 2015 10:22 PM
    Monday, November 23, 2015 8:56 PM

Answers

  • I can recommend you to deploy Internet Explorer 11 via Software Update instead of a Package / Application. I was in the same Situation as you half a year ago. Prereqs were embedded but the Setup Failed, because it still wanted to download some componentens, which failed if you have a Proxy.

    Another Advantage of Deploying IE11 via Software Update is, that you don't need to care about different languages.


    Simon Dettling | msitproblog.com | @SimonDettling



    • Edited by Simon Dettling Tuesday, November 24, 2015 10:19 AM
    • Marked as answer by pozlu0 Wednesday, November 25, 2015 1:13 PM
    Tuesday, November 24, 2015 10:18 AM

All replies

  • looks like ,the package you created is not fully completed. have you tried running the IE11 package manually first before deploying using Configmgr ? check this guide to correct IE11 package https://social.technet.microsoft.com/Forums/en-US/ea28b55e-6d9e-4e8d-abe9-369c19267d9a/packaging-ie11-prerequisite-updates-with-ieak?forum=ieitprocurrentver .For deployment issues (if manual works ) ,refer appdiscovery.log,appenforce.log (application),execmgr.log(package)

    Eswar Koneti | Configmgr Blog: www.eskonr.com | Linkedin: Eswar Koneti | Twitter: eskonr

    Tuesday, November 24, 2015 2:44 AM
  • Hi Eswar,

     thaks for the reply.

    I am a sccm newbe so for my firs package installation I used this blog

    http://prajwaldesai.com/deploy-internet-explorer-11-using-sccm-2012-r2/

    I tried to execute the package installation manually .

    In the log I see that the product is installed even if it does not.

    I'm confused.

    I attach installation result and packet folder



    Any help would be appreciated


    Luca Pozzoli

    Tuesday, November 24, 2015 9:40 AM
  • I can recommend you to deploy Internet Explorer 11 via Software Update instead of a Package / Application. I was in the same Situation as you half a year ago. Prereqs were embedded but the Setup Failed, because it still wanted to download some componentens, which failed if you have a Proxy.

    Another Advantage of Deploying IE11 via Software Update is, that you don't need to care about different languages.


    Simon Dettling | msitproblog.com | @SimonDettling



    • Edited by Simon Dettling Tuesday, November 24, 2015 10:19 AM
    • Marked as answer by pozlu0 Wednesday, November 25, 2015 1:13 PM
    Tuesday, November 24, 2015 10:18 AM
  • Thank you for the answer,

    It is possible direcltly from sccm or Ihave to use directly  the wsus componet installed ?


    Luca Pozzoli

    • Proposed as answer by Eswar konetiMVP Wednesday, November 25, 2015 2:16 AM
    • Unproposed as answer by Eswar konetiMVP Wednesday, November 25, 2015 2:16 AM
    Tuesday, November 24, 2015 11:30 AM
  • Luca,

    I had exactly the same issue. The pre-reqs still attempt to download from MS. I'm going Software Updates route tbh.


    Cheers Paul | http://sccmentor.wordpress.com

    Tuesday, November 24, 2015 11:40 AM
  • Thank you for the answer,

    It is possible direcltly from sccm or Ihave to use directly  the wsus componet installed ?


    Luca Pozzoli

    To distribute Software Updates using ConfigMgr, you'll need a WSUS. All the Administration Tasks are done within the ConfigMgr Console. WSUS itself is "orchestrated" by ConfigMgr (SUP)

    See: https://technet.microsoft.com/en-us/library/gg682168.aspx

    And: https://technet.microsoft.com/en-us/library/gg712312.aspx


    Simon Dettling | msitproblog.com | @SimonDettling


    Tuesday, November 24, 2015 12:21 PM
  • Thank you for the answer,

    It is possible direcltly from sccm or Ihave to use directly  the wsus componet installed ?


    have you tried this method ? How to create an all-inclusive deployment package for Internet Explorer 11  https://support.microsoft.com/en-us/kb/3061428

    and vbscript method http://www.itninja.com/blog/view/how-to-package-internet-explorer-11-x64-for-windows-7-x64


    Eswar Koneti | Configmgr Blog: www.eskonr.com | Linkedin: Eswar Koneti | Twitter: eskonr


    Wednesday, November 25, 2015 2:16 AM
  • Why not to use a application task sequence?

    Add all the prerequisites to the task sequence, then add the IE 11 standalone installer.
    It will work without any issues.

    http://venusingireddy.blogspot.com.au/2014/06/deploy-internet-explorer-11-sccm.html

    Wednesday, November 25, 2015 5:05 AM
  • Just be aware that if you use Software Updates to deploy IE11 then you will have an unpatched installation. So you will have to wait for a Software Updates evaluation and deployment cycle and subsequent update install and reboot before you get security updates and features like Enterprise Mode.

    There's nothing you can do about this, but you can prepare for this as an issue.

    Cheers

    Damon

    Wednesday, November 25, 2015 7:51 AM

  • It will work without any issues.

    Not true. 

    I'm currently fire fighting an IE11 TS for a customer. Getting these sort of errors http://henkhoogendoorn.blogspot.co.uk/2014/09/internet-explorer-11-prerequisites.html?_sm_au_=icVN5PrJP6HfT0k4. It's not been pretty but this is the route they took. 

    Application Task Sequences are not (as yet) supported by Microsoft. 

    You could try it but I would proceed with caution.


    Cheers Paul | http://sccmentor.wordpress.com

    Wednesday, November 25, 2015 11:40 AM
  • Thank you all for the support.
    I  followed the advice of Simon Dettling and I distributed Ie 11 via  software update rather than as a package in a test enviroment .
    Following  Damon's suggestion I waited for the PC test did some reboots before seeing that i and 11 were installed.


    Luca Pozzoli

    Wednesday, November 25, 2015 1:12 PM