none
consistently getting "Replica is inconsistent" when protecting a SharePoint datasource RRS feed

  • Question

  • Hi All,

    Since a problem with a transaction log disk full, our dpm protection for a SharePoint farm is not working correctly. we're consistently getting "Replica is inconsistent" for the SharePoint datasource. we run a synchronization job with consistency check (we have a lot of content databases so the full check takes about 40 minutes), but a few minutes after the alert disappears, it appears again with same text. this is what we see on the MSDPMCurr.errlog:

    1B64	0D38	09/20	06:13:44.743	27	FsmBlock.cs(178)		472AB17F-9ED4-423D-B6C2-72E932247219	WARNING	Backup.DeltaDataTransferLoop.CommonLoop : RAWriteDatasetDelta, StatusReason = Error (StatusCode = -2147024894, ErrorCode = ApplicatorSyncError, workitem = 1fb650fa-1fb1-4f60-8d39-f3f1e200be9b)
    1B64	0D38	09/20	06:13:44.743	27	FsmBlock.cs(178)		472AB17F-9ED4-423D-B6C2-72E932247219	WARNING	Response: <?xml version="1.0"?>
    1B64	0D38	09/20	06:13:44.743	27	FsmBlock.cs(178)		472AB17F-9ED4-423D-B6C2-72E932247219	WARNING	<Status xmlns="http://schemas.microsoft.com/2003/dls/StatusMessages.xsd" StatusCode="-2147024894" Reason="Error" CommandID="RAWriteDatasetDelta" CommandInstanceID="b803b265-a2af-43cb-8be8-846d755c6be8" GuidWorkItem="1fb650fa-1fb1-4f60-8d39-f3f1e200be9b" TETaskInstanceID="472ab17f-9ed4-423d-b6c2-72e932247219"><ErrorInfo xmlns="http://schemas.microsoft.com/2003/dls/GenericAgentStatus.xsd" ErrorCode="536900934" DetailedCode="-2147024894" DetailedSource="2"><Parameter Name="AgentTargetServer" Value="<name of the dpm server here>"/><Parameter Name="FileName" Value="<path to the sql file>\MSS_ADMIN_Content.mdf"/></ErrorInfo><RAStatus><RAWriteDatasetDelta xmlns="http://schemas.microsoft.com/2003/dls/ArchiveAgent/StatusMessages.xsd" BytesTransferred="262144" NumberOfFilesTransferred="0" NumberOfFilesFailed="0" DataCorruptionDetected="false"/></RAStatus></Status>
    1B64	0D38	09/20	06:13:44.743	27	ReplicationLoop.cs(251)		472AB17F-9ED4-423D-B6C2-72E932247219	WARNING	DataTransferLoop [RAReadDatasetDelta, RAWriteDatasetDelta]: FAILURE -- RAWriteDatasetFailure
    1B64	0D38	09/20	06:13:44.758	27	Replica.cs(983)		472AB17F-9ED4-423D-B6C2-72E932247219	WARNING	MARKING REPLICA INVALID - Function = [TaskErrorHandler.LogErrorForReplication], Reason = [ErrorCode for Invalid Replica = [RmCannotApplyChanges]], ReplicaId = [9d255aef-058a-400b-a004-72b88ad4264a]

    The eventid is full of events 3114, "The replica of ....\MSS_ADMIN_Content on <db server> is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check (ID:3106). Changes on .... cannot be applied to ....\MSS_Admin_Content.mdf (ID:112)"

    It looks like the ID 112 is The System cannot find the file, which I have logically checked. the file is there. 

    the only modification done after the disk full problem was to move the LDF file to another disk (the problem here seems to be with the MFD file).

    File path is not very long, some 80 characters. Antivirus on the server excludes all the drives and folders containing sql server databases.

    I have run out of theories about what is happening. can someone shred some light on this problem? I would be very appreciated.



    • Edited by Roberto MD Thursday, September 20, 2012 9:54 AM
    Thursday, September 20, 2012 9:05 AM

All replies

  • Hi all, we have identified the source of the problem. We had to move a transaction log of the sharepoint mss_admin_content database to another disk because it was growing big and filling the previous one. From that moment, it looks like DPM is still trying to search the file on its original location, and then fails. same error for the MSS_Config_Content database.

    We have tried moving the tranlog again to the previous location and retry the replica, but unfortunately this does not work. We also tried to stop protection (keeping data) and restarting protection, with no luck; so it looks that the only way to get rid of this is to recreate the protection group (and loose all the backed up data!!!).

    Regarding this issue, is there any way to recreate a protection group by "parking" somehow the current data and retaking it after creating from scratch the protection group?

    Thanks

    Wednesday, October 24, 2012 10:00 AM