locked
Excel, Word - save as, save directly to Sharepoint - only possible to save to local disk drive RRS feed

  • Question

  • hello,

    I am having a hard time trying to find out why or when it is possible to
    1. open an office document (Word, Excel) from a sharepoint document library (open with excel or clicking onto it for the web view and then click "open with excel")
    2. editing it in the office client
    3. saving it back DIRECTLY to Sharepoint via "save" or "save as"

    The problem ist, on some configurations of machines and office versions you only get the "save as" dialog for saving to local disk - you don't see the content of the sharepoint site (only Favorites, Desktop, Documents, Pictures, Computer..)
    Despite that, on some systems you CAN use "save" to update the office document directly on the sharepoint library. Just "save as" doesn't work. On other systems even save doesn't work. (dialog "save as" to local disk appears)

    I have client pcs here with office 2003, 2007, both and a server with 2010. The 2003 mostly works, a pc with 2007 doesn't - yet you can "save as" by entering the sharepoint doc library URL into the local path input box. After that a new menu item appears in word 2007 "file / server / [4 menu items: check-out, versioning, workflow,  document mangement information, excel services]". That menu item disappears after closing the program. As long as you do not close the program, "save as" now shows the SP lib content.
    Do you have some information on when such behaviour can occur ?
    Thanks, Robert

     

    Wednesday, December 15, 2010 1:36 PM

All replies

    • Marked as answer by Stanfford Liu Thursday, December 23, 2010 10:00 AM
    • Unmarked as answer by Robert Hl Wednesday, January 19, 2011 12:01 PM
    Friday, December 17, 2010 6:16 AM
  • hi Liu, thank you for the information.

    Unfortunately it didn't help me figuring out in which cases it will be -possible- to save directly to sharepoint and in which cases not.

    My problem is not knowing how to publish a file from excel/word, but , that on some machines I can "save" or "save as" without problems (I see the content of the sharepoint library in the "save as" window), and on some maschines I only get the "save as" to local drives Dialog, and entering the sharepoint server/library address into the file name window doesn't work either. (I think I had a machine where entering the address worked - to get the contents of the remote sharepoint folder to save the new excel file into)
    Even though the office version installed is the same - or even higher, like 2007, and still it doesn't work - trying to access the same sharepoint site on the same sharepoint server as from the other computer - that, for example, only has office 2003 + 2007 comp.pack installed.

    As far as I know I need at least Office (e.g. excel) 2003 with the office 2007 compatibility pack installed (I have tested that positive on some machines). In other cases even office 2007 doesn't work (you simply cannot see the content of the sharepoint library after clicking on "save as" - and you cannot enter the sharepoint server address into the filename box - excel won't find the sharepoint library or the sharepoint server to save to, so it only displays the "save as" to local disc / local computer dialog box.
    Could this also be related to the following problem?

    I also have the problem that "open with explorer" does not work:
    "\\server-fqdn\sitename cannot be accessed. you may not have the proper rights to access these network ressources. please contact your server administrator..  the network name/path could not be found." (translated by myself from german)

    and on a pc that works with this eplorer view (a Win xp prof. SP3 machine with office03+07), I see the folder address in explorer as "http://server..." (which should mean that FPRPC is used for explorer view and not WebDAV ?
    I also tried the WebDAV Update for WinXP, no change. Also tried changing WebDAV settings on the sharepoint server, like deactivating it beacause sharepoint does WebDAV by itself, as I read? No change here either. The explorer view address is "http://.."

    I cannot say for sure which pc works with direct save to sharepoint from excel, and if it is the same pc's that cannot open the explorer view, but I think this could be related?

    ok, thank you very much!
    Robert

    Wednesday, January 19, 2011 1:26 PM
  • hello,
    does anyone have a solution here ? would be great, thank you very much!

    Robert

    Thursday, January 27, 2011 1:34 PM
  • does anyone please have some additional information? It really isn't easy to track down the issue as there are several different behaviours on different machines here. The thread posted by Stanfford Liu (thank you by the way, Liu !) didn't really solve the problem we have here to reliably set up this function in our company - the behaviours are different on different machines, and sometimes it is like this function is working better with office 2003 + 2007 compat.pack than on earlier versions..

    thank you very much !
    Robert

     

    Friday, February 11, 2011 10:06 AM
  • Friday, December 2, 2011 12:13 PM