none
What do I need to do to set the Date Format in MIM RRS feed

  • Question

  • Hi,

    I'm looking at the Employee End Date field and I want it to be in format dd/mm/yyyy. Through my searches, I've found mentions that MIM will take your regional settings, however I've had no luck. I also saw there was a bug in some SP1 releases that meant the format was not being used but I'm using SP2.

    So far I've tried

    - Setting the date format in control panel

    - Setting the Regional Settings of the SharePoint Site

    - Setting .Net Globalization in IIS for the MIM Site

    If the value comes from the OS, which exact setting needs to be set? Where does MIM pull the value from?

    Thursday, March 12, 2020 1:31 AM

All replies

  • I found the answer. I wasn't setting it properly in Control Panel.

    First I went to Control Panel | Region | Change Location and changed to my country there.

    The I went to Control Panel | Region | Change date, time, or number formats and in the drop down at the top chose my countries version of English.

    Applied that, did an IIS reset and it was good to go. Not sure if my other settings may have also had an effect.

    Thursday, March 12, 2020 1:38 AM
  • Hi Dan

    I'm stuck with the same thing on and SP2 new installation.  It's been very frustrating.  Been on the same journey but have not yet got it sorted.  Tried what you suggested.  Have changed both location and country for number formats.  Have also done the whole regional settings, Copy Settings to apply the settings to new users and the system.  Still no luck.

    I have noticed that the Display Language is English (United States) but my Format Language is my local locale.

    Any other ideas?  I've got 2 servers doing the same thing (Server 2019 and Server 2016)



    Cheers, Adrian

    Thursday, March 19, 2020 7:08 PM
  • Hi Adrian,

    Sorry that change in my second post seemed to have done it for me. I thought maybe my other changes had an effect so I just tried rolling them back and the date remained in the right format so it really just seems to be those two settings in in control panel that is doing it for me. I have a colleague who's tried the same thing in another environment and has seen the date format not update also. There was a bug in MIM where it ignored Australia but that was way before SP2.

    Friday, March 20, 2020 3:32 AM