locked
Cannot fully update my distribution point(LAB) RRS feed

  • Question

  • hello,

    using BDD 2007 and WDS for xp deployments

    i'm trying to add new NIC drivers(they will not connect to my distribution point), and after i add new drivers i try to right click my distribution point and i select UPDATE, (to create a new windows PE image or what not)...during the update it fails on ""generating windows PE source director""....which is about 25% full on the status bar

    so probably since the distirbution point(*LAB) is not fully updating, it probably is not using or ready to use the new drivers i added correct?

    here is the error....

    can anyone diagnose?

     

    Checking share Distribution$ on \\NETAPP
    Share \\NETAPP\Distribution$ created.

    Starting: copy "C:\Program Files\Windows AIK\Tools\PETools\x86\bootmgr" "C:\Distribution\Boot\x86\bootmgr" /y >> "C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\DeployUpdates_x86.log" 2>&1
            1 file(s) copied.

    Exit code = 0

    Starting: mkdir "C:\Distribution\Boot\x86\Boot" >> "C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\DeployUpdates_x86.log" 2>&1
    A subdirectory or file C:\Distribution\Boot\x86\Boot already exists.

    Exit code = 1

    Starting: xcopy "C:\Program Files\Windows AIK\Tools\PETools\x86\Boot" "C:\Distribution\Boot\x86\Boot" /s /e /i /y >> "C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\DeployUpdates_x86.log" 2>&1
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\bcd
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\boot.sdi
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\bootfix.bin
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\etfsboot.com
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\fonts\chs_boot.ttf
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\fonts\cht_boot.ttf
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\fonts\jpn_boot.ttf
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\fonts\kor_boot.ttf
    C:\Program Files\Windows AIK\Tools\PETools\x86\Boot\fonts\wgl4_boot.ttf
    9 File(s) copied

    Exit code = 0
    Copying C:\Program Files\Windows AIK\Tools\PETools\x86\WINPE.WIM to C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\winpe.wimMounting image to C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\PE20_mount.x86Installing optional components.
    Starting: "C:\Program Files\Windows AIK\Tools\PETools\peimg.exe" "C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\PE20_mount.x86\windows" /install=*Scripting* /quiet >> "C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\DeployUpdates_x86.log" 2>&1
    Preinstallation Environment Image Setup Tool for Windows

    Copyright (C) Microsoft Corporation. All rights reserved.

     

    Unable to load DLL dependency: msxml6.dll (Status 0x8007007e)

    PEIMG was unable to load a DLL dependency.  Please check to ensure

    cbscore.dll, wcp.dll, dpx.dll, smipi.dll, smiengine.dll, cmiadapter.dll,

    msxml6.dll and msxml6r.dll are available on your system in the PATH. 

    The cbscore.dll and wcp.dll files should be located in the same

    directory.

     


    Exit code = 126
    Exception occurred generating Windows PE image:
     System.Exception: PEIMG failed, rc = 126.  See C:\DOCUME~1\rderenzy\LOCALS~1\Temp\1\DeployUpdates_x86.log for more information.
       at Microsoft.BDD.ConfigManager.PEManager.Generate()

    Tuesday, March 15, 2011 8:01 PM

Answers

  • was missing two DLL files for some reason, added and my dp fully updated
    • Marked as answer by derenzy Wednesday, March 16, 2011 8:47 PM
    Wednesday, March 16, 2011 8:47 PM