locked
Error 4010 running integration services 3.4 RRS feed

  • Question

  • Hello, I've a CentOS 6.3 x64 running in Hyper-V 2012. Integration services 6.4 are installed, and server seems ok. Virtual nic is working well too.

    Hyper-V reports the 4010 error

    Hyper-V Data Exchange connected to virtual machine 'server', but the version does not match the version expected by Hyper-V. Framework version: Negotiated (3.0) - Expected (3.0); Message version: Negotiated (3.0) - Expected (4.0). This is an unsupported configuration. This means that technical support will not be provided until this problem is resolved. To fix this problem, upgrade the integration services. To upgrade, connect to the virtual machine and select Insert Integration Services Setup Disk from the Action menu.

    How can I fix this?

    thanks

    • Moved by BrianEhMVP Friday, January 18, 2013 4:14 PM
    Friday, January 18, 2013 11:29 AM

All replies

  • Did you tried installing/upgrading integration service?

    Did you upgraded OS on the Hyper-V server after creating VM.

    Friday, August 16, 2013 6:55 PM
  • I've not installed integration services on this VM: kernel included in CentOS 6.x provides yet them bundled


    • Edited by Trapulo Monday, August 19, 2013 10:53 AM
    Monday, August 19, 2013 9:51 AM
  • A couple of things:

    1)  CentOS 6.0 thru 6.3 does not include the Linux Integration Services (LIS) built-in.  Only CentOS 6.4 and later include LIS built-in.   For CentOS 6.0 thru 6.3, you do need to download the LIS package from Microsoft and install it into your Linux kernel.

    2)  But assuming you do have LIS installed, you can ignore messages about version mismatches and unsupported configurations.  There are some known issues in the way LIS and Hyper-V are interacting over version numbers, and unfortunately we haven't gotten them fixed.   But these are just version checking issues and don't reflect an actual problem.  So if LIS is installed and the NIC is working fine, then you are good, and you would be fully supported through whatever Microsoft support channels you have contracted for.


    Michael Kelley, Lead Program Manager, Open Source Technology Center

    Monday, August 19, 2013 3:35 PM
    Moderator
  • Thank you.

    Just an addendum: I've a CentOS 6.4 running LIS from built-in Linux kernel, over hyper-v 2012.

    It reports:

    A storage device in 'OTRS' loaded but has a different version from the server.  Server version 5.1  Client version 4.2 (Virtual machine ID FB3B10AF-F287-4D00-AFF7-8652D86C7F77). The device will work, but this is an unsupported configuration. This means that technical support will not be provided until this problem is resolved. To fix this problem, upgrade the integration services. To upgrade, connect to the virtual machine and select Insert Integration Services Setup Disk from the Action menu.

    Is this also ok?

    thanks

    Thursday, August 22, 2013 7:58 AM