none
Server 2008 RODC Event 8194 Group Policy Local Users and Groups

    Question

  • I have a RODC at a remote office logging the following error every time it tries to apply group policy (some data replaced with *s):

    Log Name:      Application
    Source:        Group Policy Local Users and Groups
    Date:          5/22/2012 3:01:51 PM
    Event ID:      8194
    Task Category: (2)
    Level:         Error
    Keywords:      Classic
    User:          SYSTEM
    Computer:      MP3SPPC-A.*****.***

    Description:
    The client-side extension could not remove computer policy settings for 'Default Domain Policy {31B2F340-016D-11D2-945F-00C04FB984F9}' because it failed with error code '0x8007000d The data is invalid.' See trace file for more details.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Group Policy Local Users and Groups" />
        <EventID Qualifiers="34305">8194</EventID>
        <Level>2</Level>
        <Task>2</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-05-22T19:01:51.000Z" />
        <EventRecordID>191520</EventRecordID>
        <Channel>Application</Channel>
        <Computer>MP3SPPC-A.*****.***</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data>remove</Data>
        <Data>computer</Data>
        <Data>Default Domain Policy {31B2F340-016D-11D2-945F-00C04FB984F9}</Data>
        <Data>0x8007000d The data is invalid.</Data>
      </EventData>
    </Event>

    Here is the data from SYSVOL\domain\Policies\{31B2...}\MACHINE\Preferences\Groups\Groups.xml:

    <?xml version="1.0" encoding="utf-8"?>
    <Groups clsid="{3125E937-EB16-4b4c-9934-544FC6D24D26}"><User clsid="{DF5F1855-51E5-4d24-8B1A-D9BDE98BA1D1}" name="Administrator" image="2" changed="2011-12-12 15:21:30" uid="{85796DE2-1ACF-4FF5-BBBC-FA999464D56D}"><Properties action="U" newName="*******" fullName="" description="" cpassword="*********" changeLogon="0" noChange="0" neverExpires="0" acctDisabled="1" subAuthority="" userName="Administrator"/></User>
    </Groups>

    The policy was (I believe) last edited on a 2008R2 server, but this is the only non-R2 server having the error. Our 3 primary DCs are all non-R2 and not showing this error.

    How do I resolve this?

    Thanks

    Tuesday, May 22, 2012 7:38 PM

Answers

  • Hi,


    Please try to delete the following registry key from the problematic servers to test:
     
    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\History


    In addition, please install the following hotfix:


    Some Group Policy preferences are not applied successfully on computers that are running Windows Vista, Windows Server 2008, Windows 7 or Windows Server 2008 R2
    http://support.microsoft.com/kb/979731


    Hope this helps!

    Best Regards
    Elytis Cheng

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Elytis Cheng

    TechNet Community Support

    • Marked as answer by cvlowe Wednesday, May 23, 2012 1:58 PM
    Wednesday, May 23, 2012 2:21 AM
    Moderator

All replies