locked
Sharepoint Checked Out Word Document Cross Reference Error on Page number Only RRS feed

  • Question

  • Hi,

    I see the same error as RHABALA reported in an earlier thread, after I check out my Word Document from Sharepoint into Word 2010. 

    When I Control-click on any of my Cross References to Page Number, they fail with the warning prompt, they seem to be incorrectly pointing at the Sharepoint path. But when I Control-click an any Cross References to Paragraph Numbers,  they still work. I've added my Sharepoint Site to the trusted list in Internet Explorer, as recommended in that thread, but no difference, the error persists.

    Grateful for your assistance.

    Thanks

    Friday, December 3, 2010 6:14 AM

All replies

  • > I see the same error as RHABALA reported in an earlier thread

    Unless you give us the URL of the thread in which RHABALA reported on an error, we have no way of knowing (beyond searching all his posts in both msdn and technet) which "same" error that was. Without that info, the whole first sentence is unnecessary.

    - If you have a new question please don't refer to old posts and instead describe your problem fully.

    - If you have additional info to an existing (and fairly recent) thread please post a reply to that thread not a new thread.

    - Only if you have a follow-up to an old, closed thread should you refer to it in a new post/thread with its URL.

     (Moderator)

    P.S. I have found that other thread here http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/1933a3d8-36d4-4237-afe9-25f38316b8ef/#43bd54fb-8610-4a23-ba71-dd66d79cf139

    You had posted the same question in that already closed (in Feb 2010) thread that you (also) posted here. Such duplication wastes forum readers time. I have deleted the duplicate post in that thread.

    In future

    EITHER Make a new thread OR add a reply to a thread. Don't do both.

    (Ground rules: Create a new thread if the existing thread is not current and/or is closed, Add a reply to a thread that is recent and not closed.)


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    • Edited by Mike Walsh FIN Friday, December 3, 2010 6:45 AM P.S. added.
    Friday, December 3, 2010 6:40 AM
  • Hi Mike,

    Thank you for clarifying the ground rules, and cleaning up my garbled entry. I must admit this is my first attempt at reporting on this forum.

    My apologies for any confusion caused; I hope my question makes more sense to forum readers now.

    Regards,

    Michael

    Monday, December 6, 2010 6:13 AM
  • Hi mike_bug,

    Thanks to share your problem.

    Please try to disable the Office Document Cache handler in IE > Tools > Programs > Manage add-ons > Microsoft Corporation part.

    If it didn’t work please try http://support.microsoft.com/kb/925757 to disable hyperlink warning messages. A little different for Office 2010 is the location is ….Office\14.0 and 12.0 is for Office 2007.

    Because I haven’t come across this issue, so I can’t do the test.

    Please let me know the result. Thanks.


    Best regards. Emir
    Wednesday, December 8, 2010 11:44 AM
  • Hi Emir,

    Thank you for your response.

    Regarding KB925757 I believe we have already tried this one - Lily Wu also advised it was not necessary (see thread http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/1933a3d8-36d4-4237-afe9-25f38316b8ef/#43bd54fb-8610-4a23-ba71-dd66d79cf139).

    I went to disable the Office documents Cache handler - but did not seem to have the same menu structure as you mentioned. Perhaps because I am on IE7?

    Anyway, thanks again for your suggestions.

    Regards,

    Michael

    Thursday, December 9, 2010 6:33 AM
  • Hi mike_bug,

    Sorry, I left some steps in my first reply.

    It should like this: Open IE > Tools > Internet Options > Programs > Manage add-ons > Disable Office Document Cache handler (under Microsoft Corporation).

    I think these settings are almost the same in IE7 and IE8. Please have a try.

    Sorry for the inconvenience and thanks.


    Best regards. Emir
    Thursday, December 9, 2010 7:39 AM
  • Hi Emir,

    Thanks for clarifying, I was successfully able to disable the Office documents Cache hander this time.
    However, the behaviour of the cross-referencing remained unchanged. Paragraph cross-references still work fine, but page cross-references fail.

    To reproduce this error, please run the following:

    1. In Word 2010, create a document called "outline.docx".
    2. Switch to Outline view, and create a multilevel list selecting the format with "1. Heading 1", "1.1 Heading 2", "1.1.1 Heading 3" (and so on).
    3. Type in Level 1 text "First" as paragraph "1";
    4. Type in Level 2 text "First Sub" paragraph "1.1".
    5. Insert a page break (CTL-enter).
    6. On the second page, Type in Level 1 text "Second" as paragraph "2";
    7. Type in Level 2 text "Second Sub" as paragraph "2.1".
    8. Start a new line in body text under paragraph 2.1.
    9. Type in “See Section” then hit the space bar, and click on “References” tab.
    10. Click on “Cross Reference” icon.
    11. From the dialogue box select “Reference type” of “Numbered Item” and for “Insert Reference to” select “Paragraph Number”.
    12. Leave “Insert as hyperlink” checked.
    13. Under “For which numbered item” click on “1.1 Second”.
    14. Click on the “Insert” button.
    15. Click anywhere in the Word Document to return to the body text line (the dialogue box should stay open).
    16. Press the space bar, type “on page” then hit the space bar again.
    17. Click in the dialogue box, leaving all options unchanged except for “Insert Reference to”.
    18. Change “Insert Reference to” to “Page Number”.
    19. Click on the “Insert “ button.
    20. Click on the “close” button.
    21. The body text should now read “see Section 1.1 on page 1”.
    22. Hold down CTL and click on “1.1” after “Section”. This will take you to the first page.
    23. Go back to the body text on second page.
    24. Hold down CTL and click on “1” (after page). This will take you to the first page.
    25. Save “outline.docx”
    26. Upload “outline.docx” into Sharepoint.
    27. Check “outline.docx” out of Sharepoint.
    28. Open the checked-out version of “outline.docx”.
    29. Repeat step 22. This should work.
    30. Repeat step 24. This should fail.

    Thanks again for your help.

    Michael

    Friday, December 10, 2010 4:18 AM