none
Windows 7 domain users cannot access network share

    Question

  • AD domain is Windows Server 2008 R2; domain is mixed Windows XP Pro and Windows 7 Pro clients. Users have drive maps via GPO to 3 network shared (home folder, shared volume and apps volume - in that order). XP clients can access all three; most of the Win 7 clients can only access the first and third mapped drives; the second one appears with a red "X" over the drive icon.

    I have found several posts that indicate their users are still able to access the x-ed out drive by clicking on it. In our case, attempting to access the drive prompts the user to enter logon credentials to authenticate to the file server. All of the connect failures are Windows 7 machines (all with the same image and same hardware configuration), but not all of the Windows 7 machines fail - though most do.

    Sunday, September 18, 2011 9:15 PM

Answers

  • Hi,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 6, 2011 1:27 AM
    Moderator

All replies

  • Hi,

     

    According to your description, I suggest to perform these tests to troubleshoot the issue:

    1 Temporally disable firewall and antivirus program on Windows 7

     

    2 Clean credential on Windows 7 in Credential Manager, then add the correct credential to access the server

     

    3 Try to use \\ipaddress\\sharefolder or \\servername\\share to access network share on Windows 7

     

    4 Manually map network share on Windows 7:

    http://windows.microsoft.com/en-US/windows7/Create-a-shortcut-to-map-a-network-drive

    Or use command:

    net use x: \\computername\sharename /persistent:yes

     

    5 Open gpedit.msc on Windows7, go to Local Policies | Security Options and choose the "Network Security: LAN Manager Authentican Level" item
    Set it to "Send LM & NLTM, use NTMLv2 session if negotiated"

     

    Furthermore, this KB may helpful to you:

    Mapped Drive Connection to Network Share May Be Lost

    http://support.microsoft.com/kb/297684

     

    Hope that helps.

     

    Regards, 

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, September 19, 2011 1:59 AM
    Moderator
  • Thanks for the quick reply. Here are the details:

    1. Disabled McAfee; Windows Firewall is already disabled via GPO. Same result.

    2. Credential Manager cleared.

    3. Not possible. Student accounts are blocked via GPO from accessing network resources via UNC path. In addition, when logging on under a staff account, I can consistently access the Shared volume with no problem. 

    5. Made the indicated change to LSP, then refreshed GP. Logged on & still got the red "X".

    4. Cannot manually map the drive under a student account, and no need to do so under a staff account since the GPO succeeds for staff. I can try the 'net use' in a logon script for students, though. Will it process before or after the drive map GPO?

    On a side note, I created a folder with data in the Apps volume (which maps AFTER the Shared volume for the students). On every Windows 7 machine tested, students had no problem with accessing the data there. (They also have had no problem accessing data in their home folders, which is the first mapped drive).

     

     

     

    Monday, September 19, 2011 5:52 PM
  • Hi,

    Try to enable the GP on Windows7:
    Always wait for the network at computer startup and logon

    Computer Configuration/ Administrative Templates/ System/ Logon

    If it doesn’t help, please try this method:
    configure the EnableLinkedConnections registry value, follow these steps:


    1 Click Start , type regedit in the Start Search box, and then press ENTER.
    2 Locate and then right-click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    3 Point to New , and then click DWORD Value . 4 Type EnableLinkedConnections , and then press ENTER.
    5 Right-click EnableLinkedConnections , and then click Modify .
    6 In the Value data box, type 1 , and then click OK .
    7 Exit Registry Editor, and then restart the computer."

    You can apply the registry key via GPO in Server 2008 under Computer Configuration\Preferences\Windows Settings\Registry.  In here right-clicked in the white space and clicked New > Registry entry, and filled out the fields.


    Hope that helps.

    Regards,
    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 20, 2011 2:36 AM
    Moderator
  • 1. The default domain policy is already configured to always wait for the network at startup and logon.

    2. I will give this a try.

    Thanks for all your help so far!

    Tuesday, September 20, 2011 1:04 PM
  • If you have tried the suggestion two, please let me know if it works.

     

    Thank you for your cooperation.

     

    Regards,

    Leo   Huang

     

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 21, 2011 1:38 AM
    Moderator
  • Over the last two days, the GPO pushing the registry change appears to have had no effect in resolving the issue. On a specific computer, one user is able to access the shared volume; the next user who logged on got the red "X" over the share.

    Both users are members of the same two AD security groups (Domain Users and a specific user group)

    The user group they are members of also holds all of the XP users who never see the failure; this group is where the permissions to the share are being applied

    Am I overlooking something? Any other suggestions?

     

    Friday, September 23, 2011 2:08 PM
  • Hi,

     

    Thank you for your update.

     

    The issue is quite odd, I suspect the issue is not the networking problem, but related with the permission of the share folder.

     

    You can try to  temporally promote the permission of the problem user, put it to higher permission group for test.

     

    Furthermore, when the mapped drive with red “X” appear, you can also double click it. The mapped drive will reconnect.

     

    Regards,

    Leo   Huang

     

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, September 26, 2011 9:30 AM
    Moderator
  • 1. If a user is unable to access the shared volume from both a Windows 7 and XP computer, I can see where permissions might be the cause of the failure. However, the users who are unable to access the volume from Windows 7 computers have NO problem accessing the share from XP computers.

    2. In another instance, I have seen a user log on to two adjacent Windows 7 computers. On the first one, the shared volume had a red "X"; on the second one, he was able to access the volume with no problem.

    3. When the shared volume displays the red "X" over the drive icon, double-clicking it does not reconnect the drive. Instead, a logon window appears prompting the user for credentials to authenticate to the file server - which, in fact, is the same file server that hosts the user's home folder (that connects without fail) and the apps volume (which also connects without fail).

    Monday, September 26, 2011 12:21 PM
  • Hi,

     

    When the shared volume displays the red "X" over the drive icon, double-clicking it does not reconnect the drive. Instead, a logon window appears prompting the user for credentials to authenticate to the file server

     

    What the result when you input the user credential to the box?

     

    You may try to create a logon script to map the network share for these users for test.

     

    Net user z:\\server\sharefolder

     

    Since GPO applied before machine startup script and user logon script, you can temporally disable this GPO to map share folder.

     

     

    Regards,

    Leo   Huang

     

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 27, 2011 9:50 AM
    Moderator
  • Hi,

     

    Did your issue solved? Please feel free to give me any update.

     

    Thanks.

     

    Regards, 

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, September 30, 2011 8:43 AM
    Moderator
  • Hi,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 6, 2011 1:27 AM
    Moderator
  • I changed my firewall on System 1 (Windows 7), after which System 1 could see Systems 2&3 (Win XP systems), but neither 2 nor 3 could see System 1.

    On System 1, I could not Local Security Policies.

    Any help would be appreciated.

              CMA

    Tuesday, December 27, 2011 7:25 PM
  • Thank you Leo.

    I mapped via the IP Address instead of the Netbios name and it worked.  19 users were able to map from the server name, but this one user would get access denied.  I mapped him via IP address of the server and it works.

    Thanks,

    ZNS


    Monday, June 24, 2013 4:03 AM
  • Stored credentials ended up being the issue we had.  Thank you for pointing me in the right direction.
    Monday, June 26, 2017 6:51 PM