locked
Exchange 2007 not delivering NDRs when using an external SmartHost RRS feed

  • Question

  • Background:

    Exchange Server 2007 (EXCH) behind a Sonicwall Email Security (SEMS)behind a Sonicwall Firewall. No Exchange anti-spam plugins. All email, except internal within the Exchange Server itself, goes through the SEMS.

    SEMS employs Bounce Address Tag Verification (BATV) to block NDR back scatter and does ALL SPAM filter/blocking.

    Application Server (APPS) sends customers (OPT IN) monthly account notices via SEMS (as smart host) and using a return email address that is a distribution group in Exchange.

    It used to be if an end user sends an email to an invalid external email address (either bad user at valid domain or invalid domain) they got an NDR.

    If an email is addressed to the distribution group it gets delivered to the members.

    The problem:

    1) If APPS sends to an invalid external address the SEMS logs show the NDR arrives at EXCH but never gets delivered to the members.

    2) Now, no NDRs are delivered to the sending users.

    The problems apply if the SEMS generates the NDR as part of the conversation (or attempted conversation)with the destination server or if the destination server accepts the email and then later sends its own NDR.

    TIA.

    Tuesday, April 12, 2011 3:14 PM

Answers

  •  

     

    Hi,

     

    Can the email user get the NDR now when sending the email to invalid external email address? If you temporarily turn off the SEMS, can you obtain NDR?

     

    At this stage, I suggest you refer to the following steps to assure that NDR is enabled.

     

    1. Open the Exchange Management Console

    2. Expand the Organization Configuration folder

    3. Click on Hub Transport

    4. Select Remote Domains and select Properties.

    5. Right-click the Format of original message sent as attachment to journal report tab

    6. Click on the Message Format

    7. Assure “Allow delivery reports” and “Allow non-delivery reports” options are selected.

     

    Thanks.

    Novak


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Novak Wu Monday, April 25, 2011 2:25 AM
    Monday, April 18, 2011 3:06 AM