none
Error while installing Microsoft Assesment and Planning tool RRS feed

  • Question

  • Can any one help while installing Microsoft Assesment and Management and Planning.I am using Win XP with Service Pack 3 While installing MAPI i am getting the following error.

    All Prequisite are installed.The only Prequisite its asking is Computer restart.The SQL Server database instance cannot be installed or removed when a restart is pending.Please restart the local computer and rerun the setup wizard.
    Wednesday, September 30, 2009 5:50 AM

All replies

  • What happened when you restarted and reran the setup wizard?

    -Eric
    Wednesday, September 30, 2009 5:53 PM
  • I have the same problem and others are too.  I have tried installing this program on approx 5 XP workstations and they all have the same problem detailed above.  The only reason I'm trying on XP machines is my Win 7 installed it fine but errors out when trying to Prepare New Reports and Proposals.  I am ready to give up on this program as it has been extremely frustrating trying to make it work for the better part of 2 days. 

    * I've tried restarting
    * most of the computers have no SQL installed
    * I've gone through the registry trying to remove reboot flags

    It's suprising to me that I've read at least 3 other people with the same problem and the responses are mostly disbelief that this is happening or that their computers must be really screwed up.  I apologzie for venting ...
    Tuesday, February 9, 2010 7:56 PM
  • I understand your frustrations…and have experienced them personally.

     

    Just to explain the situation a little bit for you:  The problem here is issues with SQL install.  Which this being just the MAP product, we can’t really help out too much.  MAP has been coded to respond to a number of the more common generic SQL install errors but there is no way that we can even know the full range of SQL install errors.  SO when we encounter SQL install errors we have a couple of different paths to try to get the application running, one of them being the one you’re hitting which is what SQL setup has communicated to MAP setup.

     

    Once you get into an endless loop of SQL install errors there is nothing I can do other then suggest completely removing every evidence (add/remove, folders and registry) of SQL and try again.  Still having that issue then you will have to contact SQL support for further investigation.

     

    Thanks,

    Eric

    Tuesday, February 9, 2010 8:28 PM
  • Thanks for the quick response Eric, I do appreciate it. 

    We did discover by installing the SQL Express Edition 2008 (free web edition) before running the setup for MAP on one of the computers the problem was resolved.  I am trying on my Windows 7 pc but I hope that may help others.

    Jon
    Tuesday, February 9, 2010 9:20 PM