none
Disable USB drive

    Question

  • Hello ALL

    we are using 2012 R2 DC and want to disable the USB divices in all the client machines

    i found the path as below, however i am not able to find system under Administrative Temp. Please advise, what am i missing

    1. User Configuration-> Policies-> Administrative Templates-> System->Removable Storage Access
    2. Computer Configuration-> Policies-> Administrative Templates-> System-> Removable Storage Access

    thanks


    NA

    Thursday, July 14, 2016 9:00 PM

Answers

  • It sounds like you have a filter turned on.  Refer to https://support.microsoft.com/en-us/kb/949360 for a resolution.  Below is a copy/paste verbatim from that KB article (article says 2008 but this can happen on 2012 also.) 

    • You run the Group Policy Management Console (Gpmc.msc) on a computer that is running Windows Server 2008.
    • You open the Group Policy Management Editor to edit a Group Policy object (GPO).
    • You right-click the Administrative Templates item, and then you click Filter Options.
    • You click to select the Enable Requirements Filters check box, you select any platform in the list, and then you click OK to apply the setting.
    In this scenario, some templates in the Administrative Templates item are missing. If you right-click the Administrative Templates item and then clear the Filter On menu, these templates reappear. 


    Best Regards, Todd Heron | Active Directory Consultant

    Friday, July 15, 2016 1:46 AM

All replies

  • It sounds like you have a filter turned on.  Refer to https://support.microsoft.com/en-us/kb/949360 for a resolution.  Below is a copy/paste verbatim from that KB article (article says 2008 but this can happen on 2012 also.) 

    • You run the Group Policy Management Console (Gpmc.msc) on a computer that is running Windows Server 2008.
    • You open the Group Policy Management Editor to edit a Group Policy object (GPO).
    • You right-click the Administrative Templates item, and then you click Filter Options.
    • You click to select the Enable Requirements Filters check box, you select any platform in the list, and then you click OK to apply the setting.
    In this scenario, some templates in the Administrative Templates item are missing. If you right-click the Administrative Templates item and then clear the Filter On menu, these templates reappear. 


    Best Regards, Todd Heron | Active Directory Consultant

    Friday, July 15, 2016 1:46 AM
  • Hi,

    Have you verified Todd’s suggestion?

    If it is not the cause of the issue, you could try the below steps:

    when you open GPMC, does it show you "policy definitions retrieved from local machine" or, "policy definitions retrieved from central store" ?

    Please copy the policydefinitions folder of 2012 R2 to either the central store or to the local computer.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 18, 2016 8:17 AM
    Moderator