locked
Intranet Slow To Respond on First Load RRS feed

  • Question

  • I am having issues where the home page is slow to load for EACH person the first time they access it. It even stalls their IE as well. Once they shut it down and open it again, it flies through. Has anyone got any suggestions on what to do for this? It also seems that if the user hasnt connected in a while, it's also slow, despite already being connected that day.

    Help please? Thanks

    Edited to say that I don't think that this is from the Application Pool at all. It seems to be more IE based. After I deleted by browsing history, closed IE and loaded our intranet again, it stalled and crashed IE. Then after closing IE and connecting again, it's fine. Is there something I can do to resolve this on the machine?


    • Edited by SoapyJ Wednesday, February 8, 2012 10:56 AM
    Wednesday, February 8, 2012 9:25 AM

Answers

  • Hi SoapyJ,

    You can speed up the launching of the Companyweb site by changing the IIS Application Pool.

    1.Go to IIS Manager
    2.Open the Application Pools
    3.Right click on the DefaultAppPool and go to properties
    4.Go to the Performance Tab
    5.Uncheck the top box - shutdown worker processes after being idle.

    Also you can use other ways to Improve access speed. Here is some links about this.

    http://collab.rdacorp.com/2011/01/improving-sharepoint-performance.html

    http://blogs.msdn.com/b/joelo/archive/2006/08/13/697044.aspx

    Thanks,

    Jack


    • Edited by Jack-GaoModerator Thursday, February 9, 2012 2:38 AM
    • Marked as answer by SoapyJ Tuesday, February 14, 2012 11:57 AM
    Thursday, February 9, 2012 2:38 AM
    Moderator
  • Seemed to be a Google Webpart that was causing the issues even though my Developer Dashboard didn't really display that. I removed it and tried againa nd it's working fine now. Thankfully!
    • Marked as answer by SoapyJ Tuesday, February 14, 2012 11:57 AM
    Tuesday, February 14, 2012 11:57 AM

All replies

  • Hi SoapyJ,

    You can speed up the launching of the Companyweb site by changing the IIS Application Pool.

    1.Go to IIS Manager
    2.Open the Application Pools
    3.Right click on the DefaultAppPool and go to properties
    4.Go to the Performance Tab
    5.Uncheck the top box - shutdown worker processes after being idle.

    Also you can use other ways to Improve access speed. Here is some links about this.

    http://collab.rdacorp.com/2011/01/improving-sharepoint-performance.html

    http://blogs.msdn.com/b/joelo/archive/2006/08/13/697044.aspx

    Thanks,

    Jack


    • Edited by Jack-GaoModerator Thursday, February 9, 2012 2:38 AM
    • Marked as answer by SoapyJ Tuesday, February 14, 2012 11:57 AM
    Thursday, February 9, 2012 2:38 AM
    Moderator
  • Seemed to be a Google Webpart that was causing the issues even though my Developer Dashboard didn't really display that. I removed it and tried againa nd it's working fine now. Thankfully!
    • Marked as answer by SoapyJ Tuesday, February 14, 2012 11:57 AM
    Tuesday, February 14, 2012 11:57 AM