none
Client default printer not set as default in remote desktop session RRS feed

  • Question

  • When a user logs into an RDS session, I would like their local printers redirected.  Their local default printer should also be the default printer in the RDS session.

    In GPO, all of the Printer Redirection settings are "Not configured".  By default, that should redirect all local printers and set the local's default printer to be the session's default printer.  That didn't work - the default printer is one of the server's local printer which I don't want to remove because it's an fax printer I want users to have the option to use.

    Even so, I made "Do not set default client printer to be default printer in a session" to "disabled" (not leaving it as "not configured").  I also did a gpupdate /force, deleted the test user's profile, and logged back in - the server's local printer still is the default printer.

    As the test user, if I set one of the redirected printers as my default, then log off then back on, the setting does not stick.

    AFAIK, GPO settings look good.  Not sure why the session's default printer isn't being set to the redirected printer the local machine.

    PS: I do not want to "Redirect only the default client printer", as users may have more than one printer on their local machine they want to print to (one color, one B/W, etc).

    Edit: I set the "Do not set default client printer to be default printer in a session" to "disabled" on the two RDSH servers local GP instead of the AD GPO, and it works! Don't know why it won't work when coming from the AD GPO though.  I got it to do what I want, but not satisfied with the solution.  Why doesn't this work when coming from the AD GPO?

    • Edited by Guy Techie Friday, September 14, 2012 5:33 PM
    Friday, September 14, 2012 4:44 PM

Answers

  • Hi,

    Thanks for your post.

    It’s odd for the GPO settings apply to terminal server did not work. As you mentioned, we need to disable the settings Do not set default client printer to be default printer in a session in your scenario. However, for troubleshoot why the AD group policy not working, I would recommend that you re-post this issue at group policy forum further investigation. Your understanding is appreciated.

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    Wednesday, September 19, 2012 2:41 AM
    Moderator