none
FAST ESP 5.3 indexer memory problem RRS feed

  • Question

  • Hi,

    I'm using FAST ESP 5.3 and every couple of days that indexer halts and the matching engines tab shows 43%. I checked FAST documents I knew there was a memory segmentation issue that can be resolved by setting the HeapDeCommitFreeBlockThreshold registery key. I applied this fix, but the issue is still there. I use windows server 2008 sp2. can any one help with this? I have to restart the indexer every couple of days to make it work and that's really annoying.

    Tuesday, November 1, 2011 9:05 AM

All replies

  • Hello,

     

    The HeapDeCommitFreeBlockThreshold memory pool setting is more effective for Windows 2003 platforms, and does not need to be configued to a non-default value on a 64 bit platform for ESP operation.  The below KB article has some useful information regarding addressing error messages about the indexer having ran out of memory indexing failed:

    http://support.microsoft.com/kb/2523632

     

    Do you see for errors in the indexer.log and indexer_producer logs?

     

    To get more information about why the indexer is running out of memory, you could enable debug logging for the indexer.  To enable debug, edit the %fastsearch%\etc\config_data\RTSearch\webcluster\rtsearchrc.xml on the admin node, set debuglog to true to enable debug logging. 

     

    Also, one may need to enable debug on the index_producer logs, but that will cause them to be very large in size. Debug can be enabled for index producer by editing the %fastsearch%\etc\LoggerConfig.xml on each node where indexer producer is running, and set the "file" threshold to debug.

     

    There are changes you can make to tune the rtsearchrc.xml file to reduce the indexer memory footprint. For example, one can reduce the indexingThreads from 2 to 1: Edit the %fastsearch%\etc\config_data\RTSearch\webcluster\rtsearchrc.xml on the admin node, and change  indexingThreads="2" to indexingThreads="1". This will slow down the indexing process, but less threads will mean less memory, and can help avoid not running out of memory.

     

    For the above rtsearchrc.xml changes to take effect, the indexer component will need to be restarted. 

     

    Feel free to post errors from the debug logs and we may be able to provide a specific root cause.  Alternatively, you can open a new ticket with our Technical Support team, and we could provide some specific settings to help optimize the environment.  Let us know your findings.

     

    Thanks!

    Rob Vazzana | Sr Support Escalation Engineer | US Customer Service & Support

    Customer Service & Support                          Microsoft | Services

    Tuesday, November 1, 2011 8:52 PM
    Moderator