locked
KERNELBASE.DLL Exception 0xc000041d RRS feed

  • Question

  • Hello,

    After the Windows 10 anniversary update automatically installed a few weeks ago I have been having problems with Lockheed Martin Prepar3d flight simulator. When I open Prepar3d it doesn't crash straight away, so I load up the default flight and minimise the application for a while. After about 20 mins or so the application crashes with the following exception.

    Faulting application name: Prepar3D.exe, version: 3.4.9.18400, time stamp: 0x57d9b14e
    Faulting module name: KERNELBASE.dll, version: 10.0.14393.321, time stamp: 0x57f4c291
    Exception code: 0xc000041d
    Fault offset: 0x000da6f2
    Faulting process ID: 0x3274
    Faulting application start time: 0x01d22d23d9e96280
    Faulting application path: F:\Programs\P3D\Prepar3D.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report ID: 7720af0c-ae04-4cfc-826a-d3b26a0063e1
    Faulting package full name: 
    Faulting package-relative application ID: 

    Now this didn't happen before the Windows Updates, but unfortunately because I was running out of disk space I removed the backup. Looking at the Windows Update change log, the KERNALBASE had several security updates, which could explain why the application no longer runs.

    I know several others have had a problem with this application after installing the anniversary update, but they were able to roll back the update to get the application working again.

    I have also logged an issue with Lockheed Martin directly, but they are unable to reproduce or investigate the problem further.

    P3D 3.4 Crash to Desktop - Stack Trace

    Do you have any suggestions on how I can debug this further to try and find a solution?

    Many Thanks

    Craig

    Tuesday, November 15, 2016 8:43 AM

All replies

  • Hi craig1231,

    What is the exact machine model? Have you tried to reinstall this program?
    Please check the device manufacturer website to download the latest Windows 10 compatible drivers for your machine model.
    According to my research, it seems that the Prepar3d flight has released a hotfix. Ensure you have got the latest software version.
    Prepar3D v3.4 Hotfix 1 Released!
    http://prepar3d.com/news/2016/11/113769/

    For a third party product, the third party support should have more resources to help you.

    NOTE: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 16, 2016 5:58 AM
  • Hello,

    Yes I have installed the hotfix and tried uninstalling and completely reinstalling and it didn't fix the issue. I shall check tonight if I have the latest drivers installed, but I have a feeling I do (it should auto update).I just don't know where to go to try and get this issue resolved.

    Kind Regards

    Craig

    Wednesday, November 16, 2016 10:41 AM