locked
WSUS Server 2016 not working RRS feed

  • Question

  • Hi,

    I'm playing around with Server 2016 and WSUS. I have set up a lab with a few servers (all 2016 core and gui) and one 2016 with a gui and the WSUS role (updated with all updates from Microsoft online).

    WSUS is working, http://127.0.0.1:8530/ClientWebService/client.asmx is reachable (from WSUS itself and from other clients).

    Problem: Clients appear in the WSUS console but none of them (gui and core server) are able to install updates. If triggered from a client, needed updates appear but after downloading is complete the installation won't start (I think the problem is that the downloads aren't working). I've installed the service stack update on one of the servers but even then the server can't update the remaining ones...

    A log file from a client can be found here.

    Any ideas?

    Thursday, November 24, 2016 8:44 AM

Answers

  • Update from my side:

    After manually installing KB3200970 on the clients my servers can communicate again with my WSUS server (10.0.14393.447). Both versions (with and without GUI) are working again, no more errors in the event log.

    It seems that an "old" Win 2016 version can not communicate with an up2date WSUS...

    Sunday, November 27, 2016 12:56 PM

All replies

  • Hi Marks_Kapsch,

    >needed updates appear but after downloading is complete the installation won't start

    Could you provide related screenshot about windows update finish downloading the updates while not install them?

    What are the OS of the WSUS clients, what windows update option do you choose, auto download and auto install or others?

    Also check if run windows update troubleshooter and reset windows update components on clients could work:

    https://support.microsoft.com/en-us/kb/971058

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 25, 2016 5:47 AM
  • Hi Anne,

    Screenshot here, but I'm not sure if this will clarify things. The actual installation process doesn't start.

    WSUS clients: Server 2016 Datacenter Core and with GUI
    WSUS settings: deployed via group policy, set to auto install
    troubleshooter tool: one error which gets fixed but reappears on the next run

    The log files shows that the clients and the server talk but it seems that there are incompatible in some form.

    Friday, November 25, 2016 2:25 PM
  • Update from my side:

    After manually installing KB3200970 on the clients my servers can communicate again with my WSUS server (10.0.14393.447). Both versions (with and without GUI) are working again, no more errors in the event log.

    It seems that an "old" Win 2016 version can not communicate with an up2date WSUS...

    Sunday, November 27, 2016 12:56 PM
  • Hi Markus_Kapsch,

    Glad to hear the WSUS 2016 could work now, and thanks for sharing the information with us. Then, you may mark your reply as answer, so that others meet the similar issue may find useful information quickly.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 28, 2016 2:16 AM