Error 0x80070091: The directory is not empty


  • I am using Hardlinks for imaging systems to Windows 7. Some systems will fail with Error 0x80070091: The directory is not empty and when we caddy the drive the data cannot be deleted that way either.

    Is there a way (tool) to check for files that cannot be deleted prior to wiping the disk?

    If the wipe fails, would USMT work to backup the Hardlink folder data off the drive? For example:

    If wipe fails and it left the data in C:\HLDATA\USMT\File\C$ now I have to either run a chkdsk and hope it fixes the issue or restore the ghost file and USMT the data off the drive. Instead, can I run scanstate against C:\HLDATA\USMT\File\C$ to store the data on a network share and then do a Format and restore when done?

    Monday, April 23, 2012 6:06 PM

All replies

  • Dear,

    I faced this error a lot of time, I made some workarounds and I don't know it's the right way or not.

    one way is to copy the file for the USMT the file that backed up all the system, then format the HD and run TS with loadstate or run a normal task sequence then after finishing run the file of USMT.

    hope this is useful for you,

    Monday, April 23, 2012 6:41 PM
  • I received this error on a Folder previously moved from one drive to another. There were 2 folders left over after the move and both showed as being empty of all files including hidden files. I tried the work around from a previous thread (renaming the folder and placing a ! before the new folder name) but it did not work. I found success in creating an Excel file and placing it in the problem folder and then deleting the entitre folder. This allowed me to delete the problem folder without the error code.
    Tuesday, February 02, 2016 6:02 AM