none
Why is the Manage Rules Icon Grayed Out? RRS feed

  • Question

  • Hi

    We are using Project Server 2010. In the Approval Center for the Project Managers  the "Manage Rules" icon is grayed out even though the Global Permission for Manage Rules under Time and Task Management is set to ALLOW for the Project Managers group. Is there another setting somewhere else on the server that needs to be changed to enable this function? Thanks,


    Judy Washington

    Monday, September 30, 2013 3:06 PM

Answers

  • Hi Judy --

    The 'Manage Rules' feature can be dangerous in places where people are not experienced users of Project Server. I would not enable it unless the Project Managers can prove to you that it will remove significant administrative burden... and they are not simply wanting to be lazy about reviewing and approving task updates. If they want the feature enabled out of laziness, then they will likely end up auto-approving incorrect task updates, and therefore populating their project schedules with those incorrect updates. Bad news for them because they are responsible for finding and fixing the mistakes, and bad news for you because there are usually pockets of people who look for reasons to bad-mouth the system.

    Having said all of that... if you still want to enable the feature, I can think of two places to look immediately to determine why it appears disabled:

    • The permission is disabled on the 'Project Web App Permissions' page (PWA > 'Server Settings' > 'Project Web App Permissions'), which overrides anyplace else where the permission may be enabled.
    • The permission is denied in another security group of which the same person is a member, which overrides the same permission being allowed to another group (i.e. "Joe" is a member of the 'Project Managers' group where the permission is allowed, but he is also a member of the 'Team Members' group where the permission is denied).

    Take a look and let us know if you discover the problem.

    Good luck!

    -- tz


    Tony Zink | Vice President, EPMA | http://www.epmainc.com | Blog: http://www.epmablog.com | Training: http://www.epmainstitute.com

    • Marked as answer by Judy IPD Monday, September 30, 2013 8:35 PM
    Monday, September 30, 2013 6:16 PM

All replies

  • Hi Judy --

    The 'Manage Rules' feature can be dangerous in places where people are not experienced users of Project Server. I would not enable it unless the Project Managers can prove to you that it will remove significant administrative burden... and they are not simply wanting to be lazy about reviewing and approving task updates. If they want the feature enabled out of laziness, then they will likely end up auto-approving incorrect task updates, and therefore populating their project schedules with those incorrect updates. Bad news for them because they are responsible for finding and fixing the mistakes, and bad news for you because there are usually pockets of people who look for reasons to bad-mouth the system.

    Having said all of that... if you still want to enable the feature, I can think of two places to look immediately to determine why it appears disabled:

    • The permission is disabled on the 'Project Web App Permissions' page (PWA > 'Server Settings' > 'Project Web App Permissions'), which overrides anyplace else where the permission may be enabled.
    • The permission is denied in another security group of which the same person is a member, which overrides the same permission being allowed to another group (i.e. "Joe" is a member of the 'Project Managers' group where the permission is allowed, but he is also a member of the 'Team Members' group where the permission is denied).

    Take a look and let us know if you discover the problem.

    Good luck!

    -- tz


    Tony Zink | Vice President, EPMA | http://www.epmainc.com | Blog: http://www.epmablog.com | Training: http://www.epmainstitute.com

    • Marked as answer by Judy IPD Monday, September 30, 2013 8:35 PM
    Monday, September 30, 2013 6:16 PM
  • Hi Tony,

    Thanks for your input. Your point about the risks and responsibilities related to enabling the Manage Rules feature is well taken, but after weighing the pros and cons of enabling vs. disabling the feature  my organization has decided to enable it. In fact, it was enabled at one point in time (a few PMs have some rules in place) but a setting must have been changed somewhere that disallowed it, and now I'm backtracking to try to find it.

    The feature is already enabled under PWA, and for Project Managers and Resource Managers groups. (Both groups consists of the same resources). These same resources are also in the Team Members group and the feature was disabled for that group. After seeing that I thought I had found my fix, however, even after enabling the feature for the Team Members group the icon is still grayed out. So I'm kinda back to square one. Our server permissions were set by groups (as recommended) but I am going to check every group and individual user to see if there is a "Deny" somewhere that is over riding the Allow. Meanwhile, I'd appreciate any other ideas you might have. Thanks a bunch.


    Judy Washington

    Monday, September 30, 2013 7:18 PM
  • Hi Tony,

    I found it! I created a Non-Admin Users group as part of the instructions involved in Archiving a project.The instructions state to put everyone on the system in that group, and it was THAT group that did not have the Manage Rules permission enabled. Once I enabled the feature for that group, the PMs were able to use the feature.

    Not to be one of those who bad-mouth the system, but this reminds me of another time when i changed a setting to accomplish one thing, and it caused an issue somewhere else on the server. My problem is fixed; I'm just hoping that I haven't created another problem with the Non-Admin Users group, because it does seem that there are trade offs with this system. At any rate, thanks for your assistance! Here is the link with instructions I referred to:

    http://technet.microsoft.com/en-us/library/gg597607(v=office.14).aspx#BKMK_Step3SetUpASecurityGroupForUsersThatAreNotAdministrators


    Judy Washington

    Monday, September 30, 2013 8:35 PM