locked
Explorer high cpu usage when browsing video folders; Windows 7 RC RRS feed

  • Question

  • I have disabled thumbnails but whenever I browse to video libraries or folders containing mpeg2, mp4 etc, the CPUs are maxed out.
    It is obviously decoding the video files for some reason.

    How can I disable this behaviour?

    regards /austin
    Friday, September 4, 2009 10:17 AM

Answers

  • Please:

    1. In Windows Explorer, click ion Tools->Folder options.
    2. Click the View tab.
    3. Check the follow option.

    Always show icons, never thumbnails.

    If the issue still occurs, please let us know if the icons are changed to thumbnails or not.

    If the icons are not changed to thumbnails, please open Task Manager, click View->Select Columns, check PID. Then when the issue occurs, verify that which program consume the CPU usage, and record the PID. Then please find the program according to the PID.

    If the process is svchost.exe, please open cmd with high privilege, enter the following command.

    tasklist -svc

    Please check which program is the culprit.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Friday, September 11, 2009 4:37 AM
    Monday, September 7, 2009 9:18 AM
  • Disabling third party extensions with Autoruns or ShellExView did not fix it;

    However, I did use Autoruns to disable some third party (pinacle/avid) codecs. I now get high cpu for about a minute so I dont have to restart the explorer.


    It appears that explorer may be looping through codecs. I will have to try disabling some more.


    Also I have noticed the the context menu for "Manage" by Right-Clicking Computer does not work, so I may have registry corruption in the Shell extensions from a failed install etc.

    EDIT: I found and disabled more Third party codecs and the problem is gone, I may have to re-enable some if I find I cant play some file, but for now the problem is gone. Codec ____ :)

    • Marked as answer by Austin_KW Sunday, October 18, 2009 1:33 PM
    Thursday, October 15, 2009 5:10 PM

All replies

  • Please:

    1. In Windows Explorer, click ion Tools->Folder options.
    2. Click the View tab.
    3. Check the follow option.

    Always show icons, never thumbnails.

    If the issue still occurs, please let us know if the icons are changed to thumbnails or not.

    If the icons are not changed to thumbnails, please open Task Manager, click View->Select Columns, check PID. Then when the issue occurs, verify that which program consume the CPU usage, and record the PID. Then please find the program according to the PID.

    If the process is svchost.exe, please open cmd with high privilege, enter the following command.

    tasklist -svc

    Please check which program is the culprit.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Friday, September 11, 2009 4:37 AM
    Monday, September 7, 2009 9:18 AM
  • I have been having the same problem even since I upgraded to windows7 RC a month ago.
    I tried checking "alway show icons, never thumbnails" and while icons are displayed, the problem persists.
    According to task manager, it is "c:\windows\explorer.EXE" (PID 3028) that is ALWAYS the culprit.
    When I close any open "Windows Explorer" windows the cpu remains high for 3 - 5 minutes and then returns to normal.
    If I kill the explorer.exe process I loose the taskbar (of course).
    This happens when browsing video folders both locally and on NAS.

    Would appreciate any help you can give.
    thanks
    Edward
    Monday, September 7, 2009 10:04 AM
  • Hi Edward,

    Your issue is different. It seems that the root cause is the network communication. Can you access it properly finally?

    By the way, since it is a different issue, I suggest that you create another thread to discuss it in order to avoid confusion.


    Arthur Xie - MSFT
    Friday, September 11, 2009 4:37 AM
  • I still have this problem.

    Any-time I browse to a video folder or library, explorer.exe (pid 2768) has high cpu usage or sometimes crashes.
    Tumbnails are off and not generated.
    Operations on a file eg. Show properties result in green ribbon of death.

    Never thought I would consider going back to Vista but my laptop is currrently sitting at 55% cpu and temperature 73C when is should be idle.
    Why is explorer processing the video files, I just want to list them.
    I am using the CLI to browse and play my video files, insane.


    /austin
    Friday, October 2, 2009 1:47 PM
  • If I kill the explorer.exe process I loose the taskbar (of course).
    Find the "Launch folder windows in separate process" checkbox under Tools - Options - View and check it.

    Then you don't lose the desktop when you have to kill Explorer.

    -Noel
    Friday, October 2, 2009 5:06 PM
  • It sounds like some 3rd party software may be involved.  Consider using e.g. Autoruns or ShellExView to selectively disable Explorer extensions, and then test the result.  Also consider booting into safe mode and seeing if you are able to repro the behavior?  What about another user account - is the behavior present there?

    One course of action for attempting to gather more information about this type of issue is to configure symbols in Process Explorer. Then, when the problem is happening, inspect the properties of the process in question (explorer.exe, in this case, it would seem) and look at the Threads tab.  Sort by the "Cycles Delta" column and note the full stack of the topmost thread.
     
    Sunday, October 4, 2009 9:21 PM
  • I have been having the same problem even since I upgraded to windows7 RC a month ago.
    I tried checking "alway show icons, never thumbnails" and while icons are displayed, the problem persists.
    According to task manager, it is "c:\windows\explorer.EXE" (PID 3028) that is ALWAYS the culprit.
    When I close any open "Windows Explorer" windows the cpu remains high for 3 - 5 minutes and then returns to normal.
    If I kill the explorer.exe process I loose the taskbar (of course).
    This happens when browsing video folders both locally and on NAS.

    Would appreciate any help you can give.
    thanks
    Edward
    I have the exakt same problem. Windows 7 Build 7100. I have no problem with network communication, it's just the problem mentioned above: I want to browse a video folder and it takes minutes for the video player (wmp, vlc, doesn't matter) to start. Taskmanager says, that explorer.exe is using all the cpu. After a couple of minutes, everything returns to normal.

    I would be really, really thankful if someone knew a solution for this very annoying problem.
    Wednesday, October 14, 2009 11:19 PM
  • It sounds like some 3rd party software may be involved.  Consider using e.g. Autoruns or ShellExView to selectively disable Explorer extensions, and then test the result.  Also consider booting into safe mode and seeing if you are able to repro the behavior?  What about another user account - is the behavior present there?

    One course of action for attempting to gather more information about this type of issue is to configure symbols in Process Explorer . Then, when the problem is happening, inspect the properties of the process in question (explorer.exe, in this case, it would seem) and look at the Threads tab.  Sort by the "Cycles Delta" column and note the full stack of the topmost thread.
    Thursday, October 15, 2009 1:16 AM
  • I've tried some of the ideas listed above but I gave up on this issue some weeks ago.
    I expect to do a full clean install of Windows 7 (released version) in the next couple of weeks and see if I still have the problem then.

    Thanks for everyones suggestions.
    Edward
    Thursday, October 15, 2009 7:23 AM
  • Disabling third party extensions with Autoruns or ShellExView did not fix it;

    However, I did use Autoruns to disable some third party (pinacle/avid) codecs. I now get high cpu for about a minute so I dont have to restart the explorer.


    It appears that explorer may be looping through codecs. I will have to try disabling some more.


    Also I have noticed the the context menu for "Manage" by Right-Clicking Computer does not work, so I may have registry corruption in the Shell extensions from a failed install etc.

    EDIT: I found and disabled more Third party codecs and the problem is gone, I may have to re-enable some if I find I cant play some file, but for now the problem is gone. Codec ____ :)

    • Marked as answer by Austin_KW Sunday, October 18, 2009 1:33 PM
    Thursday, October 15, 2009 5:10 PM
  • Edragon, please check the attitude.  It helps no one.

    >is clean and 24hours old. No third party applications

    Your computer really can't run without 3rd party software.  What company has written the video drivers you're using, for example?

    And quite clearly you've visited some web sites, as evidenced by your comments.  I'd be curious what software you've already accepted into your computer from those web sites:  Please list the Add-Ins already installed into Internet Explorer.

    Have you checked to ensure your drivers are all up to date?

    What is your hardware configuration (motherboard, video, sound, etc.)?

    Not everyone running Windows 7 is experiencing the problems you are, so clearly it has something to do with your computer, specifically, or the things you've done.

    -Noel
    Tuesday, December 1, 2009 6:23 PM
  • I have the same problem, when i browse the folder "Nhung Nu Hon Ruc Ro" ext:flv the explorer use 100% cpu

    i kill it and browse this folder by total commander and open these file, the explorer use 100% cpu again

     

    Any body has any solution??

    Friday, March 26, 2010 9:24 PM
  • i am having that problem with only opening the folder that contains flv files

    the above steps works well

    but i wank to know about the problem that why it occurs

    can you please tell me

    or send me a mail

    rajsoundarrajan@gmail.com

    rajsoundarrajan@live.com

    Thursday, April 29, 2010 1:40 AM
  • I updated to 7 from Vista a month ago, and I am having the same problem. Explorer takes up 50% processor usage whenever I open any folder containing .flv files. The problem persists even when I close the folder. The only way to get process usage to normal is to restart explorer.exe.

    However, there is no problem if I disable thumbnails.

    Is there a way to fix the problem without disabling the thumbnail feature altogether?

    Friday, June 4, 2010 11:17 AM
  • Hi,
    I faced this problem today, and follow the instructions of Diparnak in http://www.sevenforums.com/general-discussion/3291-explorer-exe-50-cpu-usage.html, and solve the error.
    In my case, I downloaded NexusFiles, a utility Norton Commander Style, to browse two folder at same time and open the task manager to monitor de CPU usage.
    1.- I Killed the explorer.exe process
    2.- In Nexus, I moved all the files from the folder with problem (in my case, Downloads Folder) to a Temporal Folder.
    3.- I moved only few files to Downloads Folder and start Explorer.exe process from File->Run in Taskmanager

    3.a.- Open Explorer y open the folder with problem ( at this moment empty).


    4.- I monitored CPU Usage in Taskmanager, If it keeped low then i Moved others files... I did this until i found the file/folder with problem (Cpu Usage Raised 99-100%).
    5.- I killed, again, the explorer.exe process
    6.- I deleted the file/folder with problem
    7.- I started the Explorer.exe process again
    ... and voila!

    Thanks a lot Diparnak!

    Sorry the bad english, please... pacience and good luck!

    • Proposed as answer by Wolfang Thursday, June 10, 2010 3:54 PM
    Thursday, June 10, 2010 3:37 PM
  • I had the same problem; explorer.exe would generally run at 50% of the cpu capacity and often use as much as 95% making the computer unusable.

    After a lot of head scratching I realised explorer.exe would consume close to 100% of the cpu whenever I left or right clicked on a folder which had video files in it.

    Long story made short, removing the folder solved my problem.

    I had recently loaded Internet Download Manager (IDM) and used it to quickly loaded some video clips into the previously mentioned folder.  It appears some or all of the video clips I loaded were not “reconstructed” properly, simply, they were not complete and/or fractured.  Apparently, this can cause explorer.exe to get stuck in a kind of computer Chinese Finger Puzzle and essentially lock the machine up by using all the cpu capacity while trying to figure out what the fractured files are.

    P.s Deleting the folder was a real problem, every time I clicked on it explorer.exe used all the cpu capacity and froze the computer.  I managed to get rid of it by starting in safe mode and deleting the offending folder, it said the folder was successfully deleted but I could still see it.  I then restarting the computer in normal mode and was able to delete it again.

    Monday, April 18, 2011 9:39 AM
  • What does the COM Surrogate (dllhost) do and why does it always stop working?

    http://blogs.msdn.com/b/oldnewthing/archive/2009/02/12/9413816.aspx

    (dllhost makes the thumbnails out of pictures and video files)

     

    Monday, May 16, 2011 9:45 PM
  • Hi, The solution worked very well for me. Was facing 100 percent utilisation when I accessed Video files . Thanks a TON!
    Monday, June 20, 2011 5:14 AM