locked
Win 7 Slow Network File Transfer RRS feed

  • Question

  • I am really hacked off with this roblem, I have spent days trying out various "fixes" all to no avail.

    I have a server running 2003

    I have a PC running WIN 7

     

    Using Widows Explorer

    Sitting at the PC it takes 4.5 HOURS to copy a 1.5GB file from the Server to the WIN 7 C.

    Sitting at the Server It takes 20 MINUTES  to copy the same 1.5GB file from the win 7 PC to the Server.

     

    I have updated all network cards, O/S's etc.

    I have removed my router from the equation.

    I have switched off Firewall, Anti-virus and pretty much anything else I can think of.

     

    I have used "Teracoy Free"

     

    None of these measures has sorted the problem.

     

    It is unnaccetable to have it take so long to coy files.

    I am so angry I feel like going back t X and giving u with WIN 7.

     

    Searching the net brings numerus peole having the same problem.

     

    Come on M$ when is this problem to be addressed?

    Wednesday, September 15, 2010 3:09 PM

Answers

  • Hi Brino, this issue may  occurs with the feature “Remote Differential Compression”,  Remote Differential Compression (RDC) allows data to be synchronized with a remote source using compression techniques to minimize the amount of data sent across the network.

     

    So please try to disable “Remote Differential Compression” in Control Panel-----Programs and Features-----Turn Windows features on or off.

     

     

    And these links maybe helpful to you:

     

    http://support.microsoft.com/kb/950216/en-us

     

    http://support.microsoft.com/kb/885189/en-us

     

    As the slow copy only occurs while copying the files from the Server to Windows 7, I suggest you posting in Windows Server forums.

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

    Hope it helps.

     

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Wednesday, September 22, 2010 2:11 AM
    Friday, September 17, 2010 5:53 AM

All replies

  • Hi Brino, this issue may  occurs with the feature “Remote Differential Compression”,  Remote Differential Compression (RDC) allows data to be synchronized with a remote source using compression techniques to minimize the amount of data sent across the network.

     

    So please try to disable “Remote Differential Compression” in Control Panel-----Programs and Features-----Turn Windows features on or off.

     

     

    And these links maybe helpful to you:

     

    http://support.microsoft.com/kb/950216/en-us

     

    http://support.microsoft.com/kb/885189/en-us

     

    As the slow copy only occurs while copying the files from the Server to Windows 7, I suggest you posting in Windows Server forums.

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

    Hope it helps.

     

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Wednesday, September 22, 2010 2:11 AM
    Friday, September 17, 2010 5:53 AM
  • Here's a list of "fixes" I've encountered in various threads, but none have fixed the problem:

    1. On Vista client, edit Registry to change file size transfer limit from 50MB to maximum size:
      HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
      FileAttributesLimitInBytes set to 4294967295
    2. In IIS7 on Windows 7 server, for the webdav file sharing web site, for Request Filtering set
      Maximum allowed content length (Bytes) to maximum 4290000000
    3. Remove server from Home Group
    4. Disable IPv6
    5. Set NIC for:
      100MB Full Duplex (No Auto)
      Disable Large Send Offload (IPv4)
      Disable Energy Star
      Disable Large Send Offload (IPv6) (didn't do, not on my NIC)
    6. Disable Receive Side Scaling AND Disable Receive Window Auto-Tuning Level
      Open an elevated command prompt with administrator rights.
      Type the following commands and press Enter (the second command on RSS is optional):
      netsh interface tcp set global autotuninglevel=disabled
      netsh interface tcp set global rss=disabled
    7. Set folder options on both server and client to NOT use thumb nails
    8. Turn off Remote Differential Compression on Windows 7: (note: can cause some software to fail)
      Open Control Panel
      Click on Programs and Features
      In the Programs and Features window, click on Turn ON/OFF Windows Features
      When the list populates, click on Remote Differential Compression to deselect it
      Click OK
      Reboot
      See if helps, and if affects any of your software apps.
    9. Turn on Indexing Service on both client and server.

    Nothing helped, returned items 4 thru 9 to original settings.

    John

    Thursday, December 1, 2011 7:36 PM
  • JBoy53 - I'm wondering if you every got this issued resolved and if so...how? I have tried all the suggestions I could find on the Internet to get my Windows 7 Ultimate (64-Bit) desktop to transfer files to my Windows 7 Professional (64-=Bit) laptop at speeds faster than 200-600 KB/second, and vice-versa. I have a wired connection through a Linksys router. I'm ready to throw my computers out the freaking window I'm so pissed off at MS! This should not be this difficult and as it's been noted, many, many people are experiencing this issue. What give MS? Really. What the #$% gives? Why can't Windows 7 do something so basic?

    • Edited by CampAlbion Friday, February 3, 2012 4:26 PM
    Friday, February 3, 2012 4:23 PM