none
Server 2016 Hyper-V Replica - Planned failover keeps trying to use short domain

    Question

  • I have two Windows Server 2016 machines running Hyper-V.  I've successfully configured Hyper-V replica but I have a problem during planned failover.  When I initiate the planned failover and check "Reverse the replication direction" box, it fails to reverse the replication direction, giving the 29262 error.  Instead of using the FQDN specified in the replica configuration, it uses the format hostname.shortdomain as the server name (the "Pre-2000" domain name).  When I manually reverse the direction and change the replica hostname to the FQDN, it works.

    I believe this may have started when I migrated my Active Directory server from 2012R2 to 2016 and decommissioned my WINS server.  My current domain functional level is 2008R2, although I don't know why that would matter.

    It seems to me that Hyper-V should be using the FQDN and not the short domain format when reversing direction, but I don't know how to make it do that.  Any help would be appreciated!

    Tuesday, April 9, 2019 5:35 PM

All replies

  • Hi,

    Could you please provide the screenshot of error message?

    It seems more related with a DNS issue.

    I suppose you remove your replicate configuration and reconfigure FQDN as replica server again.

    Reference link

    https://blogs.technet.microsoft.com/canitpro/2013/04/07/step-by-step-virtual-machine-replication-using-hyper-v-replica/

    Best Regards,

    Frank


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Wednesday, April 10, 2019 3:19 AM
    Moderator

  • Hi,

    Just check the situation about your issue.

    Best Regards,
    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, April 15, 2019 7:41 AM
    Moderator
  • Hi Frank,

    The replica was originally configured for FQDN.  This is the error message:

    The configuration of the VM on both of the hosts:  (The replica is on AnalysisVH1, the primary is on AnalysisVH2)

    Monday, April 15, 2019 2:36 PM
  • Sorry for the delay, I didn't get an alert for your first reply.
    Monday, April 15, 2019 2:36 PM
  • I just tried removing and recreating replication and the problem persists.

    I've been thinking about what you said about DNS and I did some testing.  nslookup returns the correct responses when looking up the ip address, the hostname alone, and the FQDN. 

    As I said in my original post, it seems to me that Hyper-V is trying to use NETBIOS instead of DNS.  I even tried putting the appropriate NETBIOS names in the Hyper-V servers host files, but that didn't work either.  Correct me if I'm wrong, but I believe WINS is considered obsolete.  Was it a bad idea to remove it when I upgraded my domain controllers?

    • Edited by LUnger Monday, April 15, 2019 3:12 PM
    Monday, April 15, 2019 3:03 PM
  • Hi,

    Please check the option"Authorization and storage" if it is configured as below.

    Have you tried to exchange the source and target host to check if it could be work?

    >>Correct me if I'm wrong, but I believe WINS is considered obsolete.

    Sure,it is a old one.

    So the DC is your DNS server? Did you check the "H1" entry in the forward zone and the reverse zone your DNS server ?

    Did the two hyper-v hosts in domain? Did their dns setting point to DC?

    Have you tried to rejoin the hyper-v host to domain?

    Please check the name resolution policy under domain policy if there any rules.

    Closing your Firewall.

    Updating your nic driver in two hyper-v host.

    Best Regards,

    Frank


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, April 16, 2019 7:09 AM
    Moderator
  • Hi Frank, thank you for your suggestions.

    Yes, both servers are configured to "Allow replication from any authenticated server".

    The problem behavior occurs in both directions, that is with AnalysisVH2 being the replica and AnalysisVH1 being the primary, and vice versa.

    Yes, the DC is the DNS server. I've confirmed that WINS forwarding is NOT configured for any zone. (I had to remove WINS forwarding when I decommissioned the WINS server.)  Both Hyper-V hosts are joined to the domain and are configured with static IP addresses using the DC/DNS server as their DNS. 

    (There are actually two DC/DNS servers, both running Windows 2016.  Analysis02 currently holds FSMO roles, Analysis01 is secondary.  Both are configured in DNS settings of Hyper-V hosts.)

    I don't know what you mean by a DNS "H1" entry.  Both Hyper-V hosts have A records registered in the forward lookup zone and PTR records in the reverse lookup zone.  Host names, FQDN names and IP addresses all resolve properly using nslookup from either server.

    I've checked both local and domain group policies and there are no rules configured in the name resolution policy.

    I've tried disabling the windows firewall and the problem persists. 

    There are no firewalls between the Hyper-V hosts or DCs.  All are on the same subnet.  Both Hyper-V hosts and both DCs are connected via ethernet using NIC teaming, switch independent, with dynamic load balancing.

    Each Hyper-V host has three Intel PRO/1000 PT dual port adapters, for a total of 6 ports each.  Intel does not supply Windows 2016 drivers for these adapters, as they are published via Windows Update.  I have updated the drivers to the latest available version (9.15.11.0).

    I'll try rejoining the Hyper-V hosts to the domain after hours. (I originally joined them to the domain using the FQDN of the domain, not the short name.)

    Tuesday, April 16, 2019 4:49 PM
  • Hi,

    Looking forward to your update.

    >>putting the appropriate NETBIOS names in the Hyper-V servers host files

    Please check the steps of modify hosts file if it is right. 

    https://www.groovypost.com/howto/edit-hosts-file-windows-10/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Please uncheck LMHOSTS lookup and disable netbios over TCP/IP.

    At last, I found a documents related this error,please refer to it.

    Hyper-V Replica - Name Resolution of Internationalized Server/Domain names

    https://techcommunity.microsoft.com/t5/Virtualization/Hyper-V-Replica-Name-Resolution-of-Internationalized-Server/ba-p/382054

    Best Regards,

    Frank



    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Wednesday, April 17, 2019 4:53 AM
    Moderator
  • Hi,
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    18 hours 26 minutes ago
    Moderator
  • Hi Frank,

    I've confirmed that I entered the host file entries correctly, although I removed the entries as they did not resolve the problem.  I can also confirm that LMHOSTS and netbios over TCP/IP are both disabled.

    I reviewed the article "Hyper-V Replica - Name Resolution of Internationalized Server/Domain names".  This is not the problem.  Our domain name uses only letters from the basic ASCII character set.  I tried adding the UTF-8 mapping rule anyway, but it did not solve the problem.  I've still not had an opportunity to remove and rejoin the domain on the Hyper-V hosts.  I'm on another project this week so I won't get back to it until May.

    LUnger

    12 hours 42 minutes ago