none
Windows 10 goes to sleep/hibernates after RDP session ends RRS feed

  • Question

  • I'm connecting to my Windows 10 machine (a HP Zbook) using Remote Desktop. One our after that I disconnect from the session, the computer goes into hibernation.

    Starting the computer I can continue using it where I left off, and I can leave it on for several days without it going into sleep or hibernation. But as soon I make a new RDP connection to it, one hour after disconnecting the session it goes into sleep again.

    I have set the power plan to High performance, and tried to make sure that all Sleep and Hibernation options are set to Never, both on battery and plugged in. Even Unattended sleep is set 0.

    Event Viewer tells me:

    Sleep Reason: Application API

    Running powercfg /SYSTEMSLEEPDIAGNOSTICS I can see these lines from the moment I connect to the computer.

    The system idle time was reset because: The system detected user input. 0:00:11 2018-03-23 18:26:49
    The system idle time was reset because: The system detected user input. 0:00:41 2018-03-23 18:27:19
    The system idle time was reset because: The system detected user input. 0:01:11 2018-03-23 18:27:49
    The system idle time was reset because: The system detected user input. 0:01:41 2018-03-23 18:28:19
    The system idle time was reset because: The system detected user input. 0:02:11 2018-03-23 18:28:49
    The system idle time was reset because: The system detected user input. 0:02:41 2018-03-23 18:29:19
    The system idle time was reset because: The system detected user input. 0:03:11 2018-03-23 18:29:49
    The system idle time was reset because: The system detected user input. 0:03:41 2018-03-23 18:30:19
    The system idle time was reset because: The system detected user input. 0:04:11 2018-03-23 18:30:49

    Here is another example when the computer goes into hibernation.

    The system idle time was reset because: The system detected user input. 0:00:00 2018-03-20 21:41:24
    The system idle time was reset because: The system detected user input. 0:00:29 2018-03-20 21:41:54
    The system idle time was reset because: An application has indicated the user is present. 10:13:25 2018-03-21 07:54:50

    START TIME DURATION STATE ACTION REASON ID STATUS SUCCESSFUL
    2018-03-20T22:41:48 9:13:02 Hibernate 0 Application API 6 0

    1

    Those messages are not logged when using the computer without RDP.

    I can leave the RDP session on for days without any problems, but one hour after disconnecting, the computer hibernates.

    How do I disable this behavior?

    Many thanks!
    Mikael

    Tuesday, April 10, 2018 6:25 AM

All replies

  • Hi Mikael,

    It says Reason: Application API: So an application triggered this sleep. But which application it is. You may be able to find an application event in the event log near the time of this event to find out what application triggered this. Also, don't forget scheduled tasks or any "power" application, designed to optimize your system.

    Firstly, you could disable fast boot to check.

    Control Panel>Power Options>Choose what the power buttons do>Change settings that are currently unavailable>turn off the fast boot option

    Then you could perform a clean boot and disable the security software to check.

    https://support.microsoft.com/en-sg/help/929135/how-to-perform-a-clean-boot-in-windows

    Have you connected some external devices? I suggest that you could pull them out to check.

    If power settings are set to "Never Sleep" and its disabled in BIOS, then it might be something coming from GPO?

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 11, 2018 3:04 AM
    Moderator
  • Hi Mikael,

    Haven't received your message a few days, was your issue resolved?
    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as answer which can help other community members who have same questions and find the helpful reply quickly.
    Best regards,
    Carl


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Saturday, April 14, 2018 9:48 AM
    Moderator
  • Hi,

    Any update?


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 18, 2018 9:50 AM
    Moderator
  • Hi!

    Sorry for a very late answer.
    Your initial suggestions has already been performed, but the issue still remains. I cant see anything special in the event log that would suggest anything about the shutdown. Only things logged are actions taken due to the shutdown.

    I can also rule out GPOs and scheduled tasks since this only happens after I disconnect from the remote session. If there was no remote session, the computer will run until it is shutdown for real.

    I have a HP Thunderbolt dock connected, I will check if the problem occurs when it is disconnected.

    Also, I have disabled all power management inside device manager.

    Wednesday, April 18, 2018 7:54 PM
  • Hi Mikael,

    Ok. Disconnect the external device to check.

    Then run the command below in CMD as admin.

    powercfg.exe /hibernate off.

    Also have you performed a clean boot to check.

    https://support.microsoft.com/en-sg/help/929135/how-to-perform-a-clean-boot-in-windows

    Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 20, 2018 7:37 AM
    Moderator
  • So, anyone find a real solution to this issue. My machine will stay on for days without anyone touching it, if i connect to remote desktop it works great until i disconnect then the machine will go to sleep. please don't say anything about the sleep setting they are on "never" the same setting they were on 1703 (never had the issue with 1703) this issue is 1709 related. 

    /rant on

    thanks Microsoft your updates are great, my home computers that have gone to 1803 are even worse off guess i will go back to ubuntu for all my non gaming needs. glad you are making an OS to run on phones but are screwing your bread and butter the workstation PC 

     /rant off

    Tuesday, July 10, 2018 5:57 PM