error 1310. error writing to file c config.msi - WILL PAY IF YOU CAN FIX FOR ME! RRS feed

  • Question

  • I have tried everything for the past 14 hours and I can't get Adobe Photoshop CS4 to load on my Vista computer!

    I keep getting the error 1310. error writing to file c config.msi

    I did the delete/create new folder.

    I make sure permissions were all full.

    I uninstalled Carbonite.

    But, STILL. It will not work. I even set ownership to the config.msi folder.

    Will NOT work. What gives?

    I've tried these:

    On Windows Vista

    You would need to perform the steps below on the folder reference in your error message. The Config.msi folder is used in this example.

    1. Select Start > All Programs > Accessories.
    2. Right-click on Command Prompt and select Run As Administrator. A Command Prompt window will open.
    3. In the Command Prompt window, type the following commands exactly as they appear below, including all spaces and quotation marks, and press Enter at the end of each line: 

      icacls "C:\Config.Msi" /T /C /grant administrators:F 
    4. Install Adobe Creative Suite 4 or Point Products.
    I've tried this:


    It does NOT allow me to write to it. Why may I ask? What else can I check? VERY VERY frustrating, this permission stuff is terrible.

    I even unregistered and registered the windows installer again:

    c:\windows\system32\msiexec.exe /regserver
    and then reboot
    Thursday, March 18, 2010 5:09 AM

All replies

  • I did this about a 100 times now and just can't get it to work. I did notice how the "error writing file: .rbf is always different file name. So why is it writing SOME and not OTHERS?

    Seems inconsistent and stops at different spots of the install. You would think if it's a TRUE writing problem, that it would stop at the same place and same file every single time. Which is not the case.

    So, why is this error coming up? What do I do to make it write all the files?
    Thursday, March 18, 2010 5:44 AM
  • I found somewhere someone said to remove Microsoft Office, so I TOTALLY uninstalled Microsoft Office. But still, no luck!

    This is crazy....PLEASE HELP!
    Thursday, March 18, 2010 6:02 AM
  • I will offer up $25 USD via Paypal if you can fix for me! I know it's not a lot, but I need some help. Everything I found does not make it work.


    I can message you via Skype and I can get Teamviewer or something so we can get it working.

    Friday, March 19, 2010 1:15 AM
  • Had same problem.

    The solution for me was to login as local administrator.

    (Un)Impressive that Microsoft did not test this.

    Monday, May 3, 2010 6:46 AM
  • I have the solution that will work for sure. so, you were saying something about paying?

    reply at shagun_malhotra@hotmail.com

    • Proposed as answer by nongrit Friday, June 18, 2010 12:33 PM
    Thursday, June 17, 2010 9:39 PM
  • Solution 1: Disable startup items and services

    Some applications or services may cause system errors or freezes when running concurrently with Contribute. Services are specialized programs that perform functions to support other programs. Before starting Contribute, disable other applications, including startup items (items that start automatically with Windows), and services.

    To disable startup items and services, see "Disable startup items and services (Windows XP)" (TechNote kb404984 ).

    To reenable startup items and services:

    1. Choose Start > Run, type msconfig, and click OK.
    2. Choose Normal Startup on the General tab, click OK, and restart the computer.

    Note: If unselected items were present on the Services or Startup tab, then you will need to unselect them again

    Solution 2: Rename the Config.msi folder

    In some cases, permissions on the folder are in such a state that the permissions changes described below are ineffective. To test to see if data in this folder is causing the problems, attempt the following:

    1. Rename the folder C:\Config.Msi to C:\Config.msi.old
    2. Run the Adobe installer. 
    Sunday, June 20, 2010 1:39 PM
  • I agree, it is crazy.

    I solve the problem this way.

    !. Unistall the program you want to update.

    2. Download the eexecutable for that program to your desktop

    3. Right click the program and run it as an Administrator

    3. When it tells you that it cannot write the file choose retry

    4. Do number 3 as many times as necessary until the setup program informs you that the installation was successful.


    All the best and good luck


    Thursday, October 7, 2010 6:00 PM