locked
Virtual Machine from Template RRS feed

  • Question

  • I have a few template in VMM 2012 R2 but when I try to deploy virtual machine from every of it i receive errors.For example i tried with a Windows 7 Template and at step 1.8 (Customize virtual machine) i receive this error:

    Error (610)
    Virtual Machine Manager was unable to find a value for the required Sysprep parameter LocalAdminCredential.

    Recommended Action
    Add the missing Sysprep parameter either to the answer file or to the operating system configuration, and then try the operation again.

    Information (26278)
    VMM could not offload transfer the file \\MSC2012.test.com\E\VMTemplates\Template-Win7\Template-Win7_disk_1.vhdx to C:\ProgramData\Microsoft\Windows\Hyper-V\Windows7\Template-Win7_disk_1.vhdx.

    I tried too with a WS 2k12 but at 97% it gets stuck and after 15 minutes maybe i receive this error:

    Error (609)
    Virtual Machine Manager cannot detect a heartbeat from the specified virtual machine. Either the virtual machine is not running or Virtual Machine Additions is not installed.

    Recommended Action
    Verify the status of the virtual machine by connecting to it using Virtual Machine Remote Client (VMRC), and then try the operation again.

    Information (26278)
    VMM could not offload transfer the file \\msc2012.test.com\E\VMTemplates\Template-WinServ2012\Template-WinServ2012_disk_1.vhdx to C:\ProgramData\Microsoft\Windows\Hyper-V\WinServ2012\Template-WinServ2012_disk_1.vhdx.

    I had read that I must install Virtual Machine Addition but was about 2k3 version.Can everybody help me with this please?

    Thanks!

    Thursday, June 4, 2015 1:37 PM

Answers

  • Hi Sir,

    >>Virtual Machine Manager was unable to find a value for the required Sysprep parameter LocalAdminCredential.

    According to the error , please check if the local admin account / password was provisioned in guest OS profile .

     Also please refer to following article regarding to "Creating a Template and Successfully Deploying New VMs":

    http://blogs.technet.com/b/jonjor/archive/2010/09/27/creating-a-template-and-successfully-deploying-new-vms.aspx

    Best Regards,

    Elton Ji


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .

    • Proposed as answer by Elton_Ji Thursday, June 18, 2015 6:51 AM
    • Marked as answer by Elton_Ji Tuesday, July 7, 2015 11:01 AM
    Monday, June 8, 2015 2:44 PM