locked
Block E-Mails if attachments not password protected RRS feed

  • Question

  • Hi All,

    Can we create Mail flow rule with below condition?

    We have to block sending e-mails (Both Internal & External users) if attachment is not password protected (Any type of files)?  From Exchange Mail flow rule or From Outlook?


    My goal is below:

    Kindly ensure that the attachment is password protected. Mails with attachments not password protected will not be sent.
    Do send the password in a separate mail.


    i referred below link but i don't see any option related to not password protected attachments.

    https://technet.microsoft.com/en-us/library/jj674307(v=exchg.150).aspx

    Thanks,

    Mani L


    Mani L


    Thursday, May 11, 2017 4:27 AM

All replies

  • In the new rule window, click more options to see options related to the attachment.

    You can try the following, but you have to manually enter all the attachment types that you want to block.:


    My Blog: www.ADExchangeAdmin.com


    • Edited by AbidHassan Thursday, May 11, 2017 5:45 AM
    • Proposed as answer by Niko.Cheng Tuesday, May 16, 2017 2:59 AM
    Thursday, May 11, 2017 5:43 AM
  • Hi Abid,

    I created new Mail flow rule for testing and applied only for specific DL users.

    i waited for more then 1 hour to replicate and tested . But its not working .   I attached the xlsx file without password protected but its going through.   Is anything wrong with this rule? 

    i have to test this rule before applied to all users , so that i selected the sender option with DL.


    Mani L


    Thursday, May 11, 2017 6:51 AM
  • 1. you have added xlsx, if you send xls file it will be delivered.

    2. Exception says, ANY attachment is password protected. May be it means if you have two attachments, one is password protected and the other one is not, it will pass through this rule.


    My Blog: www.ADExchangeAdmin.com

    Thursday, May 11, 2017 7:08 AM
  • i have to block sending mails if any type of attachments is not password protected.

    2. Exception says, ANY attachment is password protected. May be it means if you have two attachments, one is password protected and the other one is not, it will pass through this rule.

    i don't see the above option will help us.

    Thanks,

    Mani L


    Mani L

    Thursday, May 11, 2017 7:17 AM
  • Hi Mani,

    I am afraid this is the limitations of this rule, it only applies to the email which attaches one attachment, can not be applied to multiple attachments at the same time, it's by design.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Niko.Cheng Tuesday, May 16, 2017 2:59 AM
    Friday, May 12, 2017 9:24 AM
  • yes. I verified the same.

    if we attach one document with a password and one without password its allow to send. 

    is there any other way?

    Thanks,

    Mani L


    Mani L

    Saturday, May 13, 2017 7:43 AM
  • Hi Mani,

    Except the above restrictive rule, there is no any build-in feature in Exchange can achieve your requirment.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Niko.Cheng Wednesday, May 17, 2017 9:55 AM
    Tuesday, May 16, 2017 2:59 AM
  • Hi Mani,

    Just checking in to see if above information was helpful. Please let us know if you would like further assistance. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Thanks for your understanding,

    Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 25, 2017 10:06 AM