locked
App-V apps not publishing correctly - Xendesktop non-persistent RRS feed

  • Question

  • Hi all,

    The issue we are having is that when a newly created user logs in to the desktop for the first time they get the App-V apps and icons presented to them in the Start Menu, they can also run the apps.

    However, on subsequent logons the placeholders for the App-V icons are present but they are empty and are pointing to a location it seems, does not exist.

    Looking in EventViewer there are 3 Errors
    EventID 19104 -
    Part or all packages publish failed.
    published: 0
    failed: 2
    Please check the error events of 'Configure/Publish Package' before this message for the details of the failure.

    EventID 1008
    Package {9048a7a5-96f6-4a22-9595-ab905633a8b9} version {9df7fcb5-3ec9-4d33-8de8-083432ebdbe8} failed configuration in folder '' with error 0x74F00F0C-0x801901F7.

    EventID 1008
    Package {332e8d72-6206-49a5-bb1c-ca1ab56aac0d} version {b7149e52-03fe-4ffa-a253-6cb9abb6ef4f} failed configuration in folder '' with error 0x74F00F0C-0x801901F7..

    I have ensured that authenticated users have permissions to the Shared Content Store and also the the Authenticated users is a member of the Users group on each of the Publishing servers.

    Deleting the user profile (or just the NTUSER.DAT file) and logging in again seems to fix the issue but this is obviously not a solution to be taken forward.

    The environment I am having the issues in is as follows -
    We are running App-V 5.0 SP3 in Shared Content Mode on a Windows Server 2012 R2 (Desktop Experience enabled) Citrix non-persistent desktop.

    We are using App-V Full infrastructure (2 Managment, 3 Publishing, 3 Reporting) and using the App-V GPO's to set the various required values. i.e. Publishing server, reporting server etc.

    We are using MDT to create a desktop build which is then pushed out using Citrix Xendesktop.
    We are using Citrix UPM 7.6.300.

    Among others the following File exclusions are in place
    AppData\Local\Microsoft\AppV
    AppData\Roaming\Microsoft\AppV\Client\Catalog

    And the following registry exclusions are in place
    HKCU\SOFTWARE\Microsoft\AppV\Client\Integration
    HKCU\SOFTWARE\Microsoft\AppV\Client\Publishing

    We are using Citrix GPO's for folder redirection and defining the user profile.

    I have not set the following in the environment yet and I am currently in the process of implementing this change to see if it has an effect.
    "Ensure that the following registry key is set to enable Preserving User Integrations On Login
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\Integration]
    "PreserveUserIntegrationsOnLogin"=dword:00000001"

    Has anyone experienced behaviour like this before? I am stumped.
    Tuesday, January 5, 2016 3:08 PM

Answers

  • All,

    I've resolved it.

    Seems as though the GPO which was being applied for the Proxy settings hadn't been configured correctly and therefore when the App-V apps were running they were trying to go through the Proxy when in fact the setting to "Bypass proxy server for local addresses" should have told the App-V apps to ignore the proxy server.

    However, this setting wasn't being applied correctly.

    I set the ProxyOverride registry key with the correct settings
    server.server.com;<local>

    Where <local> was the important piece of the jigsaw!

    Glad i got there in the end!
    Thanks for your replies.
    Tuesday, March 1, 2016 11:10 AM

All replies

  • Are you using Citrix Provisioning Services?

    Simon Dettling | msitproblog.com | @SimonDettling

    Tuesday, January 5, 2016 3:16 PM
    Moderator
  • Hi,

    We are using Machine Creation Services. Similar thing (non-persistent desktops) but in a different way (not streamed over the network, but using non-persistent thin clone storage which gets reset on logoff by the XenDesktop broker).

    Why do you ask?

    Tuesday, January 5, 2016 7:50 PM
  • Can you right-click the AppV icon in the non-working scenario and 'Open File Location' successfully?  

    Is it possible that you do not have 'wait for network' as a GPO option and the group membership is there the first logon but not the second (verified by comparing outputs of 'whoami /groups'

    Wednesday, January 6, 2016 6:28 AM
  • I had a similar Problem, but with Citrix Provisioning Services. The first workaround was to move the Package Installation Root to a persistant drive. But that is not really 100% supported by Microsoft.

    The final solution we ended up though, was to Change the Cache type of the vDisk to "Cache in device RAM with Overflow on harddisk".


    Simon Dettling | msitproblog.com | @SimonDettling



    Wednesday, January 6, 2016 6:33 AM
    Moderator
  • Hi simon,

    Thanks for your reply.

    When you say setting the Package Installation Root to a persistent drive did you then create a new Disk "D:\" and use that as the persistent drive or did you just make it "C:\AppV".

    Could you please give some more detail? Thanks.

    Wednesday, January 6, 2016 9:50 AM
  • We used a persistent (D:\) Drive, where we created an App-V Folder and used GPO to Change the Package Installation Root to that Folder.

    But Keep in mind, if this is working for you, that this is not officially supported.


    Simon Dettling | msitproblog.com | @SimonDettling

    Thursday, January 7, 2016 6:14 AM
    Moderator
  • Monday, January 11, 2016 5:24 PM
    Moderator
  • All,

    I've resolved it.

    Seems as though the GPO which was being applied for the Proxy settings hadn't been configured correctly and therefore when the App-V apps were running they were trying to go through the Proxy when in fact the setting to "Bypass proxy server for local addresses" should have told the App-V apps to ignore the proxy server.

    However, this setting wasn't being applied correctly.

    I set the ProxyOverride registry key with the correct settings
    server.server.com;<local>

    Where <local> was the important piece of the jigsaw!

    Glad i got there in the end!
    Thanks for your replies.
    Tuesday, March 1, 2016 11:10 AM