locked
Windows 7 64bit and installing printers RRS feed

  • Question

  • How can i install a network printer without being asked for admin rights? 

    I would like to give me users the right to select printers off of the printer server since people move around a lot. So they have the ability just as a Domain User to install printer drivers. How could i do this, through group policy?

    Tuesday, December 7, 2010 8:12 PM

Answers

  • I found this in another Technet Article:

    Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\Security Options\Devices: Prevent users from installing printer drivers - Disabled
    Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\Security Options\User Account Control: Detect application installations and prompt for elevation - Disabled
    Computer Configuration\Policies\Administrative Templates\System\Driver Installation\Allow non-administrators to install drivers for these device setup classes - Enabled
    Allowed device setup class GUIDs:
    {4d36e979-e325-11ce-bfc1-08002be10318}
    {4658ee7e-f050-11d1-b6bd-00c04fa372a7}
    Computer Configuration\Administrative Templates\Printers\Point and Print Restrictions - Enable
    Set options "When installing drivers for a new connection:" to "Do not show warning or elevation prompt" and the "When updating drivers for existing connection:" also to " Do not show warning or elevation prompt ":

    I will se what i can do with it. It will take some time and i will post back with results.

    Technet Article: http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/38c7034c-4142-4b67-afb4-1a9ded055e8b

    Update:

    I was able to do the following:
    Computer Configuration\Administrative Templates\Printers\Point and Print Restrictions - Enable
    Set options "When installing drivers for a new connection:" to "Do not show warning or elevation prompt" and the "When updating drivers for existing connection:" also to " Do not show warning or elevation prompt ":

    I back tracked and turned off all the settings i had turned on and the only setting was the one listed above that i needed. This was a test machine with a local GPO i will test it with a AD GPO next.

    Update:

    This worked for me. 


    Where ever you go, there you are.

     

    • Marked as answer by tesdalld Monday, December 20, 2010 2:47 PM
    • Edited by tesdalld Monday, December 20, 2010 2:48 PM
    Wednesday, December 8, 2010 4:13 PM

All replies

  • Refer this link.

    http://magalan.co.uk/install_local_printers_without_admin_rights.html


    "Everything we do is dictated by motive."
    Tuesday, December 7, 2010 9:28 PM
  • You can configure related policy. Please refer the following article.

    Allow Standard Users to Install Drivers For Devices from Specified Setup Classes

    Arthur Xie
    TechNet Subscriber Support in forum  
    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, December 8, 2010 3:49 AM
  • 1. My Domain Users group is in my Power Users group.

    2. We already had on our 2003 AD server a policy for "load and unload drivers". Power Users are part of this policy with the right to load and unload drivers. This is why i posted Step 1.  It doesn't seem to be working for our Windows 7 64 bit machines. It works just fine on our Windows XP machines. It would appear that this is not working because of Step 3. 

    3. We have a Windows Server 2008 R2 server as an AD as well. When i went to the GPedit on both the Windows 7 and 2008 machine the policy "Allow non-administrators to install drivers for these device setup classes" was not in the list where they said it should be.


    Where ever you go, there you are.
    Wednesday, December 8, 2010 3:47 PM
  • I found this in another Technet Article:

    Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\Security Options\Devices: Prevent users from installing printer drivers - Disabled
    Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\Security Options\User Account Control: Detect application installations and prompt for elevation - Disabled
    Computer Configuration\Policies\Administrative Templates\System\Driver Installation\Allow non-administrators to install drivers for these device setup classes - Enabled
    Allowed device setup class GUIDs:
    {4d36e979-e325-11ce-bfc1-08002be10318}
    {4658ee7e-f050-11d1-b6bd-00c04fa372a7}
    Computer Configuration\Administrative Templates\Printers\Point and Print Restrictions - Enable
    Set options "When installing drivers for a new connection:" to "Do not show warning or elevation prompt" and the "When updating drivers for existing connection:" also to " Do not show warning or elevation prompt ":

    I will se what i can do with it. It will take some time and i will post back with results.

    Technet Article: http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/38c7034c-4142-4b67-afb4-1a9ded055e8b

    Update:

    I was able to do the following:
    Computer Configuration\Administrative Templates\Printers\Point and Print Restrictions - Enable
    Set options "When installing drivers for a new connection:" to "Do not show warning or elevation prompt" and the "When updating drivers for existing connection:" also to " Do not show warning or elevation prompt ":

    I back tracked and turned off all the settings i had turned on and the only setting was the one listed above that i needed. This was a test machine with a local GPO i will test it with a AD GPO next.

    Update:

    This worked for me. 


    Where ever you go, there you are.

     

    • Marked as answer by tesdalld Monday, December 20, 2010 2:47 PM
    • Edited by tesdalld Monday, December 20, 2010 2:48 PM
    Wednesday, December 8, 2010 4:13 PM
  • Hi,

    Power User group is not present in Windows 7. The Power User group in your system is for backwards compatibility. Therefore you need to follow the steps in the article to create the GPO.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Monday, December 20, 2010 9:18 AM
    • Unmarked as answer by tesdalld Monday, December 20, 2010 2:47 PM
    Monday, December 13, 2010 4:13 AM
  • Hi,

    Just want to confirm if you have got it worked.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, December 14, 2010 4:19 AM