locked
RDP is not working after installing MOSS 2007 RRS feed

  • Question

  • Hello experts,

    Does anyone have any clue that why RDP just suddenly stopped working after installing Moss 2007?

    Thanks.

    Thursday, November 4, 2010 2:16 PM

Answers

  • After reinstalling sharepoint, everything worked fine.

    Thanks all for help.

    • Marked as answer by Me.Saqib Friday, November 5, 2010 2:21 PM
    Friday, November 5, 2010 2:21 PM

All replies

  • What is the error?
    Oleg
    Thursday, November 4, 2010 2:38 PM
  • There is no error in eventvwr. Its just port 3389 is not listening anymore.

    Thursday, November 4, 2010 2:39 PM
  • Open Terminal Servicees Manager and check what the status is of RDP-Tcp (listner)
    Oleg
    Thursday, November 4, 2010 3:08 PM
  • I checked terminal services manager. There is nothing like status field but it shows RDP, RDP version Microsoft 5.2 on the right pane of window.

    If I see the properties, RDP is listening to ALL network adapters on server.

    Thursday, November 4, 2010 3:33 PM
  • What port did you assign to central administration?
    Conrad Goodman MCITP SA / MCTS: WSS3.0 + MOSS2007
    Thursday, November 4, 2010 3:39 PM
  • 1133
    Thursday, November 4, 2010 3:42 PM
  • SharePoint can affect RDP just if you accidently created a site on port 3389 but in this case some errors should be in Application event log. 

    Can you make a simple test from server? Run telnet localhost 3389


    Oleg
    Thursday, November 4, 2010 3:48 PM
  • I have done this test already.

    Couldnt open a connection on port 3389, connection failed.

    Thursday, November 4, 2010 3:57 PM
  • which OS are you running on? Is firewall enabled? Can you please send output from the following command

    netstat -abn

     


    Sameer Dhoot
    My Blog : http://sharemypoint.in/

    Did I answer your question? If YES, Mark as Answer. If NO, reply with details to continue dialogue.

    Thursday, November 4, 2010 5:28 PM
  • There is NO firewall.

    OS : Windows Server 2003 Enterprise w/ SP2

    The output of command is:


    Active Connections

      Proto  Local Address          Foreign Address        State           PID
      TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       4
      [System]

      TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       716
      RpcSs
      [svchost.exe]

      TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
      [System]

      TCP    0.0.0.0:1035           0.0.0.0:0              LISTENING       1000
      [msdtc.exe]

      TCP    0.0.0.0:1045           0.0.0.0:0              LISTENING       1936
      [mqsvc.exe]

      TCP    0.0.0.0:1082           0.0.0.0:0              LISTENING       468
      [lsass.exe]

      TCP    0.0.0.0:1133           0.0.0.0:0              LISTENING       4
      [System]

      TCP    0.0.0.0:1433           0.0.0.0:0              LISTENING       1472
      [sqlservr.exe]

      TCP    0.0.0.0:1801           0.0.0.0:0              LISTENING       1936
      [mqsvc.exe]

      TCP    0.0.0.0:2103           0.0.0.0:0              LISTENING       1936
      [mqsvc.exe]

      TCP    0.0.0.0:2105           0.0.0.0:0              LISTENING       1936
      [mqsvc.exe]

      TCP    0.0.0.0:2107           0.0.0.0:0              LISTENING       1936
      [mqsvc.exe]

      TCP    0.0.0.0:2157           0.0.0.0:0              LISTENING       836
      ShellHWDetection
      [svchost.exe]

      TCP    0.0.0.0:5356           0.0.0.0:0              LISTENING       2416
      [sqlservr.exe]

      TCP    0.0.0.0:56737          0.0.0.0:0              LISTENING       4
      [System]

      TCP    0.0.0.0:56738          0.0.0.0:0              LISTENING       4
      [System]

      TCP    127.0.0.1:1434         0.0.0.0:0              LISTENING       1472
      [sqlservr.exe]

      TCP    192.168.1.5:139        0.0.0.0:0              LISTENING       4
      [System]

      TCP    192.168.1.5:1433       192.168.1.66:1707      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:1300       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.111:2598     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.111:3166     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:2258       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.66:1690      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.95:1543      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2477      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:2305       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2535      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2489      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.111:3217     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.66:1706      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:2259       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2536      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.67:2283      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:1299       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2503      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2719      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:2257       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:2278       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.67:1902      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.111:2655     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.67:1892      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2534      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.111:3093     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2579      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.126:4993     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2725      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.2:2008       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2487      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.123:58223    ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.126:3819     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.56:2486      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.95:1541      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.111:1378     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.5:2009       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.111:2964     ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.67:1903      ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:1433       192.168.1.5:2012       ESTABLISHED     1472
      [sqlservr.exe]

      TCP    192.168.1.5:2009       192.168.1.5:1433       ESTABLISHED     5448
      [OWSTIMER.EXE]

      TCP    192.168.1.5:2012       192.168.1.5:1433       ESTABLISHED     5448
      [OWSTIMER.EXE]

      TCP    192.168.1.5:2019       192.168.1.10:1026      ESTABLISHED     468
      [lsass.exe]

      TCP    192.168.1.5:5356       192.168.1.89:49225     ESTABLISHED     2416
      [sqlservr.exe]

      TCP    192.168.1.5:2018       192.168.1.10:1026      TIME_WAIT       0
      UDP    0.0.0.0:1043           *:*                                    1936
      [mqsvc.exe]

      UDP    0.0.0.0:1434           *:*                                    1760
      [sqlbrowser.exe]

      UDP    0.0.0.0:500            *:*                                    468
      [lsass.exe]

      UDP    0.0.0.0:3527           *:*                                    1936
      [mqsvc.exe]

      UDP    0.0.0.0:445            *:*                                    4
      [System]

      UDP    0.0.0.0:4500           *:*                                    468
      [lsass.exe]

      UDP    127.0.0.1:1113         *:*                                    976
      [spoolsv.exe]

      UDP    127.0.0.1:1067         *:*                                    408
      [winlogon.exe]

      UDP    127.0.0.1:123          *:*                                    820
      W32Time
      [svchost.exe]

      UDP    127.0.0.1:1044         *:*                                    1936
      [mqsvc.exe]

      UDP    127.0.0.1:1356         *:*                                    1472
      [sqlservr.exe]

      UDP    127.0.0.1:2375         *:*                                    5448
      [OWSTIMER.EXE]

      UDP    127.0.0.1:1025         *:*                                    468
      [lsass.exe]

      UDP    192.168.1.5:137        *:*                                    4
      [System]

      UDP    192.168.1.5:123        *:*                                    820
      W32Time
      [svchost.exe]

      UDP    192.168.1.5:138        *:*                                    4
      [System]

    Thursday, November 4, 2010 5:44 PM
  • I have seen the output, well good thing is that no other process is listening on port 3389. So this is not an after effect of you installing SharePoint. The Terminal Service is somehow not turned on.

    See if this helps you...

    http://www.itnewsgroups.net/windowsserver/t21732-terminal-services-not-working-port-3389-not-listening.aspx

     

    • Edited by Mike Walsh FIN Thursday, December 9, 2010 5:53 PM Sig removed. Do NOT ask people to mark your posts.
    Thursday, November 4, 2010 6:08 PM
  • But Terminal Services is running. I can see that in services as Started.

    Also I checked it using tasklist /svc command and I can see running using 2736 PID.

    Thursday, November 4, 2010 6:25 PM
  • Hi,

    Has the IP Addres been changed maybe for a hybrid to a static? Were any entries made in DNS that may have accideyallu affect the ServerName. Have you tried RDP (MSTSC) to the IP Address?

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Thursday, November 4, 2010 6:34 PM
  • Let me tell you that I just completely uninstalled Sharepoint Server 2007 and RDP is started WORKING!

    I m not sure what SP did but definitely causing the issue.

    I dont know should I install it again or not?

    Thursday, November 4, 2010 6:47 PM
  • After reinstalling sharepoint, everything worked fine.

    Thanks all for help.

    • Marked as answer by Me.Saqib Friday, November 5, 2010 2:21 PM
    Friday, November 5, 2010 2:21 PM