locked
problem applying clock format from gpo to windows 10 RRS feed

  • Question

  • hi all,

    im trying to apply clock format using GPO regional options settings like so:

    but windows 10 (Enterprise N 2016 LTSB) refuses to update the clock accordingly.

    anyone encountered this issue?

    thanks

    Sean.

    Tuesday, January 17, 2017 5:05 AM

Answers

  • Hi,

    How about the issue, is there anything to update?

    I tried to configure that gpp but that configuration will be reset to default every time I click "Apply" and reopen it.

    If you want to change the registry key, please check the following key:
    HKCU\Control Panel\International

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Cute_Fluff Saturday, January 21, 2017 9:25 AM
    Friday, January 20, 2017 8:26 AM
  • hi David,

    not your fault i did miss that part out :)

    eventually i stopped fighting with this specific GPP (i think there is some bug in there)

    i followed MeipoXu's advice and deployed a registry key to all stations

    HKEY_CURRENT_USER\Control Panel\International\sShortTime
    value: HH:mm

    it seems that this value was stuck on h:mm tt and it does not update in windows 10.

    Thank you everyone for the help and contribution! Have a nice weekend,

    Sean 


    • Marked as answer by Cute_Fluff Saturday, January 21, 2017 9:25 AM
    • Edited by Cute_Fluff Saturday, January 21, 2017 9:33 AM polite
    Saturday, January 21, 2017 9:25 AM

All replies

  • Hi Cute_Fluff,

    I have checked the gpp configuration. There is no option called "HH:mm", it should be "HH:mm:ss".

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 18, 2017 3:12 AM
  • Hi MeipoXu

    thank you for your response, i tried all the default values that are available from the drop down menu in the GPP but it did not work so i thought maybe i should match the format as it is shown in windows 10 time settings. all options did not work for me...

    by the way, parts of the policy do apply as i can change the AM/PM to GG/WP with no problem - its just the "short time" format that is not playing nice

    i will try to lookup the reg keys and modify them manually, ill report back with the results.

    thank you again for all the time and help

    have a great day,

    Sean

    Wednesday, January 18, 2017 4:27 AM
  • Hi,

    How about the issue, is there anything to update?

    I tried to configure that gpp but that configuration will be reset to default every time I click "Apply" and reopen it.

    If you want to change the registry key, please check the following key:
    HKCU\Control Panel\International

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Cute_Fluff Saturday, January 21, 2017 9:25 AM
    Friday, January 20, 2017 8:26 AM
  • Hi Cute_Fluff,

    I have checked the gpp configuration. There is no option called "HH:mm", it should be "HH:mm:ss".

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Start > Settings > select Time and Language > left side, select Date and time > right side, under Formats, click Change date and time formats > under Short time, click the pointer and select HH:mm

    Will that do ?

    Result................

    • Edited by david hk129 Friday, January 20, 2017 9:22 AM
    Friday, January 20, 2017 9:12 AM
  • Hi David, 

    Thank you for your reply, of course I can do that manually but I need to update thousands of computers :) 

    So group policy is my best option as far as I can tell. 

    Thank, 

    Sean. 

    Friday, January 20, 2017 10:50 AM
  • Hi David, 

    Thank you for your reply, of course I can do that manually but I need to update thousands of computers :) 

    So group policy is my best option as far as I can tell. 

    Thank, 

    Sean. 


    Sorry. I did not realize you were managing a system of computers. I missed that part.


    • Edited by david hk129 Friday, January 20, 2017 3:53 PM
    Friday, January 20, 2017 3:45 PM
  • hi David,

    not your fault i did miss that part out :)

    eventually i stopped fighting with this specific GPP (i think there is some bug in there)

    i followed MeipoXu's advice and deployed a registry key to all stations

    HKEY_CURRENT_USER\Control Panel\International\sShortTime
    value: HH:mm

    it seems that this value was stuck on h:mm tt and it does not update in windows 10.

    Thank you everyone for the help and contribution! Have a nice weekend,

    Sean 


    • Marked as answer by Cute_Fluff Saturday, January 21, 2017 9:25 AM
    • Edited by Cute_Fluff Saturday, January 21, 2017 9:33 AM polite
    Saturday, January 21, 2017 9:25 AM
  • Hi,

    It seems this is an old question so far, but here goes what the problem might be with the GPO.

    When you format the date or time, you need to go through all the tabs and press F5 until all the red lines are green, and then it won't reset by itself.

    I learnt it from here:

    https://theezitguy.wordpress.com/2014/08/07/group-policy-use-regional-settings-to-change-date-format/comment-page-1/

    Friday, January 10, 2020 8:23 PM