none
Ghost project in Reporting RRS feed

  • Question

  • Hi,

    My Excel Reports are disturbed by a project that I deleted some weeks ago. This project is still remaining in the Reporting database (dbo.MSP_EpmProject table).

    How can I delete it?

    Thursday, July 14, 2011 5:25 PM

Answers

  • Hello,

    As Paul suggested, You can run the SProc & delete the proc, which SHOULD work but If you are doing on production Is is safe to rebuild the Reporting database.

    Logon to Project Web Access with Administrator credentials
    Select Administrative Backup from the Database Administration section on the Server Settings Page in Project Web Access
    In the Items for Backup section of the Backup page, select the checkbox for Enterprise Custom Fields and then click the Backup button and click the OK button when prompted by the system
    Select Administrative Restore from the Database Administration section on the Server Settings Page in Project Web Access
    Choose Enterprise Custom Fields from the Choose Item selector on the Restore page
    Click the Restore button and then click the OK button when prompted by the system
    Now the reporting database will take some time to rebuild depending on the volume of data & once the Reporting database refresh job completes, It will not show the deleted project.

    Please refer to do step by step: http://www.msprojectnow.com/Blog/tabid/142/entryid/166/Default.aspx

    Hope that helps.


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    Friday, July 15, 2011 5:28 AM
  • As Amit stated, rebuilding the Reporting database may take some time so I would recommend running this out of hours / over a weekend.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    • Marked as answer by WLID1966 Tuesday, July 19, 2011 7:00 PM
    Tuesday, July 19, 2011 6:49 PM
    Moderator

All replies

  • Hi there,

    The reporting delete job may have failed.. You could change the queue history to see if you can see if the failed job is still there and maybe retry the job. If not and if this project doesn't exist in the Published database you could delete this project by executing the dbo.MSP_Epm_DeleteProject stored procedure manually in the Reporting database, you will need to pass the ProjectUID. I would test this on a test environment first if this is your Production environment.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Thursday, July 14, 2011 9:04 PM
    Moderator
  • Hello,

    As Paul suggested, You can run the SProc & delete the proc, which SHOULD work but If you are doing on production Is is safe to rebuild the Reporting database.

    Logon to Project Web Access with Administrator credentials
    Select Administrative Backup from the Database Administration section on the Server Settings Page in Project Web Access
    In the Items for Backup section of the Backup page, select the checkbox for Enterprise Custom Fields and then click the Backup button and click the OK button when prompted by the system
    Select Administrative Restore from the Database Administration section on the Server Settings Page in Project Web Access
    Choose Enterprise Custom Fields from the Choose Item selector on the Restore page
    Click the Restore button and then click the OK button when prompted by the system
    Now the reporting database will take some time to rebuild depending on the volume of data & once the Reporting database refresh job completes, It will not show the deleted project.

    Please refer to do step by step: http://www.msprojectnow.com/Blog/tabid/142/entryid/166/Default.aspx

    Hope that helps.


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    Friday, July 15, 2011 5:28 AM
  • Thanks, I'll work on that !
    Tuesday, July 19, 2011 6:46 PM
  • As Amit stated, rebuilding the Reporting database may take some time so I would recommend running this out of hours / over a weekend.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    • Marked as answer by WLID1966 Tuesday, July 19, 2011 7:00 PM
    Tuesday, July 19, 2011 6:49 PM
    Moderator