locked
"Microsoft Input Configuration Device" driver causing problems with multitouch on a Lenovo ThinkPad X230T RRS feed

  • Question

  • Hello,

    This problem started occurring recently. I have a Lenovo ThinkPad X230T (Windows 7 installed) with a display capable of both pen and multitouch input. Every time I resume the machine from sleep, hibernation, or shut-down, multitouch input does not work. Instead, the system interprets my touch inputs as "click" or "click-and-drag" mouse inputs, so I cannot do things like scroll or zoom web pages. I can fix the problem by going to the Device Manager and disabling & re-enabling a driver called "Microsoft Input Configuration Device." However, I have to do this every time I wake the machine, which is quite annoying for my application of this machine.

    I already tried to fix it (with no success) by doing the following:

    • Updating the driver
    • Uninstalling & reinstalling the driver
    • Uninstalling, reinstalling, & updating all drivers having to do with touch, pen, or mouse input
    • Using System Restore to roll back the machine to a time when this worked properly

    I have the same problem on an Acer Aspire 1420P laptop that I don't use so much anymore, so this problem does not seem to be unique.

    Sunday, October 13, 2013 2:46 AM

Answers

  • Yes, I tried it with the "Allow this device to wake the computer" option both on and off, and neither choice fixed the problem. And I also tried reinstalling the drivers in "Clean Boot" mode with no success.

    The find for a solution to this problem was critical for my workplace; and as my attempted fixes to solve the problem started causing blue screens of death while booting the operating system, I now did a clean reinstall of the operating system, and that fixed the problem.

    • Marked as answer by Karen Hu Friday, November 1, 2013 1:37 AM
    Friday, October 18, 2013 4:42 PM

All replies