none
Replica is inconsistant on Exchange 2010 mail database RRS feed

  • Question

  • Below is the error I recieve in the DPM 2010 Monitoring Alert.  I am using Exhange 2010 v 14.01.0289.001 on a Windows 2008 R2 SP1 Enterprise server.  DPM 2010 on a Windows Server Enterprise SP2.

    I have been getting these erros enough that my transaction log files have taken up all of my hard drive space on the log file drive.  So I decided to remove the database from the current protect group and start over.

    I created a new protection group and added the 1 mail database, ended up say it was 186GB and 485GB was allocated.

    Exchange 2010 is not being backed up by anything else.  Circular loggin is not enabled.  There is only 1 copy of the database for backup.  I have ran the consitancy check with syncronization and still get the replica is inconsistant error.  I have also tried to create a recovery point with a full backup and I get an error that tells me:  "Cannot perform creation of a recovery point on a replica which is inconsistent. (ID: 31209)  Run syncronization with consistency check for this replica and then retry this operation."

    This is a vicious circle - there is no solution that I see!!  I need some ideas to get successful backups so the transaction logs are removed and email can still be received!

    Thanks!

     

    DPM Error:

    Affected area: SG1-Def
    Occurred since: 8/26/2011 4:13:16 PM
    Description: The replica of Exchange Mailbox Database SG1-Default on CHIPMBX01 is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. You can recover data from existing recovery points, but new recovery points cannot be created until the replica is consistent.

    For SharePoint farm, recovery points will continue getting created with the databases that are consistent. To backup inconsistent databases, run a consistency check on the farm. (ID 3106)
     DPM has detected a discontinuity in the log chain for Exchange Mailbox Database SG1-Def on CHPMBX01 since the last synchronization. (ID 30216 Details: Unspecified error (0x80004005))
     More information
    Recommended action: 
    1. Consult the administrator of the Exchange server to rectify the problem. Please ensure that Exchange circular logging is turned off. Synchronization jobs may continue to fail until this issue is resolved.
    2. Last backup might have failed after log truncation.

    In the Protection task area, click 'Create recovery point' and select 'Full backup' option.
    3. If the protected datasource is an Exchange 2010 database, make sure that multiple copies of the database are not protected for FULL backup. DPM supports protecting only one copy of the database using FULL backup and the other copies have to be protected using COPY backup.
     Synchronize with consistency check.
     Run a synchronization job with consistency check...
    Resolution: To dismiss the alert, click below
     Inactivate alert

    Friday, August 26, 2011 9:47 PM

Answers

  • Solution

    1. Dismount Mailbox
      Databases in the Storage Group;
    2. Move all .log files
      from the Exchange database directory to another directory;
    3. Mount the databases
      again, all logfiles ar gone and you should now be able to perform a
      backup;
    4. You can delete the
      moved logfiles when everything is working correctly again.

    sys_admin

    Wednesday, July 11, 2012 5:23 AM
    Moderator

All replies

  • When you do an initial backup of DPM you will grab the database and log files - DPM will need at least 300 MB of free space on the volume that the Exchange database and log files reside on to create the VSS snap. Upon successful completion of an express full backup of Exchange the log files will be truncated until the next successful DPM backup - so your logs will not shrink until a successful backup.

    If you're out of disk space for Exchange and you're not going to be able to get a backup then you need to figure out another method of freeing up disk space (moving the Exchange logs to another volume or enabling circular logging temporarily - these are only suggestions, I'm not an Exchange engineer :))

    You might also want to run a vssadmin list writers on the Exchange server to make sure the VSS writer for Exchange is in a good state. If it is in an error state you'll need to restart the information store service to put the VSS writer into a good state (the two are integrated).

    Wednesday, September 7, 2011 5:06 AM
  • Solution

    1. Dismount Mailbox
      Databases in the Storage Group;
    2. Move all .log files
      from the Exchange database directory to another directory;
    3. Mount the databases
      again, all logfiles ar gone and you should now be able to perform a
      backup;
    4. You can delete the
      moved logfiles when everything is working correctly again.

    sys_admin

    Wednesday, July 11, 2012 5:23 AM
    Moderator
  • http://support.microsoft.com/kb/2664761

    Upgrade you Exchange to SP2 RU2 or 3

    Saturday, August 11, 2012 12:54 PM