none
Windows 10 l2tp/ipsec error code 809

    Question

  • Hello

    I have a firewall which also act as a VPN server, it works fine til last week a windows update, it suddenly failed to connect my VPN and has an error code 809

    but my android and other PC running windows 7's connection on same VPN are working normally,

    I edit regedit prodile to add a policy to let VPN work behind NAT, shutdown windows firewall and antivirus software and still no go, 

    but another VPN use PPTP works well, anyone has any idea? many thanks.   

    Monday, July 17, 2017 9:26 AM

All replies

  • Hi alotofjeff

    >>I edit regedit prodile to add a policy to let VPN work behind NAT

    Please try to recreate a new connect and reset the following regedit.

    1.Using Registry Editor, create a new DWORD value called "AssumeUDPEncapsulationContextOnSendRule" under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent" and set it to "2"

    2.Click Start, Settings

      Choose the "Network and Internet" category

      Click the "VPN" button in the left hand menu

      Click "Add a VPN connection" and use the following:

    • VPN provider: Windows (built-in)
    • Connection Name: anything you like, this is what's displayed in the UI
    • Server name or address: the external hostname of your VPN
    • VPN type: L2TP/IPsec
    • Type of sign-in info: Username and password
    • Username/Password/Remember me: these are optional, set as required
    • Click "Save"

      Click "Change adapter options"

      Right click the connection you just created, and click Properties

      Under the Security tab, click "Advanced Settings"

      Select "use pre-shared key" and enter the PSK, click OK

      Set "Data encryption" to "maximum strength"

      Under Authentication, select "Allow these protocols" and tick ONLY the PAP box

    At this point, if you made the registry change you will need to reboot your computer.

    3.In addition, please disable the service of Xbox Live Networking Services to check if the problem still occurs.

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, July 18, 2017 2:07 AM
    Moderator
  •  Set "Data encryption" to "maximum strength"

    still got error code 809

    1.Using Registry Editor, create a new DWORD value called "AssumeUDPEncapsulationContextOnSendRule" under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent" and set it to "2"

    I did it in the first place, doesn't work

    other settings are all the same as my original workable setting.

    Friday, July 21, 2017 1:47 AM
  • Hello,

    I have done all the steps above too and still cannot connect. I am attempting to connect via Pre-Shared Key.

    Any other suggestions?

    Thursday, March 08, 2018 8:29 PM