locked
Outlook 2007 Error When Connecting to Sharepoint RRS feed

  • Question

  •  

    Using Outlook 2007 (Pro Plus in my case), I can successfully receive an alert from SharePoint for additions or modifications. In Outlook 2007, the alert has a "Connect to..." button at the upper left of the message, e.g. "Connect to this Discussion Board".

     

    When a user or myself (admin with Full Control) selects that button, an immediate Outlook Send/Receive Error is displayed:

     

    Task "SharePoint' reported error (0x800401F3): 'Unknown Error 0x800401F3'

     

    The Discussion Board will show up in the Outlook folder view under SharePoint Lists. However it will be empty.

     

    If I went to the Discussion Board on the site and selected Connect to Outlook, this works fine and Outlook populates the List.

     

    This is not isolated to discussion boards. It gives the same error selecting the Connect To button for Calendars or anything else that comes in an alert.

     

    Does anyone have a clue what is causing this?

     

    Thanks!

     

    Thursday, April 3, 2008 4:45 PM

Answers

  • what about using an smtp server?  i currently work for an isp and we have customers that occasionally call in with the same issue.  but they have the issue connecting to our servers.  it dont matter if its port 587 or 25.  and it can be 1 person getting the unknown error out of maybe 10 people in an office.  so 9 out of 10 people having no problems with exact same email settings.  disabling firewalls, disabling email scanners etc.  mail sits in the outbox and doesnt seem to want to come to our server.  sometimes random things may fix it, like firewalls or antivirus.  sometimes we get stumped and look on google.  which leads me here.  i have gone to several different boards looking for some clues but nothing. 

    i dont know if it helps, but our servers answer on 25 and 587, secure and non secure, but they do require authentication.  by default we set people up as non secure connections but the secure option is there in case they want it.
    Friday, November 7, 2008 5:53 PM

All replies

  • Did you configured the trusted location in CA for outlook?.. and after that if you get this error.. one way is configuring the outlook to web server manually.. then it will work..
    Thursday, April 3, 2008 6:46 PM
  • Thanks for the response.

     

    We aren't using PKI so we aren't using a CA. Is that required?

     

    What do you mean 'configuring manually'? Is that a setting in the Outlook client?

     

    Thanks.

     

     

    Thursday, April 3, 2008 8:14 PM
  • bump

    Monday, April 7, 2008 8:27 PM
  • Was a resolution ever found for this problem?  I am having the exact same issue.  We're using SharePoint Services 3.0, Exchange 2003, and Outlook 2007.

     

    Wednesday, April 30, 2008 9:24 PM
  • TTT

     

    Does anyone have a resolution yet?

     

    Monday, May 12, 2008 6:59 PM
  • i have the same problem too. MOSS2007 > EXCHANGE 2003 > OUTLOOK 2007 CLIENT

     

    when i choose connect to outlook from the task list, no problem. but following the email like i get the same as everyone else....

    Task 'SharePoint' reported error (0x800401F3) : 'Unknown Error 0x800401F3'

     

    Tuesday, May 13, 2008 8:01 PM
  • Same Issue - MOSS 2007 & Office 2007 Pro. Any resolution to the problem?

     

    Tuesday, June 10, 2008 1:43 PM
  • It apprears Microsoft is ignoring this issue. I've talked to a few friends at other companies that have the same issues.

     

    Wednesday, June 11, 2008 2:01 PM
  • I was having this same issue when selecting Send/Receive.  I recall recently adding a calendar from the SharePoint site to my Outlook and the problem occurred shortly after adding it.  I went back to my Outlook under SharePoint Lists and removed it.  Selected Send/Receive with no error.  Went back to the calendar that I had added and selected it again adding it back to my SharePoint Lists and conducted a Send/Receive with no problem.

     

    Wednesday, June 11, 2008 5:18 PM
  • I tried exactly what Harold did - for some users it works for others it does not.  I'm told by our Exchange administrator that particular error message is a service error.  I believe Send/Receive is a "service."  I tried to isolate it and thought that I did, but I couldn't repeat it for another user.  I modified the Send/Receive settings to do one type of action at a time, for example: do only SharePoint Calendar Items; then do only SharePoint files; etc.  It looked like the discussion board was causing errors, but like I said I couldn't repeat it to confirm.

     

    This issue is still unresolved for us.  I'm hoping that an Exchange patch will fix this as well as a "Cannot Open Item" error message also related to SharePoint, but I've yet to convince the Exch Admin to apply it. 

     

    Tuesday, June 17, 2008 8:56 PM
  • Same Error - wow, if this forum is stumped, where to go...?
    Monday, August 4, 2008 11:48 PM
  •  Against better knowledge, but at least this topic doesn't die :)

    Same problem, looking around for answers, only to find many people with this problem :(
    Tuesday, August 12, 2008 9:49 AM
  • Same problem.... I'm betting it's the Groupboard Workspace.... it's caused me nothing but grief since I installed it..... I'm trying to resolve this today.. If I discover any solution ... I'll post here.
    Thursday, August 14, 2008 3:49 PM
  • Same issue. 

    To the MS admins:
    How is it that ALL our client machines can report the same memory address as the problem (0x800401F3) if the server isn't  the source of the issue?  Maybe they communicate telepathically?

    To Hays33d:
    I think Indra meant CA to be Central Admin not Certificate Authority.  MOSS lingo is taking over the world muhahaha!!


    Thursday, August 28, 2008 11:27 AM
  • SharePoint Ninja said:

    Same issue. 

    To the MS admins:
    How is it that ALL our client machines can report the same memory address as the problem (0x800401F3) if the server isn't  the source of the issue?  Maybe they communicate telepathically?

    To Hays33d:
    I think Indra meant CA to be Central Admin not Certificate Authority.  MOSS lingo is taking over the world muhahaha!!




     FYI - it's not a memory address, it's an HRESULT (that's the return code to a function call).
    All postings are as-is and with out warranty.
    Thursday, August 28, 2008 4:04 PM
  • Ahhh...  thanks Chad.

    So since you have MS on your name I'll assume you work for MS.  Can you tell us if this error is something I should raise w/ my supervisors?  It's mostly just inconvenient, but I'd like to hear it from MS that there arent' any NEW holes in security that may be opened by this. 

    The HRESULT we are all getting says this: (http://msdn.microsoft.com/en-us/library/cc704587.aspx)
    0x800401F3

    Invalid class string

    CO_E_CLASSSTRING

     



    Friday, August 29, 2008 1:26 PM
  • Server object, ASP 0177 (0x800401F3)
    Invalid class string
    /myweb/dllTestVb.asp, line 8

    CODE:
    <%@ Language=VBScript %>
    <%
    dim myCustomer
    dim strCName

    ' Create the component.
    set myCustomer=server.createobject("CustomerLib.clsCustomer")

    ' Call the method.
    strCName = myCustomer.GetCustomerName

    ' Display the return value.
    Response.Write ("<h1>" & strCName & "</h1")


    So if this MS Library Class is capable of producing the exact same HRESULT as adding someone's calendar view to outlook, wouldn't it have to be related to a MS Library or the lack of proper registering of its binaries?

    Also see http://forums.devx.com/showthread.php?threadid=5643 


    Friday, August 29, 2008 1:50 PM
  • Currently, I have 5 cases open on this issue... The problem appears to be Outlook 2007 not decoding a Base64 Encoded Header value that is present in the alert messages.

    Exchange 2003 was release prior to any existence or knowledge of these Sharepoint Alert Messages. According to SMTP Standards, we are not supposed to alter the existing SMTP headers of messages as they flow in transport. We are only allowed to add new trnasport headers. I am currently working with Outlook Escalation Engineers to determine why Outlook and Sharepoint are not communicating correctly.

    Exchange 2007, being Sharepoint aware, is decoding these values (at the risk of being out of compliance), while Exchange 2003 is adhering to the RFC. In other words, if some other product were to use headers such as X-AlertWebUrl,  X-AlertTitle, X-AlertWebSoap and a variety of others, we would break those applications that are designed to properly decode those values.

    Another problem we have in regards to filing a design change request for Exchange 2003 is that this will not fix the Sharepoint to  Outlook issue in Non-Exchange Environments. Especially in Hosting situations where Exchange is not used for electronic mail services.

    We are currently looking into this and attempting to determine why Outlook 2007 is not decoding the values properly. Encoding the values in the SMTP headers is required due to the fact that those headers may have to contain values that are not allowed in typical RFC 822 headers.

    As we find resolutions to this problem, I will post our findings here.
    Monday, September 15, 2008 6:36 PM
  • Keith,

    you say that Exchange 2007 understands SharePoint but I am using Exchange 2007, Office 2007 (Outlook 2007) and MOSS and still get the same error when I send and receive in Outlook.  Same exact error code.

    Don't just patch Exchange 2003; The problem appears to be elsewhere.

    JB
    Monday, September 29, 2008 3:01 PM
  • We are also experiencing the same issue.  We are using Exchange 2007, Outlook 2007, Vista and SharePoint/Moss 2007.  What is the latest news from Microsoft?

    sharepoint
    Friday, October 24, 2008 4:04 PM
  • what about using an smtp server?  i currently work for an isp and we have customers that occasionally call in with the same issue.  but they have the issue connecting to our servers.  it dont matter if its port 587 or 25.  and it can be 1 person getting the unknown error out of maybe 10 people in an office.  so 9 out of 10 people having no problems with exact same email settings.  disabling firewalls, disabling email scanners etc.  mail sits in the outbox and doesnt seem to want to come to our server.  sometimes random things may fix it, like firewalls or antivirus.  sometimes we get stumped and look on google.  which leads me here.  i have gone to several different boards looking for some clues but nothing. 

    i dont know if it helps, but our servers answer on 25 and 587, secure and non secure, but they do require authentication.  by default we set people up as non secure connections but the secure option is there in case they want it.
    Friday, November 7, 2008 5:53 PM
  • same problem here in my company.
    outlook 2007, sharepoint 2007 12.0.0.6318

    error 0x800401F3 shows up in outlook after i tried to connect a new task

    please help!
    Tuesday, November 11, 2008 1:12 PM
  • Just curious, but I noticed that the trailing forward slash was missing on all the "Connect to..." links that were throwing the error, while some older links that had the trailing slash seemed to work fine, does this have any bearing on this issue?
    Monday, November 17, 2008 11:22 PM
  • Well I hope that by now this problem has been solved. I am hoping that I can tap into your skills. How did you connect MOSS 2007 to Exchange 2007. I am having problems configuring it. Our MOSS installation is on Windows 2008 and I have Exchange 2007 SP1 installed sin this is the version that works on Windows 2008.

    Thanks
    Thursday, December 18, 2008 9:32 AM
  • Just ran into this issue.  Our environment is Outlook 2007 SP1, Exchange 2003 SP2, WSSv3 SP1 + Infrastructure Update.  User was attempting to connect to a Document Library.

    Any resolution to this, yet?
    Monday, January 12, 2009 6:39 PM
  •  Microsoft provided a work around for this issue.

    If the user has already attempted to connect the library, have them go to Tools -> Accounts -> SharePoint Lists and remove the affected library.

    Instead of using the "Connect to Library" button in an Alert email, have them go to the SharePoint site via a web browser and go to Actions -> Connect to Outlook.  They will then be able to sync the library with Outlook successfully.
    Monday, January 19, 2009 7:09 PM
  • SOLUTION:  I have also been having the same issue. Im using Exchange server 2003 and SharePoint 2007. I have tried the solution on the previous post and the sharepoint list would regenerate and I still would get the error. My work around; I deleted the exchange account on the local machine and added the account all over again. The account works as if the error never existed.

    This was kind of a last resort but worked!

    Hope this works for anyone else.

    Friday, January 23, 2009 2:51 PM
  •  Microsoft provided a work around for this issue.

    If the user has already attempted to connect the library, have them go to Tools -> Accounts -> SharePoint Lists and remove the affected library.

    Instead of using the "Connect to Library" button in an Alert email, have them go to the SharePoint site via a web browser and go to Actions -> Connect to Outlook.  They will then be able to sync the library with Outlook successfully.
    Learning about SharePoint but was getting the error.  Did you have trouble repeating the error at will?  For our installation of SharePoint on a hosted site, I would get the error message once each day - during the first boot up for the day.  Even when shutting down and manually restarting after the first message, the error does not occur again.  It is too early for me to tell if Trevor's recommendation works - however, I followed the instructions above.
    Is the "Connect to Library" button an activeX control or is it something else?  Can that button be overridden so that an IE hyperlink is generated and e-mailed to the target? 
    • Proposed as answer by Mike DePouw Wednesday, June 10, 2009 6:37 PM
    Friday, April 3, 2009 6:07 PM
  • Hey All...

    After a great deal of debugging and tracking down possible solutions to this [and battling with different product groups to determine who should publish a fix], we've altered the behavior of Windows Sharepoint Services to not Base64 Encode the GUID that is being read by outlook in order to sync the Sharepoint lists that these alerts are sent from. We've tested this in environments with Exhange 2003 and Exchange 2007 mailboxes, and in all of our cases, list syncronization within Outlook 2007 worked as designed.

    The fix is included in build 12.0.6504.5000 of Windows Sharepoint Services 3.0. The KB Article associated with this is KB968857, and to the best of my knowledge, this is now included in the April CU that is available for download.

    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=968857&kbln=en-us


    We decided upon a fix in Sharepoint, as it was the best way to correct this behavior [wich was problematic in Exhcange 2003, Exchange 2000, and other MAPI Based Mailbox Servers] across a pervasive spectrum of mailboxes. Outlook/Sharepoint integration behaves differenly when running in MAPI mode vs. Internet Mode. All Internet Mode operations continued to function fine (POP3, IMAP4, etc...) while WSS list syncronization when connected to Non-Exchange 2007 MAPI based servers was problematic.

    If you have any questions, please feel free to contact me, you can easily figure out my email alias from my display name.

    • Proposed as answer by I-16-741018 Tuesday, May 5, 2009 8:50 PM
    Tuesday, May 5, 2009 8:46 PM
  • what about using an smtp server?  i currently work for an isp and we have customers that occasionally call in with the same issue.  but they have the issue connecting to our servers.  it dont matter if its port 587 or 25.  and it can be 1 person getting the unknown error out of maybe 10 people in an office.  so 9 out of 10 people having no problems with exact same email settings.  disabling firewalls, disabling email scanners etc.  mail sits in the outbox and doesnt seem to want to come to our server.  sometimes random things may fix it, like firewalls or antivirus.  sometimes we get stumped and look on google.  which leads me here.  i have gone to several different boards looking for some clues but nothing. 

    i dont know if it helps, but our servers answer on 25 and 587, secure and non secure, but they do require authentication.  by default we set people up as non secure connections but the secure option is there in case they want it.

    This has nothing to do with the problem that Hays33d describes! Mike (moderator), please unflag this as the answer, as it will mislead people that are suffereing from this problem. This has nothing to do with SMTP or SMTP Authentication... All Alerts from Sharepoint are sent via SMTP. The problem is that when Outlook 2007 Clients access their mailbox via MAPI, instead of internet protocols such as IMAP4 or POP3, it is expecting the mailbox server to decode the GUID that it is trying to use to load a COM object in order to facilitate the WSS List Sync.

    The actualy answer is in my post from May 5th, see below...
    Wednesday, May 6, 2009 5:28 PM
  • Please see my post of May 5th...

    Thanks
    Wednesday, May 6, 2009 5:31 PM
  • Jack, Please see my post of May 5th...

    Thanks
    Wednesday, May 6, 2009 5:33 PM
  • Robert, what version of Exchange Server is hosting your mailboxes?

    Please see my post of May 5th...

    Thanks
    Wednesday, May 6, 2009 5:33 PM
  • Trevor, the fix I've developed and linked to will solve the problem that we had reproduced.
    Please see my post of May 5th...

    Thanks
    Wednesday, May 6, 2009 5:34 PM
  • Hey MS-KeithP,

    Thanks, that solved the problem immediately with all new alerts. Alerts sitting in the mailbox from before the fix was installed still don't function, but since the fix was to change Sharepoint's creation of the alert mails, i expected this.

    I've spoken to 6 or more different people at Microsoft and nobody had any idea on how to fix this! You rock!
    Wednesday, May 6, 2009 5:40 PM
  • Hey All...

    After a great deal of debugging and tracking down possible solutions to this [and battling with different product groups to determine who should publish a fix], we've altered the behavior of Windows Sharepoint Services to not Base64 Encode the GUID that is being read by outlook in order to sync the Sharepoint lists that these alerts are sent from. We've tested this in environments with Exhange 2003 and Exchange 2007 mailboxes, and in all of our cases, list syncronization within Outlook 2007 worked as designed.

    The fix is included in build 12.0.6504.5000 of Windows Sharepoint Services 3.0. The KB Article associated with this is KB968857, and to the best of my knowledge, this is now included in the April CU that is available for download.

    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=968857&kbln=en-us


    We decided upon a fix in Sharepoint, as it was the best way to correct this behavior [wich was problematic in Exhcange 2003, Exchange 2000, and other MAPI Based Mailbox Servers] across a pervasive spectrum of mailboxes. Outlook/Sharepoint integration behaves differenly when running in MAPI mode vs. Internet Mode. All Internet Mode operations continued to function fine (POP3, IMAP4, etc...) while WSS list syncronization when connected to Non-Exchange 2007 MAPI based servers was problematic.

    If you have any questions, please feel free to contact me, you can easily figure out my email alias from my display name.


    Wow! Worked great! Thank you so much, this has been a pain point for me for months now!

    And thanks for letting us in the forums know about the solution! Well done!
    • Proposed as answer by Mike DePouw Wednesday, June 10, 2009 6:36 PM
    Wednesday, May 6, 2009 5:42 PM
  • Can you have this KB article updated:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;968484

    The answer is most unhelpful versus the KB fix that you provided.

    Thanks, Keith!
    http://sharepoint.nauplius.net
    Friday, May 8, 2009 4:01 AM
  • Hi, I installed the KB fix, but it still didn't resolve the issue.  I'm not sure what I did wrong.  Can you help?

    MOSS 2007 > Exchange 2003 Standard > SQL 2005 > Outlook 2007 SP1
    Friday, May 15, 2009 4:01 PM
  • When I read the "answer" I don't see an answer, am I missing something?  If not why is that marked as the answer?
    Regards, Mike DePouw
    Tuesday, June 9, 2009 1:37 AM
  • I hotfix did not resolve our problem.

    The workaround via going into SP and clicking on Connect to Outlook is working though.
    Regards, Mike DePouw
    Wednesday, June 10, 2009 6:38 PM
  • Is there a fix that is for MOSS instead of WSS?  I have MOSS & have the same issue.
    Thursday, June 25, 2009 1:08 PM
  • MOSS sits on top of WSS.  You need to be applying both MOSS and WSS patches when they're released (typically WSS first, MOSS second).
    http://sharepoint.nauplius.net
    Thursday, June 25, 2009 1:41 PM